Results 1 to 7 of 7

Thread: modem Connects but no internet

  1. #1
    Junior Member registered user
    Join Date
    May 2003
    Posts
    13

    modem Connects but no internet

    Hi,
    after a very long search and fix for my modem, i was able to get it to work .... now it dials fines and connects and the timer starts normally .... however trying to open any browsers it just doesnt open any page !! anyone has an idea ....???

    another question , if i dont want to keep filling the password for root, is there a way to autologin .... ???


    thanks

    Mahdi

  2. #2
    Senior Member registered user
    Join Date
    May 2003
    Posts
    981
    Which browser? I had a similar problem with Mozilla. After getting the Winmodem working via ltmodem, I configued the modem using KPPP so that it would dialup ok but Mozilla also has to be configured to my ISP username & password. It defaults to use the email address name for the username which is not correct so I had to reconfiguer it separately to the proper username.
    I don't think there is any way to autologin as root but ther may be a way to autologin as 'user' i.e. as Knoppix. Maybe more experienced people will correct me on this.
    You are not really supposed to be 'root' all the time anyway. It is more secure to login as a 'user' & su to root if you have to. Or use 'sudo'. Knoppix-on-HD by default doesn't allow any sudoers by default so you will have to edit the /etc/sudoers file to allow you as user (default 'Knoppix') to be a sudoer. I don't know why but there are a number of quirky little differencence like this between Knoppix-on-CD & Knoppix-onHD.

  3. #3
    Junior Member registered user
    Join Date
    May 2003
    Posts
    13
    thanks for replying ....

    I was trying to find where Mozilla is configured but I dont know where !!!

    Please help me ....



    Thanks


    Mahdi

  4. #4
    Junior Member
    Join Date
    May 2003
    Location
    Azzate-Varese (Italy)
    Posts
    9
    Hi Mahdi and Crash...
    I have exatly the same problem as (after HD installation only) modem dials in and I can ping the ISP no problem but no internet.
    Please have a look at my other posts and give me your comments aand/or suggestions if you found a workaround

    pieter

  5. #5
    Junior Member
    Join Date
    Sep 2003
    Posts
    2

    modem Connects but no internet

    Hi all, I have the same problem months later. Did you ever resolve this one?

    I have found that I can log in as root and surf but not as any other user. I expect I don't have permissions. Where would I set them?

    Rich

  6. #6
    Junior Member
    Join Date
    Sep 2003
    Posts
    1
    I had the same problem and resolved it by removing/commenting out the Gateway line in /etc/network/interfaces.

    Hope this helps.

  7. #7
    Junior Member
    Join Date
    Sep 2003
    Posts
    2
    Why thank you. As it turns out my problem was with nameservers. I later found that I could connect to the Internet and download webpages as root but not as a normal user. When I looked at the Kppp settings side by side, on the DNS tab, I had 'Automatic' selected for root but not for my normal user. Once I selected Automatic DNS for my normal user, the problem was solved.

    Thanks again for your help.

    Richard

Similar Threads

  1. Connecting to the Internet via USB ADSL modem (again...)
    By HornyToad in forum General Support
    Replies: 2
    Last Post: 08-26-2005, 09:40 PM
  2. Kppp connects but cannot access internet
    By dsg68818 in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 12-06-2004, 04:52 PM
  3. Modem connects, but I still can't surf the net
    By WolfBLN in forum Networking
    Replies: 2
    Last Post: 05-11-2004, 06:25 AM
  4. Internet not working with cable modem
    By kibkid in forum Networking
    Replies: 5
    Last Post: 05-04-2004, 01:41 PM
  5. Replies: 7
    Last Post: 10-07-2003, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •