Results 1 to 4 of 4

Thread: KNX 5.1.1 wont boot with Broadcom 4306 WLAN...

  1. #1
    Member registered user
    Join Date
    Jun 2005

    KNX 5.1.1 wont boot with Broadcom 4306 WLAN...

    ...booting from the CD-version i can see the Kernel-messages up to configuration of network interfaces. eth0 (internal LAN) config is being backgrounded, on configuration of eth1 (broadcom) Knoppix gets stuck - nothing else happens.

    My system can boot with older Knoppix-version 5.0.1. Its an IBM Thinkpad T40 with mini-PCI wlan device described above.


    Update 1:
    I have wlan up and running on 2006-01-RC4 of Kanotix using ndiswrapper. Maybe the kernelmodule bcm43xx is the problem here in Knoppix? Here is the output line from lspci:
    02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

    Update 2:
    "expert" kernel wont boot either. Network drivers are loaded automatically.
    I found out that there is a cheatcode to disable dhcp at least, and this one helps on booting! --> knoppix nodhcp
    But, when i try to load ndiswrapper module (after unloading bcm43xx) the whole system freezes!
    Remember: Kanotix (Kernel 2.6.18 ) works this way with ndiswrapper and i have a connection. And Kanotix does also load bcm43xx kernelmodule first, which has to be unloaded for ndiswrapper.

  2. #2
    Junior Member
    Join Date
    Feb 2007

    Broadcomm and New HP Laptop! Resolved!

    I will go over the steps I've gathered together from various websites which I used to get my Broadcomm Wireless running
    on my brand new HP laptop I just bought this month! I'm just trilled to be using it and want to thank everybody out
    there who helped to make this possible, you all did a great job.

    Let me go back in history a little. I was one of the first people to get a SB/Live card and I can remember it took
    them 3/4 months to get the driver working for that thing on my desktop at home and we hade the driver working before
    they officially did with Windows! So, for this community to get the wrapper for Broadcomm working this quickly, I'm
    impressed. I just bought this portable 1 month ago.

    The Kernel Driver BCM43XX is not working for all Broadcomm cards right now so we will de-activate it.
    I'm using Knoppix 5.1.1. which I've installed to the Hard drive using the 'recommened' debian install.
    Nothing fancy here. But if your practicing you can follow along these steps with your DVD version of
    KNOPPIX 5.1.1 running from the DVD. You don't have to install it to a hard drive to test this
    out if you don't want to. Practice from the DVD if you want to. I've already wiped out Windows XP
    as Knoppix 5.1.1 has the entire HP portable supported now. There's nothing left.

    As root, go into /etc/modprobe.d and add this line to blacklist file.
    blacklist bcm43xx

    Next, we go to /etc and add to modules file

    Run rmmod bcm43xx to make sure she's gone from memory.

    Next we have to find YOUR bcmwl5.inf file from your windows installation.
    On my HP it was in the top directory of Windows XP as \SWSetup under another folder \WLAN

    I found out that my .inf file and maybe yours was a 4.x series .inf file and didn't work with the current fwcutter routine
    mentioned on debian. And ndiswrapper with the new kernel on Knoppix 5.1.1 was the only one which would actuall load/wrap this
    windows driver properly as this is very brand new stuff! The newest Ubuntu I have has the .17 kernel and an older NDISWRAPPER
    and it doesn't work with the 4.x drivers at all. Ubuntu is a few months behind KNOPPIX on internals.

    So, from inside my running knoppix install, I mount Windows XP to /media/whatever and go into that directory with my
    bcmwl5.inf file, and I load it into the system with ndiswrapper -i bcmwl5.inf. There may be some switching messages
    pop up when you do this. Ignore them for now. Next run ndiswrapper -l to see if it got installed okay.

    root@roam ndiswrapper -l
    bcmwl5 : driver installed
    device (14E4:4311) present

    It will say something like this. BTW, \windows\system32\drivers is another place you might find your .inf file and I think that's where it should be installed in Windows to run the card from Windows XP.

    It's at this point we can do some snooping.

    iwlist WLAN0 scan
    root@roam iwlist wlan0 scan

    wlan0 Scan completed :
    Cell 01 - Address: 00:20:A6:50:7B:71
    Protocol:IEEE 802.11b
    Frequency:2.412 GHz (Channel 1)
    Quality:51/100 Signal level:-63 dBm Noise level:-96 dBm
    Encryption keyff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
    Cell 02 - Address: 00:20:A6:506:CC
    Protocol:IEEE 802.11b
    Frequency:2.462 GHz (Channel 11)
    Quality:18/100 Signal level:-84 dBm Noise level:-96 dBm
    Encryption keyff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
    Cell 03 - Address: 00:20:A6:50:7B:9C
    Protocol:IEEE 802.11b
    Frequency:2.457 GHz (Channel 10)
    Quality:6/100 Signal level:-92 dBm Noise level:-96 dBm
    Encryption keyff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s

    iwconfig wlan0 essid SIRICOMM

    Or use what ever wifi configuration you need there to access your local service.
    and then

    ifup wlan0

    This will get the interface up and get your lease via dhcp.

    I'm currently upgrading my hard drive install to Debian stable/testing with security.
    Everything is working great and I want to thank you all again for a job well done.

    You might ask, why am I using Knoppix to install Debian to this new portable considering
    I had no networking going???? Well, the Debian DVD for Sarge didn't handle the Broadcomm
    WIFI either and it also didn't handle USB drives. See, just about all these new portables
    have a USB drive where HDA used to be. And so, when you run the Debian DVD's (2) to install
    Sarge on your new laptop you find out it can't see ANY drives as they are all USB!

    So Knoppix 5.1.1 does and it has that knx2hd install routine you can run as root and select
    the recommended debian install from and it works just fine. After editing the /etc/apt/sources.list
    file, and running an apt-get you get a good system.

  3. #3
    Junior Member
    Join Date
    Feb 2007
    I wanted to add that after you do your ndiswrapper -l command,
    you can run these

    ndiswrapper -m
    ndiswrapper -ma
    ndiswrapper -mi

    Just now noticed another threat mentioning these three and thought I woudl throw that in too.

  4. #4
    Member registered user
    Join Date
    Jun 2005
    ACK to kd5ob.

    I have KNX 5.1.1 (cd -> HD install / debian) running with my BCM 4306 for a couple of days now, with ndiswrapper. I have a reliable 54Mbit link.

    But, my Thinkpad T40 doesn't suspend (to ram) properly here. A T40 should be able to do that with Linux, so i guess it has something to do with this Broadcom card and/or its driver. It does suspend with WinXP without problems. It does enter suspend in Knoppix, but on wakeup there sometimes are graphics errors, sometimes screen keeps being black - and everytime system freezes. I have tried to suspend with ndiswrapper module undoaded, and with X deactivated - no success.

    Today i did some testing with my older Knoppix 5.0.1 CD (running from CD) - and ... whoa! After installing the bcm43xx-fwcutter package and using this tool (by the way: it worksn't on my windows driver, telling me something about "unknown MD5sum" - it looks like this tool doesnt know my bcmwl5 driver. I think i will try to contact the driver guys in the next days. It worked with some other bcm4306 driver from somewhere in the outer limits of the internet... ) and putting the .fw files in the right place (/lib/firmware) the driver loaded, leaving some positive messages in the syslog! I tried a dhcp-broadcast using wlcardconfig and netcardconfig - this one was unsuccessful. But after setting ip stuff manually with netcardconfig - card's working !! But for some reason (maybe this is the driver's fault, i have to RTFM a little bit more...) maximum speed is at 11Mbit/s. (FTP download with large files speeds at 1+MIB/s maximum - this also looks like 11Mbit/s.)


Similar Threads

  1. pcmcia broadcom 4306
    By luface2000 in forum Hardware & Booting
    Replies: 0
    Last Post: 11-05-2009, 07:27 PM
  2. NDISWrapper+Broadcom-4306 Not Working [Properly]
    By mr-roboto in forum Networking
    Replies: 1
    Last Post: 04-24-2007, 04:00 PM
  3. Replies: 1
    Last Post: 06-04-2006, 06:46 PM
  4. HP Pavilion ze4904us (Broadcom 4306 chip) & WPC54G
    By Blackbomb in forum Networking
    Replies: 1
    Last Post: 10-27-2005, 04:08 PM
  5. pcmcia wlan card wont recognize on boot...
    By gotsanity in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 12-01-2004, 07:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts