Results 1 to 8 of 8

Thread: Getting Knoppix to BOOT from the HD....

  1. #1
    BioStitch
    Guest

    Getting Knoppix to BOOT from the HD....

    I can't seem to get Linux to boot....
    ...at all.
    Brand new HD, nothing on it at all, nor has there ever been.
    I tried LiLo and Grub to no avail.
    I've tried Gentoo and Knoppix both SEEM to install fine... but after removing the boot/liveCD, the computer won't boot from the HD...

    [I seem to have no troubble in installing Knoppix using
    knx-hdinstall
    and I think I only need two partitions one root and one swap...?]

    My goal here is to run Knoppix from my HD, I have no problem booting from CD and running it. but booting from the HD just dosn't work, I get a:
    "Disk boot error, insert system disk and press enter" when I start up without the CD in.
    I have to boot order set up correctly in the BIOS (I've tried switching the order too)
    1st CDROM
    2nd HDD-0

    I can save files to the HD and read files saved on it. I'm sure the HD works, and it's not a mechanical prob. Like I said, Knoppix SEEMS to install fine, all the correct files are there and what not. IT JUST WON"T BOOT!!!

    I'm thinking maybe something about the MBR is off? or I need to zero out part of the disk?
    (It's got to be something fundamentally simple that I just don't have adjusted correctly I think...?)
    I'm very new to Linux and have very few ideas as to what to do.
    I'm open to any any all suggestions, just fire away, I need more stuff to try.
    Thanks!!!
    [/u]

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    Did you run cfdisk and set up a primary linux bootable partition (82?)as well as a linux swap partition (83) and rewrite this info?

    Good luck,

  3. #3
    Guest
    Yes
    Tried that.
    LiLo still won't load.....

    How do I write to or just erase the MBR?

  4. #4
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    I had a problem with them MBR whereby I couldn't boot WIN95 anymore after a knx-hdinstall. What I did was get a Windoze rescue disk and run fdisk /mbr.

    I hope that helps you too!

  5. #5
    Junior Member
    Join Date
    Jan 2003
    Location
    London, UK
    Posts
    3
    Hi all,

    Just installed KPX 3.1 on my PIII550/512MB box and all works fine, apart from not being able to boot from the hdd that is ;(

    I've got a swap, root and a fat32 shared partition. All I get is 99... and then it stops. The only way to boot from hdd is with the floopy.

    PS: The root partition was selected as bootable.

    Any pointers? MTIA

    Axel

  6. #6
    Junior Member
    Join Date
    Nov 2003
    Posts
    3
    Also have the same problem. There are some complications too (newbie, so bear with me):

    1) Laptop
    2) No floppy, forget booting from one
    3) Booting from CD-ROM doesn't work with all CDs. Some windoze cds don't work. Knoppix CD boots ok.
    4) knx-hdinstall runs ok, if knoppix booted in cmd line. During install cfdisk creates partitions in /dev/hdb. Only one HD. Dunno what happened to /dev/hda. Tried going with and without LILO.
    5) When trying to boot from HD, after successful knx-hdinstall, bios does not find it.
    6) Managed to boot DOS from a rescue CD and run fdisk /mbr. It said there were no HDs.

    Bottom line: mbr is totally screwed up. I need to find a way to fix it from knoppix CD.

    Help appreciated.

  7. #7
    Junior Member
    Join Date
    Nov 2003
    Posts
    3
    New developments.

    I've noticed that lilo.conf had:
    boot = /dev/hda

    There's no hda in this system, so I tried to fix it with:
    (edited lilo.conf to have 'boot=/dev/hdb1' instead of above)
    su
    mount /dev/hdb1 /mnt/hdb1
    chroot /mnt/hdb1
    lilo -v

    The following warnings show up:
    '/proc/partitions' does not exist. disk scan bypassed
    /dev/hdb1 is not on the first disk

    Still, I rebooted and got the "non system disk" error.

  8. #8
    Junior Member
    Join Date
    Nov 2003
    Posts
    3
    Again, the problem was not on the wood but on the carpenter.

    Hd was on slave. I made back ups and forgot to set it as master again.

Similar Threads

  1. installed kanotix to hdb, lost boot option to boot knoppix
    By helios17 in forum General Support
    Replies: 7
    Last Post: 11-27-2004, 06:27 AM
  2. How can I boot Knoppix using windows boot loader?
    By J.A.X in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 01-30-2004, 02:52 AM
  3. using knoppix on multi-boot CD's (boot scriptor)
    By ebone in forum Customising & Remastering
    Replies: 4
    Last Post: 05-16-2003, 02:26 AM
  4. Remastering Error: Can't Find Boot Image KNOPPIX/boot.img
    By mswarbrick in forum Customising & Remastering
    Replies: 6
    Last Post: 04-18-2003, 12:30 AM
  5. Boot knoppix withough Floppy and CD boot
    By Dan_Netwalker in forum Hdd Install / Debian / Apt
    Replies: 7
    Last Post: 02-23-2003, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •