Results 1 to 4 of 4

Thread: Radeon7200/glxgears=3000+ fps/how am I doing?

  1. #1
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933

    Radeon7200/glxgears=3000+ fps/how am I doing?

    I installed a new Radeon 7200 w/ 64M. Booted the Knoppix 3-30. It detected the card beautifully. Ran glxgears- a constant 850-900 fps. Edited a few lines of the hdd install to match the ramdisk XF86Config-4. Booted the hdd install- went great. Look at this!!

    $ glxgears -info
    GL_RENDERER = Mesa DRI Radeon 20020611 AGP 1x x86/MMX/3DNow! TCL
    GL_VERSION = 1.2 Mesa 4.0.4
    GL_VENDOR = Tungsten Graphics, Inc.
    GL_EXTENSIONS = GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_convolution GL_EXT_compiled_vertex_array GL_EXT_histogram GL_EXT_packed_pixels GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_texture3D GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_object GL_EXT_texture_lod_bias GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_MESA_window_pos GL_NV_blend_square GL_NV_texgen_reflection GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp
    2390 frames in 5.0 seconds = 478.000 FPS
    2440 frames in 5.0 seconds = 488.000 FPS
    15463 frames in 5.0 seconds = 3092.600 FPS
    16777 frames in 5.0 seconds = 3355.400 FPS
    16887 frames in 5.0 seconds = 3377.400 FPS
    17053 frames in 5.0 seconds = 3410.600 FPS
    17093 frames in 5.0 seconds = 3418.600 FPS

    I'm loving it, especially after using a Savage w/ 8M video ram!
    I suppose I'm just wondering what the rest of you are getting for frame rates. Notice that my old mobo is only AGP 1x w/ 256M RAM.

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    After some experimenting I have come to realize that everything wasn't exactly as it seemed. To get the 3000+ fps my cpu was maxed out. Now it doesn't want to climb above 490 fps using <16% cpu and <2% system RAM. Here's where it get weird:
    Booting the Knoppix 3-30 cd I get 1032-1041 fps using 33% cpu and <2% system RAM. (BTW-That's just the RAM that glxgears uses).

    $ glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    client glx vendor string: SGI
    client glx version string: 1.2
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    OpenGL vendor string: Tungsten Graphics, Inc.
    OpenGL renderer string: Mesa DRI Radeon 20020611 AGP 1x x86/MMX/3DNow! TCL
    OpenGL version string: 1.2 Mesa 4.0.4
    OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_convolution, GL_EXT_compiled_vertex_array,
    GL_EXT_histogram, GL_EXT_packed_pixels, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color, GL_EXT_texture3D,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_object, GL_EXT_texture_lod_bias, GL_EXT_vertex_array,
    GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat, GL_MESA_window_pos,
    GL_NV_blend_square, GL_NV_texgen_reflection, GL_SGI_color_matrix,
    GL_SGI_color_table, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc 0 24 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
    0x24 24 tc 0 24 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x25 24 tc 0 24 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
    0x26 24 tc 0 24 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    0x27 24 tc 0 24 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
    0x28 24 tc 0 24 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x29 24 tc 0 24 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
    0x2a 24 tc 0 24 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    0x2b 24 dc 0 24 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
    0x2c 24 dc 0 24 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x2d 24 dc 0 24 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
    0x2e 24 dc 0 24 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    0x2f 24 dc 0 24 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
    0x30 24 dc 0 24 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x31 24 dc 0 24 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
    0x32 24 dc 0 24 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

    Here's the DRI docs for glxinfo:

    OpenGL vendor string: VA Linux Systems, Inc.
    OpenGL renderer string: Mesa DRI Voodoo3 20000224
    OpenGL version string: 1.2 Mesa 3.4

    or this:

    OpenGL vendor string: VA Linux Systems, Inc.
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 Mesa 3.4
    Notice that my glxinfo doesn't jive too completely- using Tungsten Graphics instead of VA Linux systems.

    I can't install the latest drivers - it fails creating modules because of our custom Knoppix kernel- of course a new kernel will fix this so I suppose that's next unless someone has a better idea.

    I am under the impression that there are some parameters that may be set during compile/install- specifically page flipping which is supposed to be quite the performance tweak. Also I need to switch from AGP1x to AGP 2x. Still working it..........

    almost forgot

    I cannot make the radeon xserver work.

  3. #3
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Well it's all working now after an install of overclockix technomancer. Both Knoppix and Morphix had DRI working from cd but it went away after hdd install. Additionally APM stoped working with the 3.2 release. It's great to have it all back.

  4. #4
    Senior Member registered user
    Join Date
    Jun 2003
    Posts
    611


    Glad overclockix works for ya.

    Just so you know, I didn't do anything special to the iso for radeon drivers or xfree. I therefore suspect Knoppix 3.2 06-06 might also work with similar results.

Similar Threads

  1. Simcity 3000 unlimited on Linux
    By Seyyapc in forum Games
    Replies: 0
    Last Post: 02-26-2005, 04:04 AM
  2. Knoppix 3.7 and Canon BJC-3000 - no printing at all
    By waterproof in forum General Support
    Replies: 0
    Last Post: 12-22-2004, 07:03 PM
  3. logitech quick cam pro 3000 connected via USB
    By bmike1 in forum Hardware & Booting
    Replies: 3
    Last Post: 12-02-2003, 02:13 PM
  4. fonts and glxgears??
    By klimg in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 11-23-2003, 02:42 PM
  5. Dell Inspiron 3000 - knoppix - oddness
    By Trance in forum Laptops
    Replies: 0
    Last Post: 08-08-2003, 07:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •