Results 1 to 5 of 5

Thread: Knoppix 5.3.1 invisible mouse cursor

  1. #1
    Junior Member
    Join Date
    Feb 2009
    Posts
    3

    Knoppix 5.3.1 invisible mouse cursor

    Hi,
    I'm new to Knoppix and Linux in general. I've looked for an answer to this problem here and on other forums and FAQs. Other people seem to have the same sort of problem but the few suggestions that were given haven't worked for me.

    I'm booting 5.3.1 from DVD. Checksum verified it ok.
    It boots fine but I can't see the mouse cursor. I've tried a Memorex ScrollPro 4-button+wheel mouse (wire, optical, USB) and a logitech 2-button+wheel mouse (wire, ball, PS/2). When both are plugged in, the KDE dies (having both plugged in with WinXP was not a problem). When either one is used singly, everything seems to work but the mouse cursor is not visible. I have been rebooting after changing mice to allow hardware detection. The cursor effect is there and useable, just not visible. I can open and select things by guessing the cursor location from the highlighting.

    I've tried cheatcode "knoppix wheelmouse" and various settings in the control panel>peripherals>mouse options with no luck.
    Someone suggested "Ctrl-Alt-F2, modprobe -r usbmouse, modprobe hid, Ctrl-Alt-F5" but that wasn't recognized.

    I'm booting the DVD from a DVD ROM on a Dell Dimension 8400, Pentium4 630+HT, 1GB DDR2 SDRAM, 256MB NVidia GeForce 6800 with lots of HD space (WinXP when not booting from Knoppix disk). Someone mentioned that NVidia cards and Knoppix may not work well together.

    Any suggestions that are noobie compatible would be appreciated.
    Thanks!

  2. #2
    Senior Member registered user
    Join Date
    Jan 2005
    Location
    UK
    Posts
    282
    You've answered your own question, just use one mouse.
    Why do you need two mouses?
    Unix/linux uses a third mouse button in general, so your logitech 2button + wheel will work fine. No applications are set to use 4 mouse buttons so put that mouse in a drawer and forgot about it. Unless you're going to be drawing, all mouse commands can be done with the keyboard anyway.

  3. #3
    Junior Member
    Join Date
    Feb 2009
    Posts
    3
    I am only using one mouse.
    I just mentioned that having both mice plugged in killed the KDE even though it was fine for WinXP, so I haven't been doing that.
    The Logitech 2-button with wheel does not work. If either mouse worked alone, that would be fine for me.
    I will need it for the usual applications which include some drawing so I would rather give up on this distro than use it in a very limited manner (such as number pad only rather than a mouse.)
    The four-button+w mouse has been my main one for three years with no compatibility problems with WinXP but it isn't a necessity.
    I pulled out the logitech 2-button+w to use instead if the other was a problem with Knoppix, but it has the same problem of no visible cursor.

    Thanks for trying to help.

    Edit: Could the problem have something to do with the NVidia card, or is that unlikely? Has anyone else had an invisible cursor with a standard logitec wheelmouse and found a way to fix it?

  4. #4
    Junior Member
    Join Date
    Feb 2009
    Posts
    3
    I've now tried a third mouse: Kensington Pocketmouse Pro (2-button, USB, wheel, optical) and still no cursor.

    When booting, I get these lines:
    (for the Logitech) Mouse is ImPS/2 Logitech wheel mouse at /dev/input/mice
    (for the Kensington) Mouse is unknown device 047d:101f at /dev/input/mice
    (for the Memorex) Mouse is DSC Communications Unknown Device 1166 at /dev/input/mice
    The Logitech mouse at least should work but the cursor remains invisible no matter what I try.

    I've tested all three mice with and without the "knoppix wheel mouse" cheat code.
    I tried the Logitech PS/2 with no USB ports in use at the same time since someone mentioned there might be a conflict.
    Rebooting was done each time with the mouse to be checked already attached but I also tried hot swapping.
    Somehow, I doubt that trying other mice will make any difference. There has to be something else going on.
    I put the same Knoppix DVD in a laptop and it gave a normal cursor that was controllable by the touchpad.
    Looks like the DVD is ok.
    Any ideas on something else to try?

  5. #5
    Junior Member
    Join Date
    Mar 2009
    Location
    Minny-soda
    Posts
    4
    Never saw this exact issue, but saw something similar.....oddly enough, a BIOS update fixed it. There was some USB compatibility bug with the installed BIOS version--the fix for the bug was to flash the BIOS to the current version and all was well.

    Can't say this would help you, but it might be worth a look to see what your BIOS version is and to see what updates are available for it.

Similar Threads

  1. Mouse cursor invisible
    By fixon in forum Hardware & Booting
    Replies: 1
    Last Post: 10-12-2007, 02:34 AM
  2. 5.1.1 Invisible Mouse Cursor with nv Nvidia driver on LiveCD
    By bricedue in forum Hardware & Booting
    Replies: 2
    Last Post: 01-18-2007, 04:06 PM
  3. Garbled Mouse Cursor with Knoppix 5.1.1
    By zephyr200200 in forum General Support
    Replies: 0
    Last Post: 01-13-2007, 03:02 AM
  4. mouse cursor size
    By turbine in forum General Support
    Replies: 3
    Last Post: 06-14-2004, 10:41 AM
  5. Mouse Cursor
    By kvihijar in forum General Support
    Replies: 4
    Last Post: 07-04-2003, 10:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •