Results 1 to 4 of 4

Thread: Knoppix 6.2 Hard Drive install – Setting your desktop cloc

  1. #1
    Member registered user
    Join Date
    Apr 2009
    Location
    Christchurch, New Zealand
    Posts
    34

    Knoppix 6.2 Hard Drive install – Setting your desktop cloc

    By default my hd install of Knoppix 6.2 always sets the system clock to the wrong time (for NZ) and the time zone setting defaults to <America/NewYork>.

    you can change Knoppix to your time-zone with the following command run as root

    <dpkg-reconfigure tzdata>

    and then choosing from the lists that come up, first your general area, e.g. <Pacific> and then appropriate city e.g. <Auckland> BUT this will be lost and reset to <America/NewYork> each time you re-boot [at least mine was]

    Once you're in your correct time-zone you can then set the correct system clock time by running the command:
    <date 120310422009> [that's for 10:42 on 3rd December 2009]

    but again it will all be lost when you reboot and all needs to be done over again – and you need to have an accurate clock available to reset it from

    SO

    Is there a long term solution?
    For the Time Zone problem - Find your time-zone [in the right format] from /usr/share/zoneinfo/####/#### - in my case <Pacific/Auckland> and then go to your editor [as root] and open /etc/init.d/knoppix-autoconfig and change line 357 from <KTZ="$(getbootparam tz)"> to <KTZ='Pacific/Auckland'> or whatever your own zone is. This will get you into the right time-zone each time you boot but will still not get the correct system time

    For the correct time problem - I've installed the small debian package ntpdate - add your closest <####.pool.ntp.org> ntp servers to the appropriate lines of /etc/default/ntpdate – and that's it – if you're automatically connected to the net when you boot up then ntpdate will run at boot and set your system clock to the correct time and if not when you do connect to the net it will run soon after and correct the time you see in the bottom right hand corner of the screen. If all else fails you can run the command [as root]
    <ntpdate nz.pool.ntp.org> [changing <nz> to whatever your nearest area pool server is] or I suppose you could write a simple script to run this command at boot time.

    Has anyone found a simpler or more elegant solutions to this problem with Knoppix 6.2 as a hard drive install? I never had this problem with Knoppix 6.01 as a hard drive install.

    It's a great distro but it's good to have the right time too.

    Best wishes, John

    PS - 02 Mar 2010 - If you have the dvd version as hard drive install you can go (as root in a terminal) to <time-admin> and change what you need to there - much more easily.

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    2

    Re: Knoppix 6.2 Hard Drive install – Setting your desktop

    Quote Originally Posted by johnmd
    By default my hd install of Knoppix 6.2 always sets the system clock to the wrong time (for NZ) and the time zone setting defaults to <America/NewYork>.

    you can change Knoppix to your time-zone with the following command run as root

    <dpkg-reconfigure tzdata>

    and then choosing from the lists that come up, first your general area, e.g. <Pacific> and then appropriate city e.g. <Auckland> BUT this will be lost and reset to <America/NewYork> each time you re-boot [at least mine was]

    Once you're in your correct time-zone you can then set the correct system clock time by running the command:
    <date 120310422009> [that's for 10:42 on 3rd December 2009]

    but again it will all be lost when you reboot and all needs to be done over again – and you need to have an accurate clock available to reset it from

    SO

    Is there a long term solution?
    For the Time Zone problem - Find your time-zone [in the right format] from /usr/share/zoneinfo/####/#### - in my case <Pacific/Auckland> and then go to your editor [as root] and open /etc/init.d/knoppix-autoconfig and change line 357 from <KTZ="$(getbootparam tz)"> to <KTZ='Pacific/Auckland'> or whatever your own zone is. This will get you into the right time-zone each time you boot but will still not get the correct system time

    For the correct time problem - I've installed the small debian package ntpdate - add your closest <####.pool.ntp.org> ntp servers to the appropriate lines of /etc/default/ntpdate – and that's it – if you're automatically connected to the net when you boot up then ntpdate will run at boot and set your system clock to the correct time and if not when you do connect to the net it will run soon after and correct the time you see in the bottom right hand corner of the screen. If all else fails you can run the command [as root]
    <ntpdate nz.pool.ntp.org> [changing <nz> to whatever your nearest area pool server is] or I suppose you could write a simple script to run this command at boot time.

    Has anyone found a simpler or more elegant solutions to this problem with Knoppix 6.2 as a hard drive install? I never had this problem with Knoppix 6.01 as a hard drive install.

    It's a great distro but it's good to have the right time too.

    Best wishes, John


    THANK YOU SOOOOOOOOOOOOO VERY MUCH!!!

  3. #3
    Quote Originally Posted by johnmd View Post

    PS - 02 Mar 2010 - If you have the dvd version as hard drive install you can go (as root in a terminal) to <time-admin> and change what you need to there - much more easily.
    Thanks so much, that was the best solution of all...

  4. #4
    Senior Member registered user
    Join Date
    Nov 2003
    Posts
    203
    I like to keep my system clock and my hardware clock set to local time.

    After fiddling with ntpdate and trying to understand all of the intricate and confusing linux time settings, I took total control of the situation with the following script that I run at each bootup and via a cron job every day at 6:30 am.
    #!/bin/bash

    #To get a list of server names and ip addresses, go to
    # http://www.nist.gov/pml/div688/grp40/its.cfm

    #Get the time from an internet time server
    hhmmss=$(rdate -p -4 -u time-a.nist.gov | tr -s " " | cut -d' ' -f4)

    #hhmmss is now a time field of the form hh:mm:ss in utc format

    utchour=$(echo $hhmmss | cut -d':' -f1)
    minute=$(echo $hhmmss | cut -d':' -f2)
    second=$(echo $hhmmss | cut -d':' -f3)

    #for my timezone, my offset from utc is 5 hours
    OFFSET=5

    #To convert the hours to local time
    hour=$(( $(($utchour+24-$OFFSET)) % 24 ))

    thetime="$hour:$minute:$second"
    echo $thetime

    #set the system time to thetime
    sudo date -s $thetime

    #set the hardware clock to the system time
    sudo hwclock --systohc

    date > /home/knoppix/date.log

Similar Threads

  1. Hard drive no longer shows on desktop
    By Kirk-out in forum Hardware & Booting
    Replies: 2
    Last Post: 08-06-2008, 07:25 PM
  2. I cannot see Windows hard drive on Knoppix desktop
    By Crimpshrine in forum MS Windows & New to Linux
    Replies: 13
    Last Post: 08-23-2006, 12:28 PM
  3. Questions on setting up a Persistant Hard drive image
    By slvrldy17 in forum MS Windows & New to Linux
    Replies: 2
    Last Post: 02-23-2006, 04:06 AM
  4. Desktop hard drive icons?
    By maxmartin in forum Customising & Remastering
    Replies: 4
    Last Post: 02-19-2006, 06:09 PM
  5. desktop full of hard drive icons
    By Lion in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 05-13-2005, 10:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •