This is what happened and where I am - ie, desperate!! (Knoppix Newbie)
1. Acer without CD drive was infected with virus which caused BSOD.
2. Loaded Knoppix to flash drive.
3. Acer's internal drive with 2 partitions (hidden recovery partition and with crashed Windows XP partition)would not mount
4. Copied (mirror image - using dd command) Acer internal drive with both partitions to external drive (which I still have set aside)
5. Tried the following (as one last ditch effort before restoring to factory default settings): used Knoppix to fix NTFS partition on Acer drive:
From root terminal as administrator: NTFSFIX /dev/sda2
6. This failed twice with IO errors
7. Decided to give up and restore to factory default settings
8. Launched Acer's recovery partition
9. It worked - until about 85% done.
10. Aborted and went to BSOD (blue screen)
11. Now get NTLDR missing - can no longer launch recovery partition - but ACER internal drive now mounts in KNOPPIX (though it is corrupted)
12. Still cannot launch old windows partition. AND now cannot launch recovery partition. Please help. I am desperate.
Corrupted recovery partition is sda1 - and is not NTFS, but FAT. Am afraid NTFSFIX command corrupted recovery partition? Maybe it was already corrupted?
Believe hard drive is physically ok; just logically corrupted.
Can I, should I copy hidden FAT partition from backup drive to sda1? If so, how?
Other suggestions?