Results 1 to 4 of 4

Thread: How to upgrade VirtualBox OSE to Puel (or share files with Windows guests)

  1. #1
    Junior Member
    Join Date
    Apr 2010

    How to upgrade VirtualBox OSE to Puel (or share files with Windows guests)


    I have been getting used to using this software and it is great! I have V6.2 Knoppix and am running it on a small laptop with an Atom processor without problems. So what is wrong? I am using Vbox and need file sharing with the Linux host which is not possible using OSE. I set up a bridged network and a Windows file share that is accessible from both Windows and the host, but I cannot write to it from the host -- Only from Windows. I got to a point where it seemed everything (except file sharing) was working and tried to install the PUEL version on top of the OSE version because I did not want to risk uninstalling it as it seems that perhaps it is being used by Knoppix (and I did not want to break Knoppix). I instead broke VBox and had to reinstall Knoppix to my USB (which is another story!) and start from scratch in any case. I have been working for two days now trying to get this share to work both ways and as an alternative to reinstalling VBox, guidance on that could also be helpful if upgrading is not an option!

    Thanks in advance for any advice, Robert!

  2. #2
    Moderator Moderator
    Join Date
    Jan 2010
    Asheville, NC, USA
    I use Knoppix on a Flash with a "shared drive" approach - Knoppix looks like a couple of large files taking up room (no Vbox needed) but I'm only using Windows as an alternative that my wife knows better than Linux and sharing files for a later boot to Knoppix. Are you running Windows within the Virtual environment, I assume? If you'd like to share your virtual machine, I could try running it and see what I can do.


  3. #3
    Junior Member
    Join Date
    Apr 2010
    H Krishna,

    Thanks for replying! I am also using the thumb drive approach to run Knoppix which leaves the system"untouched" with Windows 7 installed and usable (should it be needed). I need the Windows share because all my customers run Windows applications and I need to try things in a windows environment so Wine won't work. Last night, I tried something because I know this is "simply" a permissions problem: I switched to the terminal emulator and tried to create a file in my share (cat /dev/null >> testfile) as myself and then again as root. Only the attempts as root worked, which is what I suspected. The problem I have is that even after changing the group and user ID as well as permissions for the folder, as soon as I mount the share into the folder, the owner and group change to root! If I can figure out how to either properly change owner and group for the share, or change my user ID (which I will try later but I am not sure if changing it in etc/password will work). Let me know if you have any ideas

    As for sharing the machine, that would not be a problem, if needed. Let me know what you need, in case we do go that way.

    Regards, Robert

  4. #4
    Junior Member
    Join Date
    Apr 2010

    I was able to resolve the second issue of permissions so I now have R/W access to my share from both Knoppix and Windows. I was trying to figure out how to get my CDRW to allow writing and discovered an option to "Open Current Folder as Root" under the "Tool" menu in PCMan and bingo, write access! The CDRW is still not working but that is another problem for another post (if I can't find the answers on my own by looking around).

    In the process of trying to get this working, I ran into new problems relating to the original post -- How to upgrade to PUEL so I can have access to USB from my VM and I also believe it would be better to use the Vbox share than the network share I am using now. The dpcumentation for VBox says to simply install upgrades over the existing one but when I did that, I broke things. Any advice would be helpful!

    Thanks, Robert

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Lenovo ThinkPad T470 14

Lenovo ThinkPad T470 14" FHD Core i7-7600U 2.80GHz Webcam Backlit HDMI USB-C


Lenovo ThinkPad T14s Gen 2 Intel Laptop, 14.0

Lenovo ThinkPad T14s Gen 2 Intel Laptop, 14.0" FHD IPS LED Backlight, vPro®


Lenovo Laptop Computer Yoga 12.5

Lenovo Laptop Computer Yoga 12.5" Core i3 4GB Ram 128GB SSD HDMI WiFi Windows 10


Lenovo - Ideapad 1 15.6

Lenovo - Ideapad 1 15.6" HD Laptop - Athlon Silver 3050U - 4GB Memory - 128G...


Lenovo - Legion 5 17.3

Lenovo - Legion 5 17.3" 144Hz Gaming Laptop FHD - Ryzen 7 5800H - RTX 3050 4G...


Lenovo IdeaPad 3i 14

Lenovo IdeaPad 3i 14" FHD Notebook i5-1235U 8GB RAM 256GB SSD Abyss Blue


Lenovo IdeaPad 3 14

Lenovo IdeaPad 3 14" FHD Laptop Intel Core i7-1165G7 8GB RAM 512GB SSD


Lenovo - Yoga 7i 16

Lenovo - Yoga 7i 16" 2.5K Touch 2-in-1 Laptop - Intel Evo Platform - Core i7-...


Lenovo Flex 5i 14

Lenovo Flex 5i 14" Laptop Intel Core i3-1115G4 8GB Ram 256GB SSD W11H in S Mode


Lenovo Thinkpad Yoga Touchscreen Laptop Computer Windows 10 4GB 128GB SSD HDMI picture

Lenovo Thinkpad Yoga Touchscreen Laptop Computer Windows 10 4GB 128GB SSD HDMI