Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: turn off compiz fusion

  1. #1
    Junior Member
    Join Date
    May 2010
    Posts
    4

    turn off compiz fusion

    I hate this compiz fusion crap. I know you can use the 'knoppix no3d' on live boot but where do you save this cheatcode so that compiz fusin is permanently disable?

  2. #2
    yes, the 3d effects are a bit much, I turned them off. The question isn't about the cheat code, its about storage, and unless youre using flash/HDD install, which allows them to be turned off under Menu-Preferances -CompiZConfig Settings Manager and saved as Persistent data, then itll take re-burning a CD with code changes, or writing a prompt into the F2 or F3 files. The last 2 arent exercises for beginners.

  3. #3
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    198
    You have two options
    1. To include the no3d cheatcode in /mnt-system/boot/syslinux/syslinux.cfg -place it in the the line that loads your knoppix - adrian or knoppix or both.

    2.Second option is to use openbox instead of compiz and metacity by editing /etc/xdg/lxsession/LXDE/desktop.conf the line window_manager=compiz should be window_manager=openbox-lxde.

    I would personally recommend the second option.It gives you a good control over the looks and you get rid of this annoying compiz for good.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    198
    If after boot you still get compiz - delete the file /home/knoppix/.config/lxsession/LXDE/config

    All this is assuming that you run knoppix from usb with persistent data file.If run from cd, there is no way of changing it apart from remastering
    Last edited by mecho; 05-23-2010 at 06:50 AM.

  5. #5
    Junior Member
    Join Date
    May 2010
    Posts
    4

    turn off compiz fusion

    Am told that when u boot from live disc, use the cheatcode 'knoppix no3d' then install knoppix. The cheatcode will remain. Somebody try it out and let us know the outcome.

  6. #6
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    198
    I see no reason why I would want to install Knoppix on my hard drive. If I want to do that I would get a full Debian distro. Knoppix is specifically designed to be run as live CD or USB - that's it's strength

  7. #7
    Junior Member
    Join Date
    Oct 2012
    Posts
    1
    Quote Originally Posted by mecho View Post
    If after boot you still get compiz - delete the file /home/knoppix/.config/lxsession/LXDE/config

    All this is assuming that you run knoppix from usb with persistent data file.If run from cd, there is no way of changing it apart from remastering
    neither deleting config or desktop.conf work. everytime window_manager variable is set to openbox-lxde and then reboot or logout, the variable is restored to compiz. will removing compiz package work?

  8. #8
    Junior Member
    Join Date
    Oct 2012
    Posts
    2

    Thumbs down what a absolutely nosense idea!

    seriously, i registered just so that i could blast this nonsense. What purpose does enabling Compiz effects on a live cd/dvd serves?!

    I was fixing an old pc, and since i forgot my usual pack of linux dvds, i remember to download Knoppix instead of Mint as knoppix was once know as superb and light live cd (Linux MInt has been gaining weight..).

    And after spending 30 minutos downloading, burning it to dvdrw booting up the old pc(pentium 4, 1 gb ram, 128 mb graphics) what do i find?! that it had compiz effects enabled by default, no way to disable it and it's slow as molasses because of that.

    seriously, what purpose does this nonsense serve?! for me, sincerely, i'm done with knoppix. what a waist of time. if i had gone with Mint, i would be done rescuing data by now. Now i have to have doubled work!

  9. #9
    Junior Member
    Join Date
    Oct 2012
    Posts
    2
    Quote Originally Posted by crazywizard View Post
    I hate this compiz fusion crap. I know you can use the 'knoppix no3d' on live boot but where do you save this cheatcode so that compiz fusin is permanently disable?
    by the way, where can i insert that code? after boot selection i'm not given any time to use it. After the console login as root, it doesn't recognize the comand "knoppix" (maybe it was "startx no3d" ? ).

  10. #10
    Junior Member
    Join Date
    Oct 2012
    Posts
    1
    Quote Originally Posted by maccouch View Post
    by the way, where can i insert that code? after boot selection i'm not given any time to use it. After the console login as root, it doesn't recognize the comand "knoppix" (maybe it was "startx no3d" ? ).
    No, this cheat code you enter when you are booting knoppix as a kernel parameter (i.e. you write in syslinux: "knoppix no3d"). More about cheat codes: http://knoppix.net/wiki/Cheat_Codes (this particular one is actually not listed there, if I see correctly). Enjoy!
    To everybody - am I doing something wrong if "standard" key-shortcuts like <Alt>F1/<Alt>F2 does not work for me after replacing compiz with metacity, or there is some bug?

    BTW, if you were interested in a small linux for hacking, I'd actually recommend grml instead of knoppix.

    OT: I also registered just to write you the reply.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •