Results 1 to 2 of 2

Thread: Can't mount Mac hdd hfs+ journaled with knoppix live dvd

  1. #1
    Junior Member
    Join Date
    Nov 2010
    Posts
    1

    Unhappy Can't mount Mac hdd hfs+ journaled with knoppix live dvd

    Hi there guys,
    I have problem here to mount sata drive from crashed macbook pro of my girlfriend too sad as she has lot files on it specially pics as she is photographer so i put it to my toshiba laptop and run live dvd knoppix as usually. Palimset disk util can see drive but marked as unrecognized so i tried mount it manually with mount -t hfsplus /dev/sda /home but it gave me error 'ount: wrong fs type, bad option, bad superblock on /dev/sda,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog'

    but nothing please help!!!!!!!??????!!!!!!

    dmesg:

    [ 787.944074] hfs: unable to find HFS+ superblock
    [ 4717.850591] hfs: unable to find HFS+ superblock

    and few more :
    root@Microknoppix:/home/knoppix# mount -l
    rootfs on / type rootfs (rw,relatime)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    /dev/sr0 on /mnt-system type iso9660 (ro,relatime) [KNOPPIX]
    tmpfs on /ramdisk type tmpfs (rw,relatime,size=1048576k)
    /dev/cloop on /KNOPPIX type iso9660 (ro,relatime) [KNOPPIX_FS]
    unionfs on /UNIONFS type aufs (rw,relatime,si=d288e1c1,noplink)
    unionfs on /home type aufs (rw,relatime,si=d288e1c1,noplink)
    usbfs on /proc/bus/usb type usbfs (rw,relatime)
    tmpfs on /UNIONFS/var/run type tmpfs (rw,relatime,size=10240k)
    tmpfs on /UNIONFS/var/lock type tmpfs (rw,relatime,size=10240k)
    tmpfs on /UNIONFS/var/log type tmpfs (rw,relatime,size=102400k)
    tmpfs on /tmp type tmpfs (rw,relatime,size=1048576k)
    udev on /dev type tmpfs (rw,relatime,size=20480k)
    tmpfs on /dev/shm type tmpfs (rw,relatime,size=1048576k)
    devpts on /dev/pts type devpts (rw,relatime,mode=1777)

    root@Microknoppix:/home/knoppix# cat /etc/fstab
    # DEFAULT BASE FSTAB, UNCONFIGURED
    proc /proc proc noauto 0 0
    sysfs /sys sysfs noauto 0 0
    # Added by KNOPPIX
    /dev/sda1 /media/sda1 auto noauto,users,exec 0 0
    # Added by KNOPPIX
    /dev/sr0 /media/sr0 auto ro,noauto,users,exec 0 0



    I have never came across this kind of problem so if anyone know how to make it work
    i will send you a karma points ))))
    thank's lot

  2. #2
    Senior Member registered user
    Join Date
    Oct 2003
    Location
    N42.41 W73 and change
    Posts
    401
    You didn't say which version of Knoppix you are using, however you might try installing the hfsutils package. In a root terminal type:
    Code:
    aptitude update && aptitude install hfsutils
    And then try mounting. More info about hfsutils can be found my typing:
    Code:
    man hfsutils
    in a terminal. Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •