Results 1 to 4 of 4

Thread: GNU gfortran compiler not in knoppix 7.0.5 distribution

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Location
    Schenectady , NY (USA)
    Posts
    7

    GNU gfortran compiler not in knoppix 7.0.5 distribution

    I am still using the Knoppix 5.3.1 DVD . It has many of the utilities I need ... Gnu gfortran, Gnu C, Nedit, Perl, gawk ...
    It is a nice environment to do some engineering programming in mixed fortran and C .

    I keep looking at the new Knoppix distributions , I see some interesting additions , it uses a newer Linux kernal , and there are newer verisons of existing packages .

    However , I do not see a fortran compiler listed. So, I go back and use 5.3.1 , mostly because it has gfortran .

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    And why do you not use Synaptic to install gfortran and so on?

  3. #3
    Junior Member
    Join Date
    Dec 2009
    Location
    Schenectady , NY (USA)
    Posts
    7
    Quote Originally Posted by Werner P. Schulz View Post
    And why do you not use Synaptic to install gfortran and so on?
    Hello Werner,

    Up until now I have just been using Knoppix from the DVD , so 5.3.1 was practical for me.

    I have been doing scientific programming for years but never got into computer system administration . I just started looking through the tools with Knoppix 7.2 and decided to try to install Knoppix to a USB flash drive. I had no problems with that. I then created a 2gb knoppix-data.img file .

    Then , as you suggested , I used Synaptic . I did a refresh on the package list , which I had never done before. I looked through the updated list of packages and saw gfortran 4.7. I selected gfortran 4.7 from the updated list , did the download and install with no problems. gfortran 4.7 is working nicely.

    I did notice that gfortran 4.8 is available. However , when I selected gfortran 4.8 for download there was a red tag and indications that there is a problem with this package.

    Thank you and the others who have posted valuable information on the Knoppix forum.

    Regards,
    Ldot

  4. #4
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    If you really need gfortran-4.8 use "aptitude update". After this you can simulate the update with
    Code:
    aptitude install -s -t testing gfortran-4.8
    or
    aptitude install -s -t unstable gfortran-4.8
    If all looks well install it using the command without the parameter "-s".

    Make a backup of your persistent memory first!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •