Results 1 to 3 of 3

Thread: HDMI sound problem

  1. #1
    Junior Member
    Join Date
    Dec 2010
    Posts
    2

    HDMI sound problem

    I'm having a problem with the HDMI connection from my laptop to my high def TV.

    I have a DELL Inspiron 1525 laptop connected to a high def TV via the HDMI port

    If I boot the machine using Windows XP Pro (which is what I have installed on the internal drive), the picture shows on the TV and the sound come out of the speakers on the TV.

    But if I boot Knoppix (which I run from a 4GB Kingston Flashdrive), the picture shows on the TV but the sound still comes from the laptop (rather then from the speakers on the TV)

    Most people are going to say "why not just use XP"

    The answer to that is: When I use XP (to watch TV on the Internet), every so often the show (playing at the time) runs in... kind of slow motion. Its almost like the processor is having a problem rendering the picture.
    It doesn't occur very long and it always speeds-up again but its very irritating.

    When I run Knoppix, this problem never occurs (ie. The TV show plays smoothly all the way through)
    But again, the sound continues to come from the laptop speakers (rather then the speakers on the TV)

  2. #2
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    This is something I have never tried before but maybe the problem should be divided as two,

    1. To identify if the system has identified the presence of audio on HDMI
    2. To channel the voice to the right audio device

    For (1), you can try this command 'aplay -l' to see if there is 'HDMI' audio
    For (2), you need to run 'alsamixer' and/or 'amixer' to channel the audio to the HDMI.

  3. #3
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    512
    I think that you should create a configuration file /home/knoppix/.asoundrc as described in the thread http://www.knoppix.net/forum/threads...l=1#post121157

    If you want to use more than one audio device at a time then you should install pulse audio. It allows you to select the audio device in a comfortable way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM Power S822 8284-22A 12SFF Power8 3.89GHz 6Core 64GB RAM No HDD Server System picture

IBM Power S822 8284-22A 12SFF Power8 3.89GHz 6Core 64GB RAM No HDD Server System

$359.99



1U IBM x3550 M5 4 Bay SFF SAS3 Server 2x E5-2683 V3 28 Core 128GB DDR4 2x Tray picture

1U IBM x3550 M5 4 Bay SFF SAS3 Server 2x E5-2683 V3 28 Core 128GB DDR4 2x Tray

$318.00



IBM Power S822 12-Bay Server System Power8 Core 3.42Ghz DVD-Rom Drive 64GB No HD picture

IBM Power S822 12-Bay Server System Power8 Core 3.42Ghz DVD-Rom Drive 64GB No HD

$349.99



IBM Power S822 8284-22A 12SFF Power8 3.89GHz 6-Core 64GB RAM No Bezel/HDD Server picture

IBM Power S822 8284-22A 12SFF Power8 3.89GHz 6-Core 64GB RAM No Bezel/HDD Server

$319.99



IBM HS23 Server 2x Xeon E5-2630 @ 2.30 GHz HDD Caddies NO HDD NO RAM NO OS (LS) picture

IBM HS23 Server 2x Xeon E5-2630 @ 2.30 GHz HDD Caddies NO HDD NO RAM NO OS (LS)

$62.95



IBM System x3550 M3 Dual Intel Xeon X5650 @2.67GHz 32GB RAM No HDD picture

IBM System x3550 M3 Dual Intel Xeon X5650 @2.67GHz 32GB RAM No HDD

$84.50



IBM mainframe server cpu IBM93 vintage cpu collector's item picture

IBM mainframe server cpu IBM93 vintage cpu collector's item

$129.99



IBM Power8 S822L 20-Core 3.42GHz 256Gb 1.2Tb 40G Elastic Storage Server 5148-22L picture

IBM Power8 S822L 20-Core 3.42GHz 256Gb 1.2Tb 40G Elastic Storage Server 5148-22L

$599.95



IBM System X3250 M3 Server 8GB RAM Intel Xeon x3440 2.53ghz (NO HDD) picture

IBM System X3250 M3 Server 8GB RAM Intel Xeon x3440 2.53ghz (NO HDD)

$41.99



IBM IntelliStation 9114-275 4-Bay Server Power4+ Core 1.0ghz DVD-Rom 1GB No HDD picture

IBM IntelliStation 9114-275 4-Bay Server Power4+ Core 1.0ghz DVD-Rom 1GB No HDD

$699.99