Results 1 to 3 of 3

Thread: HDMI sound problem

  1. #1
    Junior Member
    Join Date
    Dec 2010
    Posts
    2

    HDMI sound problem

    I'm having a problem with the HDMI connection from my laptop to my high def TV.

    I have a DELL Inspiron 1525 laptop connected to a high def TV via the HDMI port

    If I boot the machine using Windows XP Pro (which is what I have installed on the internal drive), the picture shows on the TV and the sound come out of the speakers on the TV.

    But if I boot Knoppix (which I run from a 4GB Kingston Flashdrive), the picture shows on the TV but the sound still comes from the laptop (rather then from the speakers on the TV)

    Most people are going to say "why not just use XP"

    The answer to that is: When I use XP (to watch TV on the Internet), every so often the show (playing at the time) runs in... kind of slow motion. Its almost like the processor is having a problem rendering the picture.
    It doesn't occur very long and it always speeds-up again but its very irritating.

    When I run Knoppix, this problem never occurs (ie. The TV show plays smoothly all the way through)
    But again, the sound continues to come from the laptop speakers (rather then the speakers on the TV)

  2. #2
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    This is something I have never tried before but maybe the problem should be divided as two,

    1. To identify if the system has identified the presence of audio on HDMI
    2. To channel the voice to the right audio device

    For (1), you can try this command 'aplay -l' to see if there is 'HDMI' audio
    For (2), you need to run 'alsamixer' and/or 'amixer' to channel the audio to the HDMI.

  3. #3
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    512
    I think that you should create a configuration file /home/knoppix/.asoundrc as described in the thread http://www.knoppix.net/forum/threads...l=1#post121157

    If you want to use more than one audio device at a time then you should install pulse audio. It allows you to select the audio device in a comfortable way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Server 2022 Datacenter activation license picture

Windows Server 2022 Datacenter activation license

$23.00



HYVE Openrack OCP 1U Server Intel Xeon 16 Core 2.0Ghz 64GB Ram 500GB 10GB SFP+  picture

HYVE Openrack OCP 1U Server Intel Xeon 16 Core 2.0Ghz 64GB Ram 500GB 10GB SFP+

$199.00



Dell Poweredge R410 2 X SIX CORE 2.40GHZ E5645 32GB RAM 500GB HHD SERVER QTY picture

Dell Poweredge R410 2 X SIX CORE 2.40GHZ E5645 32GB RAM 500GB HHD SERVER QTY

$159.99



HPE ProLiant EC200a Mini Server, Xeon D1518 2.2GHz CPU picture

HPE ProLiant EC200a Mini Server, Xeon D1518 2.2GHz CPU

$199.00



Chenbro SR301 Series 4-Bay Compact SOHO Server Chassis w/ 250W PSU | SR30169 picture

Chenbro SR301 Series 4-Bay Compact SOHO Server Chassis w/ 250W PSU | SR30169

$129.00



HP Proliant DL380p G8 Server 2x E5-2670 2.6ghz 16-Cores / 16GB / P420 / 2x 460w picture

HP Proliant DL380p G8 Server 2x E5-2670 2.6ghz 16-Cores / 16GB / P420 / 2x 460w

$84.99



Supermicro CSE-512-200B Rackmount bare bones 1U Server Chassis picture

Supermicro CSE-512-200B Rackmount bare bones 1U Server Chassis

$49.99



Storage Server Starter Kit - 2U 12 Bay Xeon 2x 2.6Ghz 8 Cores 32GB RAM HBA RAILS picture

Storage Server Starter Kit - 2U 12 Bay Xeon 2x 2.6Ghz 8 Cores 32GB RAM HBA RAILS

$389.00



HYVE Openrack OCP 1U Server 2x Intel Xeon 8 Cores 2.0Ghz 16GB 500GB 10GB SFP+  picture

HYVE Openrack OCP 1U Server 2x Intel Xeon 8 Cores 2.0Ghz 16GB 500GB 10GB SFP+

$149.00



Dell PowerEdge T320 Intel Xeon E5-2430 @ 2.20 GHz Server, No RAM, PSU's or HDD picture

Dell PowerEdge T320 Intel Xeon E5-2430 @ 2.20 GHz Server, No RAM, PSU's or HDD

$75.00