Results 1 to 3 of 3

Thread: dd_resue error

  1. #1
    Junior Member
    Join Date
    Dec 2010
    Posts
    2

    dd_resue error

    Hi I am absolutly a newbie when it comes to linux. I know dos so I was hoping that helps as I need to use dd_rescue to try and recover some data.

    I am using knoppix live DVD lastest version downloaded today. I have a laptop booted with knoppix and have 2x USB devices. 1x a Kingston 1Gb flashdrive and the 2nd a Seagate 2Tb external USB drive. Both sare see and can be browsed to. Kingston sdc1 and Seagate sdb

    Now I have a single file on the Kingston and it is not corrupt but I am testing as I cannot get this correct. I run the ffg command and I get an error.

    dd_rescure /dev/sdc1 /dev/sdb

    This runs without an error, but there are NO files on sdb when I browse to it. (I believe there should be none)

    I than run....
    dd_rescue /dev/sdc1 /dev/sdb/backup.img

    I get an error that the
    dd_rescue: (fatal): open "/dev/sdb/backup.img" failed: not a directory

    I created a directory on sdb called backup and tried it and I get same error. I also created a file called backup.img thinking that when it encounters it it would let me know if it should overwrite it...but no difference.

    What am I doing wrong?

    Thanks

    PS: I tried to initially run the corrupt drive and I am not sure but it went on for days (I think 5-6 days) and had not finished. (the drive capacity was 120Gb)

  2. #2
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    Quote Originally Posted by ss1001 View Post
    What am I doing wrong?
    You need to have some understanding of device files, file system types ( FAT, VFAT, NTFS etc), mounting of file systems ....etc in order to use the tools effectively.

  3. #3
    Junior Member
    Join Date
    Dec 2010
    Posts
    2

    Got past the initial error to encounter others...

    Ok I got past the initial error and I did this by actually changing directory to the destination drive i.e. where the actual log file and image file (of the rescued HDD) will reside. I believe there may be a command in Linux similar to DOSes "Path" command ...however I have not investigated this as yet. NOTE IMPORTANT: I did all of this in the "roots" terminal window as the regular terminal window does not have enough permissions. Again I am new to Linux and didn't know how to login as root from the regular command/terminal window.

    So I was able to successfully make an image of my Test flash drive with the a single file in it and was able to mount (again here I had to be in the actual folder where this recovers image file is...that Path command mentioned above).

    So I than proceeded to try and recover the 120Gb HDD installed in an external USB enclosure. The system saw the drive fine and also reported it as NTFS. I got the image file after several hours and finally mounted the image to find it black with no files. So not sure if the previous attempts with dd_resuce wiped the file clean.

    Anyway, I proceeded to recover another drive 750Gb SATA in an External USB enclosure and when I looked at the file system it indicated unrecognized and showed it as FAT. However it reported the drive as a 2Tb drive and not 750Gb as marked in the lable.....

    Any 'CONSTRUCTIVE' idea's please ....

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Lenovo Ideapad 1 15Iau7 15.6

Lenovo Ideapad 1 15Iau7 15.6" Laptop Intel Core i5-1235U 8GB RAM 512GB SSD W11P

$299.99



15.6

15.6" Lenovo ThinkPad Laptop PC: Intel i5 16GB RAM 512 SSD Windows 10 Webcam

$229.99



Lenovo ThinkPad Yoga Touchscreen Laptop PC 11.6

Lenovo ThinkPad Yoga Touchscreen Laptop PC 11.6" Windows 10 4GB RAM 256GB SSD

$89.99



Lenovo ThinkBook 15 Gen 4 Notebook 15.6

Lenovo ThinkBook 15 Gen 4 Notebook 15.6" FHD AMD R7 5825U 16GB RAM 512GB SSD

$479.99



Lenovo ThinkBook 15 Gen 4 Notebook 15.6

Lenovo ThinkBook 15 Gen 4 Notebook 15.6" FHD Intel Core i7-1255U 8GB RAM

$514.99



Lenovo ThinkPad T14S 14

Lenovo ThinkPad T14S 14" 2020 Intel Core i5 10310U 256 GB 16 GB SSD Grade B

$199.99



Lenovo IP 5 16IAU7 16

Lenovo IP 5 16IAU7 16" 2.5K Chromebook i3-1215U 8GB Ram 128GB eMMC Chrome OS

$219.99



Lenovo ThinkPad E14 Gen2 (Ryzen 7-4700u 16GB RAM 256GB SSD Win11Pro) | C-Grade picture

Lenovo ThinkPad E14 Gen2 (Ryzen 7-4700u 16GB RAM 256GB SSD Win11Pro) | C-Grade

$171.34



14

14" Lenovo ThinkPad Laptop: Intel i5 Quad Core 16GB RAM 1TB SSD Windows 11

$249.95



Lenovo ThinkPad E480 14

Lenovo ThinkPad E480 14" (i5-8250u 1.60GHz - 16GB RAM - 256GB SSD - Win11Pro)

$122.34