Hi I am absolutly a newbie when it comes to linux. I know dos so I was hoping that helps as I need to use dd_rescue to try and recover some data.

I am using knoppix live DVD lastest version downloaded today. I have a laptop booted with knoppix and have 2x USB devices. 1x a Kingston 1Gb flashdrive and the 2nd a Seagate 2Tb external USB drive. Both sare see and can be browsed to. Kingston sdc1 and Seagate sdb

Now I have a single file on the Kingston and it is not corrupt but I am testing as I cannot get this correct. I run the ffg command and I get an error.

dd_rescure /dev/sdc1 /dev/sdb

This runs without an error, but there are NO files on sdb when I browse to it. (I believe there should be none)

I than run....
dd_rescue /dev/sdc1 /dev/sdb/backup.img

I get an error that the
dd_rescue: (fatal): open "/dev/sdb/backup.img" failed: not a directory

I created a directory on sdb called backup and tried it and I get same error. I also created a file called backup.img thinking that when it encounters it it would let me know if it should overwrite it...but no difference.

What am I doing wrong?


PS: I tried to initially run the corrupt drive and I am not sure but it went on for days (I think 5-6 days) and had not finished. (the drive capacity was 120Gb)