Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: It's about time

  1. #1
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390

    It's about time

    I didn't like my 6.4.3 digital clock reading in 24hr utc,
    so I edited, as root, /etc/init.d/knoppix-autoconfig
    on the first line which begins KTZ="$(get..
    to read KTZ="America/New_York"

    Then I set the digital clock format to %I:%M%P so now
    it reads 10:09pm (today), instead of 3:09 (tomorrow).

    Your zone may vary.

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390

    sequel to It's about time

    My post #1 solved my Knoppix panel time problem,
    but created a new problem:
    on subsequent reboot to Windows 7 on the same machine,
    Windows 7's panel time was all wrong.

    At this point, my new objective is in having both Windows 7
    and Knoppix panel times read the correct local time.

    It would seem that editing, as root, /etc/init.d/knoppix-autoconfig
    on the first line which begins KTZ="$(get.." to read KTZ="Etc/UTC"
    gives me this new objective.

  3. #3
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390

    second sequel to It's about time

    In looking for a refinement of the lxpanel digital clock
    format to get '01:35pm' to read '1:35pm', I found some-
    thing more immediately interesting:

    I found someone other than myself whose digital clock is
    (or was) one minute (or so) off. My GE stove is keeping
    better time.

    https://bbs.archlinux.org/viewtopic.php?id=109328

    It's not clear (to me) if the 'archlinix bug fix' is
    available through Synaptic as yet. I am presuming it is
    contained in lxpanel itself and not some another element.

  4. #4
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390

    third, etc

    Back now to the format question.

    You have to look close:
    The format %I:%M%P gives times like 02:15pm.

    What you want is probably:
    The format %l:%M%P which gives times like 2:15pm.

    That's lower-case l (small ell, not capital eye), not upper-case i.
    Last edited by utu; 01-06-2011 at 07:27 PM.

  5. #5
    Senior Member
    Join Date
    Nov 2011
    Posts
    121
    Hi - I'm new to Knoppix and I've been experimenting with ubuntu for a couple of months, so please excuse if I'm missing the obvious.

    I booted up the install CD and thought I'd change the time display to be a little clearer for me. So far, this thread is the best I've found for directions for the digital clock. Are the settings based on PHP, PERL or something? Where are the settings documented?

    With information in this thread, I've changed to pm without a leading zero in the time, but haven't figured out how to show a 4 digit year in the tool tip. (Any ideas?)

    I've found a help manual, but nothing found when searching for clock
    http://www.google.com/search?client=...+by+Phil+Jones

    Anyway, just starting, but hope this isn't an indication I might be trying the wrong distro.

    On the positive side, my right side scroll works on my touchpad (hoorah).
    Last edited by Clinton; 11-22-2011 at 10:34 AM. Reason: changed link that started automatic download

  6. #6
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390
    Quote Originally Posted by Denver Dave View Post
    ...
    haven't figured out how to show a 4 digit year in the tool tip. (Any ideas?)
    ...
    %Y; that is, percent sign, cap 'wye'.
    Cheers

  7. #7
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    903

  8. #8
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390
    Hi, Werner.
    Superb reference.
    Thanks.

  9. #9
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390
    Two updates for those who even care:

    My lxpanel digital time display is still one minute slow relative
    to my GE stove, see post #3, my date command and the knoppix forum time; and...

    Recently, as a result of clumsy typing I've found a function 'ddate'
    in /usr/bin which worries me. It is not GPL-ed and all 'rites' are reserved.

  10. #10
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,390
    FWIW

    This is a peculiar quirk of the lxpanel digital clock which, as far as I know, occurs only
    for display formats which don't include seconds. It was well-described in the following bug
    report, for which for the complainer promptly reported that it had been corrected:

    http://sourceforge.net/tracker/index...58&atid=894869

    It has NOT been corrected in the Knoppix 6.7.1 debian choices of lxpanel 0.5.6-1 (stable) NOR
    0.5.8-1 (testing). 0.5.8-1 also has other problems, as has been noted by Werner.
    Last edited by utu; 11-25-2011 at 02:37 PM.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •