Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: wicd asks for root password

  1. #1
    Senior Member
    Join Date
    Jan 2011
    Posts
    123

    wicd asks for root password

    I've been hesitating to ask here or the wicd forums but they appear to be closed to registration .
    I didn't like nm-applet and for some reason I decided to get rid of it and replace it with wicd.

    The problem is that wicd asks for the root password to "get acces to your computer's network card".
    After some google searches everyone told me I needed to run the deamon "/etc/init.d/wicd". if it is running wicd will not ask for the root pass.

    first I tried to add "/etc/init.d/wicd start" to rc.local. this didn't appear to run and yes I've chmoded 775 to rc.local, I assume this is suposed to make it runnable? so I added "rm -f /home/knoppix/testfile" and after next boot testfile was still there.

    then I installed sysv-rc-conf but wicd was already getting started up at boot? after looking with rcconf(another tool) it turned out that knoppix-autoconfigure and another script was never run. So I'm guessing knoppix doesn't really looks at the other /init.d/ scripts and just runs knoppix-autoconfigure.

    at last I had a little bit succes with /etc/init.d/knoppix-autoconfigure. I edited it and found some lines that started the default networking deamon. I've replaced it with wicd and sure enough, when I boot and look at "/etc/init.d/wicd status" it says wicd is running.

    The problem now is that wicd still asks for a root password but it doesn't mattter what pass I give, it just works.
    If i gave a fake pass befor the fix I got a bunch of error messages about the deamon could not be started,... .

    I'm using wicd 1.7.0 and knoppix 6.4.4 cd edition.

    Forester, from this topic http://www.knoppix.net/forum/threads...etwork-Manager I could see that you have wicd running on a debian system and from here: http://www.knoppix.net/forum/threads...highlight=wicd I've read you have some notes on a piece of paper about wicd, did I forget a step on that piece of paper?

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Hello dinosoep. I take it that you've got your system working again after the patch problem and this wicd thing isn't actually stopping you doing what you need to do ?

    Hmm, Knoppix has it own start up thing as you know and installing stuff like upstart or sysv-rc-conf is very likely to break it.

    First thing to check ... is the file /etc/inittab the same as the one on the CD ? This file is not Knoppix specific but its contents are. In particular the line:

    Code:
    si::sysinit:/etc/init.d/knoppix-autoconfig
    is crucial. The script knoppix-autoconfig is Knoppix specific. What comes after this is not, it is standard SYSV start-up as far as I know. Do an ls -l in any of the directories /etc/rc0.d ... /etc/rcS.d. There directories contain a lot of symbolic links to scripts in /etc/init.d. Look at the README in one of these directories. The script in /etc/init.d do get run when you start up the system but they are run indirectly through these scripts. At least I think so.

    When you installed the wicd from the Debian repositories, it should have added new symbolic links in one or more /etc/rc*.d directories and should start automatically. So I don't know what is going on.

    I don't know why your changes to rc.local didn't work. I've added ssh and mysql to my services by adding them to:

    Code:
    SERVICES="cups ssh mysql"
    in rc.local and they start just fine. Altering knoppix-autoconfig should work just fine too. Knoppix does a special here so the cheatcode works. Note there are no symbolic links to /etc/init.d/network-manager.

    I don't know why you get asked for a password. In fact, I can't see how you can be asked for a password when you start wicd in the background so I suspect it is obvious to you when it asks you for a password and not obvious to me.

    I guess I'll have to install it myself to figure out what you are talking about but that may not be for a day or two.

  3. #3
    Senior Member
    Join Date
    Jan 2011
    Posts
    123
    " I suspect it is obvious to you when it asks you for a password and not obvious to me."
    well, wicd assumes the wicd daemon is running. if it's not it starts the daemon but for that it needs root priviliges.
    at least thats what they say on the forums.
    it is not obvious to me why he asks a pass even if the deamon is running.

    and not all patches have been aplied and tested, just squashfs but I"m trying the others too in the near future

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Does wicd ask for the root password in response to something you do or is it spontaneous ?

    Do you select menu item or click on a panel icon ?

    It it a prompt from the console before the desktop starts or is it a pop-up windows that appears after the desktop first appears ?

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Posts
    123
    spontaneous popup from desktop

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Posts
    123
    Strangest of all is that when I disable wicd applet network gets set up and I can browse the web...
    and when I then run wicd-gtk (what the applet also does) I get no root prompt whatsoever

  7. #7
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Hi dinosoep,

    I've had a look at the wicd installation I have on Debian and it is fine. I've installed wicd on Knoppix and it too is fine. I don't get asked for a password but I get a notification that a program has been granted permissions without asking for password.

    I take back what I said about Knoppix running all the scripts in the directories /etc/rcN.d. There are a lot of services pre-installed that don't get started so ....

    There are a few things I'd like you to check. What output does:

    Code:
    ps -ef | fgrep wicd
    give (once your wireless network is connected).

    What output does:

    Code:
    groups
    give.

    Have you set a password for a) knoppix b) root ?

    Myself, I've changed my cheat codes to include nonetworkmanager and I've altered /etc/rc.local to:

    Code:
    SERVICES="cups wicd"
    but I have not (yet) uninstalled the Network Manager itself (it's a KK special so I'm not sure I could reinstall it). This arrangement works fine with LXDE but is, as expected, a bit of a balls up under KDE.

  8. #8
    Senior Member
    Join Date
    Jan 2011
    Posts
    123
    Code:
    knoppix@Microknoppix:~$ ps -ef | fgrep wicd
    knoppix   3197     1  0 13:59 ?        00:00:00 /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py
    root      3285     1  0 13:59 ?        00:00:00 /usr/bin/python -O /usr/share/wicd/daemon/wicd-daemon.py
    root      3290  3285  0 13:59 ?        00:00:00 /usr/bin/python -O /usr/share/wicd/daemon/monitor.py
    root      3465     1  0 13:59 ?        00:00:00 wpa_supplicant -B -i wlan0 -c /var/lib/wicd/configurations/00259c43f1b8 -D wext
    root      3490     1  0 13:59 ?        00:00:00 /sbin/dhclient -v -cf /var/lib/wicd/dhclient.conf wlan0
    knoppix   3709  3688  0 14:02 pts/0    00:00:00 fgrep wicd
    knoppix@Microknoppix:~$ groups
    sudo netdev
    I have set a pass on root and knoppix
    automatic granting of root acces has been disabled by me (I like it more that way)

    But that would actually be the solution to my problem
    So I added this to sudoers:
    Code:
    knoppix ALL= NOPASSWD: /usr/sbin/wicd
    and for people planning to use wicd, do
    Code:
    sudo leafpad /etc/init.d/knoppix-autoconfig
    search for the line
    Code:
    start_net(){
    ....
    }
    
    start_swap(){
    and replace it with
    Code:
    start_net(){
     addtask "net"; addprogress "Starting network..."
     # Remove ifup-statusfile
     [ -f /etc/network/run/ifstate ] && rm -f /etc/network/run/ifstate 2>/dev/null
     # In theory, we just have to wait for udev to add new network cards,
     # and dhclient-daemon will send a broadcast automatically
     # dhclient -q -1 -nw >/dev/tty$LOG_CONSOLE 2>&1 &
     # /etc/init.d/resolvconf start
     # if ! checkbootparam "nodnscache" && [ -x "/etc/init.d/bind9" ]; then
     #  /etc/init.d/bind9 start
     # fi
     if ! checkbootparam "nonetworkmanager" && [ -x "/etc/init.d/wicd" ]; then
      ( /etc/init.d/wicd start & )
     else
      ( ifup -a & )
     fi
    }
    
    start_swap(){
    maybe I should try to make a patch for this?

  9. #9
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    I've just watched the the Azuri win. Bravo !

    I think devising a patch for knoppix-autoconfig is a very good thing to do.

    I see you are fiddling with the sudoers file. Does that make any difference ? I would expect not so I'd be very interested to know if it did.

    The processes you show are the same as I have. Three are root processes. These are created by /etc/init.d/wicd, which you start from knoppix-autoconfig. They are thus started in a root context and will not need a password.

    The fourth process is a knoppix user process and that would need root privileges to read the wicd configuration files. You get asked for a password 'cos you've told Knoppix to do this. I get a notification 'cos I haven't and I see nothing under Debian. I guess that is because Debian has this root password thingy done differently.

    automatic granting of root access has been disabled by me
    How do you do that ? I'd like to know.

    When you use the great Network Manager is asks you for your password 'cos is has saved your wireless network's key or pass phrase in a 'wallet'. On a (non-Knoppix) machine with several users, each user has their own wallet. With wicd, the wireless network's key or pass phrase is stored in a file only root can read or write but the file is common for all users. So I don't really understand you complaint.

    With the great Network Manager, you have to log in before it can read the key or pass phrase so the network connection is made late, which isn't good enough for utu. With wicd, the daemon makes the connection so boot up should be quicker.

    You might actually try disable the auto-start of the wicd panel icon and that might remove the password prompt. You can always start the wicd Network Manager from the Main Menu. Oddly enough, its under Internet where you would never expect to find it.

  10. #10
    Senior Member
    Join Date
    Jan 2011
    Posts
    123
    yeah, I forget to mention that that little line in the sudoers file removed the sudo pass prompt, exactly the way I want it.

    and to disable it edit your sudoers file and comment the line out that goes like this: "knoppix ALL=NOPASSWD :ALL" by placing an # before it

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Dell Latitude D500, D600 & Inspiron 500m, 600m Hard Drive Caddy Set-Lot of Five
$14.99
Dell Latitude D500, D600 & Inspiron 500m, 600m Hard Drive Caddy Set-Lot of Five pictureHGST HUC109090CSS601 2.5" 900GB 10K RPM SAS Hard Drive
$550.0
HGST HUC109090CSS601  2.5Ultrabay SATA 2nd HD Hard Drive Caddy Tray Lenovo ThinkPad T420i T510 W510 T520
$7.95
Ultrabay SATA 2nd HD Hard Drive Caddy Tray Lenovo ThinkPad T420i T510 W510 T520 pictureIBM 59Y5460 - 600GB 15K 4Gbps FC E-DDM HDD
$258.0
IBM 59Y5460 - 600GB 15K 4Gbps FC E-DDM HDD pictureWestern Digital Caviar Green 2 TB,Internal,5400 RPM,3.5" (WD20EARS) Hard Drive
$9.5
Western Digital Caviar Green 2 TB,Internal,5400 RPM,3.5