Results 1 to 3 of 3

Thread: Xkbmodel us

Hybrid View

  1. #1

    Xkbmodel us

    Knoppix 6.2.1.HD install. I am attempting to fix the problem with every word I type in browser and word from being undelined in red, indicating the wrong dictionary is being used. Additionally, in my browser I can only type in 1 block paragraph. In /etc/default/keyboard my XKBMODEL="PC105". I have searched on the Internet and found that PC 105 is for "de_DE@euro". Yet I cannot find the correct XKBMODEL to use. I tried PC104, as some other internet search examples provided, but - as you can see, there is no change. Can anybody tell me the correct setting? Or the correct way to fix this problem?

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Hi Bo,

    Hard drive install, eh ? Do cheat codes still work ?

    The setting of XKBMODEL is in /etc/defaut/keyboard and allows you to specify bits and pieces for your keyboard under X instead of specifying them in xorg.conf. This is handy except ...

    ... under Knoppix LiveCD and LiveUSB install this file gets overwritten with every boot and changes you make may be lost. It depends on how you override the default cheat codes. If you've also modified xorg.conf then I don't know which wins in case of a conflict.

    The setting:
    Code:
    XKBMODEL=PC105
    simply says what keyboard you have. If you had a Mac it would be macintosh, if you were lucky enough to have an old sparc it would be sun. The number simply refers to how many keys there are on the keyboard. It used to be 101 or 102 until M$ forced the two Windows and the Menu key on the world. I understand 104 keys in standard in the US and the 105 is standard in Europe regardless of whether the keys have a QUERTY, QUERTZ, AZERTY or some other arrangement. Myself, I have effectively been using:

    Code:
    XKBMODUEL="pc105"
    XKBLAYOUT="us,gb"
    XKBVARIANT=""
    for years and I can tell you it has nothing to so with the spell checker in your browser.

    The "de_DE@euro" bit is more concerned with the 'locale', which is not quite the same. Knoppix is produced in a German university and I think is used in a lot of German universities so a locale that says "We are in Germany, we use the German language and we use the Euro (not the DM anymore)" seems a reasonable default.

    If you use the 'EN' edition and no lang= cheat code, then the local is set to "C", which is the default, old Unix 7-bit ASCII, which is entirely appropriate for the US so long as you don't want compose key functionality. It too has nothing to do with the spell checker in your browser.

    If you have ever installed Debian or Ubuntu or a desktop distribution derived from them you should be able to recall that the installer asks (first) what you keyboard is and then for your locale (where in the world are you). On the basis of the second answer the installer guesses your language (perhaps if your locale is Belgium is might ask whether you want Flemish or French) and on the basis of the result installs appropriate spell checkers. Knoppix is not a desktop distribution and, alas even with the 'EN' edition, comes with German spell checkers. That is your problem.

    You need to install (US) English spell checkers as I did. Knoppix also comes with the hunspell checker, which seems to be incompatible with the myspell checker: when I installed the later, Knoppix insisted in removing the former.

    There is one more snag. I'm using 6.4.4, which came out on 30 January 2011. I changed the spell checkers on March 7 2011 but I couldn't do this for the iceweasel browser. The browser comes from the experimental repository. In February, Firefox 4 came out, iceweasel in the experimental repository was upgraded so I had a repository compatibility issue. I could have upgraded iceweasel to version 4 or I could have downgraded but I decided I could not be bothered.

    You have Knoppix 6.2.1, which is two years out of date. You may have serious problems changing spell checkers. I suggest you try first with the LiveCD. You wouldn't want to go breaking you HD install would you ?

  3. #3
    Hey Forester. Cheat codes work, but I am using Grub - they have to be edited there. If you mess that up, you mess with XP as well (dual boot) - been there. Had to do (fixmbr) on windows and reinstall Knoppix. Had I known on the original install the Grub would have picker-up my cheats from the command line (I think). I think I will try the spell checker option, or just leave it alone until I decide on a distro. The spell checker is one issue, but it seems that in Iceweasel, I cannot do paragraphs either. The experimental explanation probably applies to me, as well. I changed my updates to stable, and security only - I believe I tried the new Iceweasel on one of many installs, and found the "No scripts" had been altered to something else (might have been another browser). I will try the spell checker to fix Abiword, and leave Iceweasel alone. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •