Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Time

  1. #11
    Junior Member
    Join Date
    Apr 2011
    Posts
    23
    I managed to hit "e" on boot up and changed the line that comes up to tz=europe/london but i need to change the language to en gb and that should work. Any idea why in system settings advanced I can't alter the time and date? I just get a "not authorized message". Thanks again......

  2. #12
    Moderator Moderator
    Join Date
    Jan 2010
    Location
    Asheville, NC, USA
    Posts
    528
    Quote Originally Posted by Werner P. Schulz View Post
    ... the HD-installation of Knoppix is an installation to HD like other OS (Debian, Ubuntu etc). The differences are among other things: no root password by default, no safety updates, only user knoppix.

    You can chroot within this installation for remastering purpose, but is isn't chroot'd by default. Tell me, if I'm wrong.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.4.4 remaster)
    It sounds like you may know more than I. The impression I've gathered is that "HD install" is not recommended for the faint of heart, as it produces unpredictable results due to strange differences in user/owner of resources, etc., primarily related to the ability to remaster. Flash install, on the other hand, produces a fairly solid system for daily use, in my experience.

    Cheers!
    Krishna

  3. #13
    Referring to time problem I was able to get the following to work; in this order - you get one shot. 1. run dpkg-reconfigure tzdata
    to set your timezone. 2. date MMDDHHmmCCYY 3. hwclock --localtime.... After having to change the time everytime I logged in. I eventually tried my original steps, again - and they worked. The first time I tried this I added the step 4. hwclock --systohc, and lost everything. Do not do step 4. If you are dual boot decide which clock is more important. My Windows clock is not correct but if I change it Knoppix will be the loser. I almost never use Windows after learning Knoppix. By the way - I am Knoppix 6.2.1HD install.

  4. #14
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Quote Originally Posted by jacksbutler View Post
    Hi and thanks very much for the great help, but none of it works! I changed the language to lang=uk etc but it was still us english and us keyboard layout. Do I do the changes as root in the console and if so what do I do to have the changes saved?
    No. You're on the wrong track. Werner mentions the file /boot/grub/menu.lst. You need to back this file up and edit it. You'll probably need to be root to do this. Use nano. If I've lost already, I'm sure utu can help with Linux basics - he's been reading up recently.

    Based on the name of the file, Knoppix is still using the old grub version and I don't have a HD install so I'm scratching my head with both hands here.

    In the file you'll find groups of lines like:

    Code:
    title           Debian GNU/Linux, kernel 2.6.26-1-686
    root            (hd0,0)
    kernel          /boot/vmlinuz-2.6.26-1-686 root=/dev/md0 ro quiet
    initrd          /boot/initrd.img-2.6.26-1-686
    Find the first such group. The line that starts with kernel has all the cheat codes. You might even find lang=us there. Remove it. Add lang=uk xkeyboard=gb. Save, reboot, cross-fingers etc.

    @ werner

    Klopt das oder ?

  5. #15
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Code:
    title KNOPPIX
    root (hd0,1)
    kernel /boot/vmlinuz root=/dev/sda2 rootwait lang=de apm=power-off \
    nomce libata.force=noncq tz=Europe/Berlin loglevel=7  rw
    ... this is the entry in my '/boot/grub/menu.lst'

  6. #16
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    The problems found by many in setting localisation on Knoppix may stem from the GRUB installed by the program used to create the live USB. GRUB works fine on an HD install because it is installed by Knoppix and follows the rules as given in this thread ... viz: modify the "kernel" line in menu.lst and reboot ... works for me. However, I used Unetbootin on a Kubuntu system to install the 32-bit Knoppix on a 2Gb USB. The entries in the file /boot/grub/menu.lst on the resulting live USB are for a read-only boot and the same in single user mode. The active lines in the file are:

    default 0

    color cyan/blue white/blue

    title Debian GNU/Linux, kernel 3.0.4
    root (/dev/sda,0)
    kernel /boot/vmlinuz-3.0.4 root=/dev/sda1 ro

    title Debian GNU/Linux, kernel 3.0.4 (single-user mode)
    root (/dev/sda,0)
    kernel /boot/vmlinuz-3.0.4 root=/dev/sda1 ro single

    but none of these settings apply and editing them for language and timezone thus has no effect, because Unetbootin installed a GRUB which presents a very pretty boot menu, on a graded shiny silvery-purple background, that has options for:

    Default
    adriane
    adrian64
    knoppix
    knoppix64
    debug
    debug64
    grub
    fb1024x768
    fb1280x1024
    fb800x600
    fb640x480
    memtest
    dos
    failsafe

    I presume it picked up all these options from the Knoppix ISO. The "Default" option has a boot instruction:

    /ubnkern initrd=/ubninit ramdisk_size=100000 lang=en vt.default_utf8=0 apm=power-off nomce libata.force=noneq hpsa.hpsa_allo_any=1 loglevel=1 tz=localtime

    which works, whilst the "knoppix" option uses:

    /boot/isolinux/linux initrd=/boot/isolinux/minirt.gz ramdisk_size=100000 lang=en vt.default_utf8=0 apm=power-off nomce libata.force=noneq hpsa.hpsa_allo_any=1 loglevel=1 tz=localtime

    (note the extra space in front of "nomce", presume this is a typo, it has no effect). The "grub" option tries to start from the HD and fails, all the 64-bit options barf as do "memtest" and "dos". I have not tried "adriane", but all the rest use the same boot command as "knoppix" with version specific extras. Both the "Default" and "knoppix" options will start the live USB.

    There is an option to use "tab" to edit a boot command at the boot menu, and if I use this to change the language (lang=uk) and timezone (tz=Europe/London), the live USB will boot accordingly. The changes are not permanent and have to be reapplied on each boot.

    The live USB boots with the "/boot/vmlinuz-3.0.4" that is in Knoppix 6.7.1. I have not found either /ubnkern or /boot/isolinux/... on the live USB, so presumably Unetbootin have the appropriate translation hidden somewhere. I have yet to work out how to permanently modify the Unetbootin boot menu commands. Using commands on a terminal screen on the live USB to update or install the GRUB dictated by the /boot/grub/menu.lst file have no effect ... which may well be a good thing since both mount the root file system as read-only.

    I have tried several other live USB creator programs, from Linux and Windows, and each seems to install its own GRUB, not the one supplied with Knoppix, which may explain the frustrating situations in this and other threads where localising the boot proves so problematic.

  7. #17
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    Addenda ... the boot strings should read "hpsa.hpsa_allow_any=1" not "hpsa.hpsa_allo_any=1" ... typo on my part,
    also ... "adriane64" not "adrian64" in the options list,
    my excuse is the keyboard ... some of the keys don't, occasionally.

  8. #18
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    OK ... (/Sheepish grin mode: ON) next time read all the way down the release notes page, not just the first 1/2! (/Sheepish grin mode: OFF) Wha-hey, relearning as I go.

    On the live USB, change the localisation values in the entries in /mnt-system/syslinux.cfg.

    Booting localised works fine now ... except that "grub" still tries to run the HD grub file and barfs because it then cannot find something ... "dos" and "memtest" still barf, have not chased why ... the 64 bit options probably don't like a 32-bit machine, will try them on a 64-bit laptop, when I can prise it out of my son's grip ... ADRIANE looks interesting, 'm going to have a play with that!

    Have tried making a live USB on W7 with both LinuxLive and PendriveLinux utilities ... do not get all of the Unetbootin boot menu options and the resulting USB only successfully boots from a manual command at the initial boot prompt ... possibly something not right from anti-intruder software which tries to alter the boot status of the USB after it is written ... the W7 machine needs reloading anyway ... just another reason to get on with it.

  9. #19
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    Trying "knoppix64" on a Samsung R780 laptop, which is not the usual i5 32-bit unit, but a DualCore i3 64bit machine ... Knoppix correctly detects both the real cores and the two virtual ones, but fails on the video and sound. The video card is an nVidia GT218 (aka GeForce 310M), which is not listed with the "nouveau" nVidia driver used in Knoppix, which may explain only having 1024x768 resolution available. The sound card is detected as Intel 5 series, 3400 chipset, but fails to configure at all. W7 actually provides a Realtek driver for this card.

    Are there any cheat codes available to boot with a different nVidia driver, and something that would run sound with this hardware consist?

    TIA

  10. #20
    Junior Member
    Join Date
    Jun 2012
    Posts
    1

    Question

    Quote Originally Posted by Werner P. Schulz View Post
    ... the HD-installation of Knoppix is an installation to HD like other OS (Debian, Ubuntu etc). The differences are among other things: no root password by default, no safety updates, only user knoppix.

    You can chroot within this installation for remastering purpose, but is isn't chroot'd by default. Tell me, if I'm wrong.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.4.4 remaster)
    This issue is fairly central to my question: I am coming from an Ubuntu environment so I expected to find some differences but need some help. I liked the look of 7.0.2 on the live DVD so wanted to try it out as a 64bit HD install as a possible replacement for my lxde Mint 9. Found the installer didn't have a manual install option to specify the partition for my /home folder and my pre-existing username. Also wanted to continue to use grub2 after a few years of getting used to it. So I have installed grub2 to the mbr from a live CD and did an update-grub from another partiton OS. Then after creating the additional user adding it to sudoers and editing the fstab to include the mounting of various HD partitons I find I have mount troubles. Booting with either the original knoppix user or the added user the fstab mount points are not mounted.

    Mount returns

    /dev/root on / type reiserfs (rw,relatime) proc on /proc type proc (rw,relatime) sysfs on /sys type sysfs (rw,relatime) usbfs on /proc/bus/usb type usbfs (rw,relatime) tmpfs on /tmp type tmpfs (rw,relatime,size=2097152k) udev on /dev type tmpfs (rw,relatime,size=20480k) tmpfs on /dev/shm type tmpfs (rw,relatime,size=2097152k) devpts on /dev/pts type devpts (rw,relatime,mode=1777)

    where fstab looks like:

    proc /proc proc noauto 0 0 sysfs /sys sysfs noauto 0 0 /dev/sda8 / reiserfs relatime 0 0 /dev/sda9 none swap defaults 0 0 # Added by KNOPPIX # noauto,users,exec 0 0 #Added by me /dev/sda6 /home ext3 defaults,rw 0 0 # Added by KNOPPIX /dev/sr0 /media/sr0 auto noauto,users,exec 0 0 # Added by KNOPPIX /dev/sda7 /media/sda7 ext3 noauto,users,exec 0 0 # Added by KNOPPIX /dev/sda2 /media/sda2 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0 # Added by KNOPPIX /dev/sda5 /media/sda5 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0 # Added by KNOPPIX /dev/sda1 /media/sda1 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0

    The line

    Code:
    /dev/root on / type reiserfs (rw,relatime)
    makes it look like it is booting a DVD image still and fstab seems not to be loaded. Uname -r returns 3.3.7 so I don't believe the following grub.cfg lines are doing the wrong thing.:

    menuentry "KNOPPIX (on /dev/sda" { insmod reiserfs set root='(hd0,' search --no-floppy --fs-uuid --set c20b16c7-61ef-4410-9007-62b75197301c linux /boot/vmlinuz root=/dev/sda8 rootwait lang=en apm=power-off nomce libata.force=noncq tz=localtime loglevel=1 knoppix_dir=knoppix1 lang=en ramdisk_size=100000 vt.default_utf8=0 noimage rw and cat /proc/cmdline looks consistent with this: BOOT_IMAGE=/boot/vmlinuz root=/dev/sda8 rootwait lang=en apm=power-off nomce libata.force=noncq tz=localtime loglevel=1 knoppix_dir=knoppix1 lang=en ramdisk_size=100000 vt.default_utf8=0 noimage rw

    I have tried adding mount -a in various places to force it to be loaded during boot including in /etc/rc.local and /opt/bootlocal.sh and also /etc/init.d/knoppix-start without success It would be easy to blow the install away and load something else but I wanted to give Knoppix a really good shot as everything else looks fine. Anyone have any suggestions? Any help would be much appreciated.


    -------------------------------
    Please use the "Go Advanced" button to have more abilities to format the posting; before sending your posting use "Preview" to see how it looks like.
    WPS
    Last edited by Werner P. Schulz; 06-23-2012 at 01:24 PM. Reason: unreadable posting

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •