Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Time

Hybrid View

  1. #1
    Junior Member
    Join Date
    Apr 2011
    Posts
    23

    Time

    I have just successfully installed 6.4.4 on my Dell Inspiron 1545 (6.4.3 would not install), but when I set the time, it is not "locked", so that I have to keep going in as root and resetting it and also the keyboard. Any ideas? Thanks a lot. Love this distro very much!

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    You will have to explain more 'cos I don't think anyone can visualise what you are talking about.

    What is the difference between the behaviour you expect and the behaviour you observe ?

    What is it you do to 'correct' this behaviour ? Command line ? GUI ?

    Under what circumstances does the 'corrected' behaviour cease to be in force ? Reboot ?

    Which edition of 6.4.4 are you using: CD/DVD, DE/EN, Knoppix/Adriane.

    What is your installation ? LiveCD, LiveUSB or HD install ?

    Are you using any cheat codes ?

    What continent are you on / timezone are you in ? (as long as disclosing that information isn't going to get you arrested).

  3. #3
    Junior Member
    Join Date
    Apr 2011
    Posts
    23
    Hi and thanks for the reply. I am using Knoppix hd install English. I have to use the konsole and do sudo and then time-admin to reset and also have to reset the keyboard to UK. Every time I log out or reboot I have to reset both. I am in UK. Thanks a lot.

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Quote Originally Posted by jacksbutler View Post
    I am in UK. Thanks a lot.
    Hi Jack,

    Knoppix has several cheat code that allow the user to specify what language and keyboard they are using and which timezone they are in. This is a Knoppix home-grown mechanism that sits atop to 'normal' mechanisms. It does the business for most people.

    If that isn't adequate, you can drop the cheat codes and alter the files that the cheat codes cause Knoppix to alter to get just what you want.

    I don't have a HD install so I haven't had the pleasure of fiddling with cheat codes with a HD install. After having some folks say "Yes" and other say "No", I am grateful to Werner for confirming that cheat codes are alive and well with the HD install: you just have to understand grub instead of syslinux.

    Assuming your HD Knoppix is running, open a console and type in:

    Code:
    cat /proc/cmdline
    This shows you all the cheat codes used to boot your Knoppix. I expect among these you've got:

    Code:
    lang=us
    which sets things up for use on the East Coast of the US. Knoppix tries the set the 'country', 'language', 'keyboard' and 'timezone' from just the one cheat code. This works fine in Germany but not so well in elsewhere. For someone in the UK, such as yourself, the quick answer is to try:

    Code:
    lang=uk
    but that does not work in Knoppix 6.4.4: by mistake this cheat code gives you a Ukranian X keyboard and lots of grief. The international language symbol uk means ukranian and the X windows system honours this but the Knoppix cheat codes are based on the much older convention used for console terminals (ctrl+alt+F1) that most people hardly ever use. BTW I think that lang=ie for Ireland had the same ukranian issue.

    To set the keyboard and X keyboard to something other than that implied by the lang= cheat code use the following cheat codes:

    Code:
    keyboard=uk
    xkeyboard=gb
    or whatever you fancy. To set the time zone, as Werner suggests, use:

    Code:
    tz=Europe/London
    because Berlin in generally an hour ahead of London.

    I don't know all the details of time zones but Knoppix doesn't use the normal Linux mechanism. I think this is so that Knoppix should display the correct local time regardless of whether local time or UTC is stored in CMOS. Windows systems store local time but Linux systems store UTC. Dual-boot systems have a small issue with this except in the countries like the UK where local time is UTC+0. The suggestion from Krishna I think is an attempt
    to reinstate the normal Linux mechanism. If that works for you and you are happy with it ... then fine.

    There is another snag with the time zones. I think. Since Knoppix 6.4.4 came out, the Debian project rearranged its repositories, renaming the volatile repository. This is the repository that contains the timezone information about when summer time starts and ends etc. I found the time displayed to my Knoppix in a virtual machine at work was an hour behind the time displayed by the Windows host and I suspect this is because the repository renaming snag.

    If you find the cheat codes don't give you what you want all is not lost. These cheat code are interpreted by the famous script /etc/init.d/knoppix.autoconfig. This script generates no less than five other files containing definitions used by Knoppix, Linux, X Windows, KDE and other applications. You can alter cheat codes, knoppix.autoconfig or the five files or some confusing combination of the three.

    The notes below assume your rationalisation is to leave the big scary knoppix.autoconfig alone, not use any cheat codes and alter the five files to suit. Here's approximately what I came up with:

    Code:
    $ cat /etc/timezone
    Europe/London
    Enough said.

    Code:
    $ cat /etc/sysconfig/keyboard
    KEYTABLE="us"
    XKEYBOARD="us,gb"
    KDEKEYBOARD="us,gb"
    KDEKEYBOARDS=""
    I worked in Europe a lot with different keyboards. To stay sane I always set the keyboard to "us" and just don't look at the keys. The XKEYBOARD setting allows the keyboard layout to be switched at run time if necessary (when I let someone else use my Knoppix). The separate KDE settings I suspect are redundant but KK is sentimental.

    Code:
    $ cat/etc/sysconfig/il8n
    LANG="en_GB"
    COUNTRY="gb"
    LANGUAGE="en_GB:en"
    CHARSET="utf8"
    XMODIFIERS=""
    This is another Knoppix specific configuration file. I'm not happy with it. The first entry, LANG= is the Unix/Linux locale. I tried en_GB.UTF-8 to be like Debian and then en_US.UTF-8 but both seem to be invalid under Knoppix (6.4.4). I'm not convinced the CHARSET has much effect either. For the US and UK, Knoppix uses ISO8859-1, otherwise known a Latin-1 or International Western European. For Germany and other Euro countries (including Ireland), Knoppix uses ISO8859-15, which adds the and shuffles some other interesting characters around.

    If you ever need to change a Knoppix script that contains German help text in it, make sure you tell the editor you are using the script in question is in ISO8859-15.

    There was some chap from Russia the other day complaining that Knoppix did not display the non-US (ASCII) characters in filenames on his Windows hard drive correctly. I suspect that is because CHARSET was not set to what he needed it to be set to.

    I input characters that are not on a US keyboard using the X compose key mechanism. This does not work with the default local LANG=C, which is what you get if you use the EN edition as is.

    Code:
    $ cat /etc/environment
    LANG="en_GB"
    LANGUAGE="en_GB:en"
    LC_MESSAGES="en_GB"
    This is a Debian rather than a Knoppix configuration file. I think. The declarations I use hint that I want British English, if available. Actually, despite using the EN edition of Knoppix, I found the internationalisation packages, like spell checkers, are the German versions and I had to replace them all but that's another topic.

    Code:
    $ cat /etc/default/keyboard
    XKBMODEL="pc105"
    XKBLAYOUT="us,gb"
    XKBVARIANT=""
    XKDOPTIONS="terminate:ctrl_alt_bksp,grp:alt_caps_toggle,shift:breaks_caps,compose:menu"
    This is an X Windows configuration file. I used to specify this keyboard stuff in /etc/X11/xorg.conf, another file Knoppix tends to rewrite for you. The first says I've a bog standard keyboard with 105 keys (as is the case throughout Europe I believe - in the US they tend to use pc104). The second allows me to toggle between keyboard layouts and the final line says, among other things, left-alt+caps key pair toggles between layouts.

    Note the terminate:ctrl_alt_bksp is the Knoppix default and allows you to restart a (broken) X session with the ctrl+alt+bksp key triple. This is jolly useful as utu will confirm. It is no longer the X windows default: apparently the good folks that use the Big Brown distribution are so inept they type these three keys by mistake and claim this means their distribution isn't user friendly enough.

  5. #5
    Junior Member
    Join Date
    Apr 2011
    Posts
    23
    Hi and thanks very much for the great help, but none of it works! I changed the language to lang=uk etc but it was still us english and us keyboard layout. Do I do the changes as root in the console and if so what do I do to have the changes saved?

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Posts
    242
    Quote Originally Posted by jacksbutler View Post
    Hi and thanks very much for the great help, but none of it works! I changed the language to lang=uk etc but it was still us english and us keyboard layout. Do I do the changes as root in the console and if so what do I do to have the changes saved?
    No. You're on the wrong track. Werner mentions the file /boot/grub/menu.lst. You need to back this file up and edit it. You'll probably need to be root to do this. Use nano. If I've lost already, I'm sure utu can help with Linux basics - he's been reading up recently.

    Based on the name of the file, Knoppix is still using the old grub version and I don't have a HD install so I'm scratching my head with both hands here.

    In the file you'll find groups of lines like:

    Code:
    title           Debian GNU/Linux, kernel 2.6.26-1-686
    root            (hd0,0)
    kernel          /boot/vmlinuz-2.6.26-1-686 root=/dev/md0 ro quiet
    initrd          /boot/initrd.img-2.6.26-1-686
    Find the first such group. The line that starts with kernel has all the cheat codes. You might even find lang=us there. Remove it. Add lang=uk xkeyboard=gb. Save, reboot, cross-fingers etc.

    @ werner

    Klopt das oder ?

  7. #7
    Moderator Moderator
    Join Date
    Jan 2010
    Location
    Asheville, NC, USA
    Posts
    528
    Quote Originally Posted by jacksbutler View Post
    Hi and thanks for the reply. I am using Knoppix hd install English. I have to use the konsole and do sudo and then time-admin to reset and also have to reset the keyboard to UK. Every time I log out or reboot I have to reset both. I am in UK. Thanks a lot.
    When you say "Knoppix hd install", are you talking about using the program link of that name on the Preferences menu? That "install" produces a system that is chroot'd, and really not a very good general use system (it's for re-mastering to make your own version of Knoppix, mostly.) This install produces unpredictable results in ordinary use.

    I recommend using the Flash install routine instead - it'll work with your HD, but it requires a FAT32 filesystem on partition 1, so you'll probably want to re-partition using the CD copy of GParted (again on the Preferences menu.) After booting it from this "install", you'll be prompted to create a "permanent store", which will allow operation as if it were a conventional Debian system installed to HD.

    Cheers!
    Krishna

  8. #8
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    That "install" produces a system that is chroot'd, and really not a very good general use system (it's for re-mastering to make your own version of Knoppix, mostly.)
    ... the HD-installation of Knoppix is an installation to HD like other OS (Debian, Ubuntu etc). The differences are among other things: no root password by default, no safety updates, only user knoppix.

    You can chroot within this installation for remastering purpose, but is isn't chroot'd by default. Tell me, if I'm wrong.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.4.4 remaster)

  9. #9
    Moderator Moderator
    Join Date
    Jan 2010
    Location
    Asheville, NC, USA
    Posts
    528
    Quote Originally Posted by Werner P. Schulz View Post
    ... the HD-installation of Knoppix is an installation to HD like other OS (Debian, Ubuntu etc). The differences are among other things: no root password by default, no safety updates, only user knoppix.

    You can chroot within this installation for remastering purpose, but is isn't chroot'd by default. Tell me, if I'm wrong.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.4.4 remaster)
    It sounds like you may know more than I. The impression I've gathered is that "HD install" is not recommended for the faint of heart, as it produces unpredictable results due to strange differences in user/owner of resources, etc., primarily related to the ability to remaster. Flash install, on the other hand, produces a fairly solid system for daily use, in my experience.

    Cheers!
    Krishna

  10. #10
    Junior Member
    Join Date
    Jun 2012
    Posts
    1

    Question

    Quote Originally Posted by Werner P. Schulz View Post
    ... the HD-installation of Knoppix is an installation to HD like other OS (Debian, Ubuntu etc). The differences are among other things: no root password by default, no safety updates, only user knoppix.

    You can chroot within this installation for remastering purpose, but is isn't chroot'd by default. Tell me, if I'm wrong.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.4.4 remaster)
    This issue is fairly central to my question: I am coming from an Ubuntu environment so I expected to find some differences but need some help. I liked the look of 7.0.2 on the live DVD so wanted to try it out as a 64bit HD install as a possible replacement for my lxde Mint 9. Found the installer didn't have a manual install option to specify the partition for my /home folder and my pre-existing username. Also wanted to continue to use grub2 after a few years of getting used to it. So I have installed grub2 to the mbr from a live CD and did an update-grub from another partiton OS. Then after creating the additional user adding it to sudoers and editing the fstab to include the mounting of various HD partitons I find I have mount troubles. Booting with either the original knoppix user or the added user the fstab mount points are not mounted.

    Mount returns

    /dev/root on / type reiserfs (rw,relatime) proc on /proc type proc (rw,relatime) sysfs on /sys type sysfs (rw,relatime) usbfs on /proc/bus/usb type usbfs (rw,relatime) tmpfs on /tmp type tmpfs (rw,relatime,size=2097152k) udev on /dev type tmpfs (rw,relatime,size=20480k) tmpfs on /dev/shm type tmpfs (rw,relatime,size=2097152k) devpts on /dev/pts type devpts (rw,relatime,mode=1777)

    where fstab looks like:

    proc /proc proc noauto 0 0 sysfs /sys sysfs noauto 0 0 /dev/sda8 / reiserfs relatime 0 0 /dev/sda9 none swap defaults 0 0 # Added by KNOPPIX # noauto,users,exec 0 0 #Added by me /dev/sda6 /home ext3 defaults,rw 0 0 # Added by KNOPPIX /dev/sr0 /media/sr0 auto noauto,users,exec 0 0 # Added by KNOPPIX /dev/sda7 /media/sda7 ext3 noauto,users,exec 0 0 # Added by KNOPPIX /dev/sda2 /media/sda2 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0 # Added by KNOPPIX /dev/sda5 /media/sda5 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0 # Added by KNOPPIX /dev/sda1 /media/sda1 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0

    The line

    Code:
    /dev/root on / type reiserfs (rw,relatime)
    makes it look like it is booting a DVD image still and fstab seems not to be loaded. Uname -r returns 3.3.7 so I don't believe the following grub.cfg lines are doing the wrong thing.:

    menuentry "KNOPPIX (on /dev/sda" { insmod reiserfs set root='(hd0,' search --no-floppy --fs-uuid --set c20b16c7-61ef-4410-9007-62b75197301c linux /boot/vmlinuz root=/dev/sda8 rootwait lang=en apm=power-off nomce libata.force=noncq tz=localtime loglevel=1 knoppix_dir=knoppix1 lang=en ramdisk_size=100000 vt.default_utf8=0 noimage rw and cat /proc/cmdline looks consistent with this: BOOT_IMAGE=/boot/vmlinuz root=/dev/sda8 rootwait lang=en apm=power-off nomce libata.force=noncq tz=localtime loglevel=1 knoppix_dir=knoppix1 lang=en ramdisk_size=100000 vt.default_utf8=0 noimage rw

    I have tried adding mount -a in various places to force it to be loaded during boot including in /etc/rc.local and /opt/bootlocal.sh and also /etc/init.d/knoppix-start without success It would be easy to blow the install away and load something else but I wanted to give Knoppix a really good shot as everything else looks fine. Anyone have any suggestions? Any help would be much appreciated.


    -------------------------------
    Please use the "Go Advanced" button to have more abilities to format the posting; before sending your posting use "Preview" to see how it looks like.
    WPS
    Last edited by Werner P. Schulz; 06-23-2012 at 01:24 PM. Reason: unreadable posting

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •