Results 1 to 4 of 4

Thread: My RAID array disappeared . . . why????

  1. #1
    Junior Member registered user
    Join Date
    Nov 2005
    Posts
    18

    My RAID array disappeared . . . why????

    ver: Knoppix 6.2.2 CD
    issue: softRAID array (dmraid) not showing up any more
    hardware: ASRock 770 Extreme3 motherboard

    I shut down my machine last night without explicitly unmounting one of my RAID partitions. I did a sync before shutdown, but not a umount. I just forgot. Anyway, I thought the automatic unmount done by Knoppix as it shut down would be fine.

    Now, when I boot, the RAID doesn't show up at all. I can see a /media/sda, /media/sda1, /media/sda2, /media/sdb, /media/sdb1/, and /media/sdb2. But nothing is visible in /mnt/ (where mount points are usually created), and ESPECIALLY there is no /mnt/psomething1/ or /mnt/psomething2/, which are what the two RAIDed partitions are mounted at.

    How can I get my data partitions to show up again?

    FWIW, there are two partitions, one NTFS and one EXT3.

  2. #2
    Junior Member registered user
    Join Date
    Nov 2005
    Posts
    18
    Ok, this is mildly insane. I plugged in a USB flash drive, and suddenly the mount points for the RAID partitions show up in /mnt (along with the new mount point for the flash drive), and the data looks available.

    How do I verify that the partitions aren't corrupted? Likewise the softRAID metadata?

    BTW, this is a RAID 1 mirror, two drives.

  3. #3
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    801
    Quote Originally Posted by FlameWeasel View Post
    Anyway, I thought the automatic unmount done by Knoppix as it shut down would be fine.
    I would consider that extremely optimistic. IMO, the safest way with special file systems is to execute suitable shutdown scripts. If you haven't already done it, I would also check out what Debian packages for RAID there may be, and install them.

    If you find something lacking, I think this may be a good subject for a new post to the knoppix-devel mailing list, but the more you can find out yourself first, the better.
    Good luck

  4. #4
    Junior Member
    Join Date
    May 2011
    Location
    USA
    Posts
    5
    Go to the disk manager and see its status.
    If you recreate the array may have deleted the format, so you have to do a Windows format on it. Not shown in My Computer until it has a recognizable format it (FAT, NTFS, etc)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •