Results 1 to 5 of 5

Thread: Fix for Knoppix Install Components utility

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Posts
    3

    Fix for Knoppix Install Components utility

    This has been broken for a while, maybe nobody has reported it?
    When you go to Menu>Preferences>Install Components and try to install something, nothing happens.

    Today I decided to look into it, and found that the problem is actually in /usr/sbin/checkinstall.

    This patch fixes it (at least for me):
    Code:
    # wget -O - http://dl.dropbox.com/u/17126237/checkinstall.patch | patch -p0
    These are the contents of the patch file for those interested, only one line is changed:
    Code:
    --- /usr/sbin/checkinstall.orig	2009-02-07 18:59:59.000000000 +0000
    +++ /usr/sbin/checkinstall	2011-08-06 21:10:30.936666664 +0000
    @@ -103,7 +103,7 @@
      type -p Xdialog >/dev/null 2>&1 && exec Xdialog --title "'"$TITLE"'" '"$ICON"' --msgbox "'"$FAILED"'" 10 55
     fi' >"$TMP"
     chmod 755 "$TMP"
    - ${XSHELL[@]} "$TMP"
    + "${XSHELL[@]}" "$TMP"
      rm -f "$TMP"
     }
    Hopefully somebody finds this helpful

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    steev-p

    Fine work.
    That's been around a long time.
    There should be some sort of award for this.
    I love one-liners myself.
    Welcome to the forum.

  3. #3
    Junior Member registered user
    Join Date
    Dec 2002
    Location
    Germany
    Posts
    22
    Quote Originally Posted by steev-p View Post
    This has been broken for a while, maybe nobody has reported it?
    When you go to Menu>Preferences>Install Components and try to install something, nothing happens.

    Today I decided to look into it, and found that the problem is actually in /usr/sbin/checkinstall.

    This patch fixes it (at least for me):
    Code:
    # wget -O - http://dl.dropbox.com/u/17126237/checkinstall.patch | patch -p0
    These are the contents of the patch file for those interested, only one line is changed:
    Code:
    --- /usr/sbin/checkinstall.orig	2009-02-07 18:59:59.000000000 +0000
    +++ /usr/sbin/checkinstall	2011-08-06 21:10:30.936666664 +0000
    @@ -103,7 +103,7 @@
      type -p Xdialog >/dev/null 2>&1 && exec Xdialog --title "'"$TITLE"'" '"$ICON"' --msgbox "'"$FAILED"'" 10 55
     fi' >"$TMP"
     chmod 755 "$TMP"
    - ${XSHELL[@]} "$TMP"
    + "${XSHELL[@]}" "$TMP"
      rm -f "$TMP"
     }
    Hopefully somebody finds this helpful
    Thanks for finding this! I totally missed it, probably because checkinstall worked "accidentially" with german locales, since the $TITLE contains a single word there and this fixes the wrong syntax, too, while in the english version, I had used two words for the title. Your solution is the corretco one.

    I also will also replace Xdialog by zenity in all scripts soon, since Xdialog is keeping the old gtk1 libs installed and has broken fonts when english locales are set, the "digital" fonts were NOT intentional, I have to admit it now.

  4. #4
    Junior Member
    Join Date
    Aug 2011
    Posts
    3
    Glad I could help

    @utu Thanks for the welcome.

  5. #5
    Junior Member
    Join Date
    Aug 2011
    Posts
    2
    Thanks, works perfectly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •