Results 1 to 6 of 6

Thread: Knoppix 6.7 boots to black screen on iMac

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Posts
    3

    Knoppix 6.7 boots to black screen on iMac

    I downloaded a Knoppix 6.7 DVD, verified MD5, burned a DVD, verified a good DVD and good boot on an Intel desktop. But I am trying to boot this DVD on my iMac. The boot begins normally, I see the boot prompt and can respond to it, and I can see the boot messages fly by right up until "starting hardware abstraction layer". Then the screen goes completely black. The DVD continues to whir and the sultry voice says we are starting, so sound card works. The keyboard and mouse are completely unresponsive beyond this point. I've tried debug, expert, knoppix 2, and various combinations of noacpi, noapm, failsafe, screen=2560x1440, no3d, desktop=kde, xmodule=ati, xmodule=radeon, xmodule=fbdev, norandr, nofb nodrm vga=normal. CTL-ALT-F2 does nothing --- ever. The same blank screen happens in text mode. The only way out at this point is to power cycle the machine. One of the above combinations (failsafe) caused a shell prompt to appear for less than a second before the screen blanked. When the screen goes black, it usually does so in two stages. First all the boot messages disappear and the screen has an all black background, but appears "lighted". The it goes completely dark, as if the power were just shut off. There are no flashes of words or lines or graphics -- just goes black. The boot messages indicate my graphics card has been detected as "ATI 9488" for an ATI Radeon HD 4670 wtih 256MB VRAM on PCIe bus with device ID 9488. The machine is an Apple iMac Intel 3.06 Mhz core 2 Duo with 4GB of memory and 3MB of L2 Cache. I'm using a usb keyboard and mouse and booting from a USB connected external DVD. (internal DVD scratches media) I've searched this forum for "iMac" with no results and tried Google. Any help would be very greatly appreciated. Thank you much in advance.

  2. #2
    Moderator Moderator
    Join Date
    Jan 2010
    Location
    Asheville, NC, USA
    Posts
    528
    Dear knbbob:

    It sounds like there's a graphics driver problem, and you've made some good guesses on how to work around that, I think. In order to do better, we'd need to know what chipset Apple used. I recommend starting with the exact model number in Google, and/or calling Apple or your local Apple store to get more information about what's in there. Once that's known, we can probably figure out how to get you moving in the right direction. Let us know what you find out!

    Cheers!
    Krishna
    Last edited by krishna.murphy; 09-21-2011 at 04:11 PM. Reason: OOPS!

  3. #3
    Junior Member registered user
    Join Date
    Feb 2004
    Location
    Somerset, England
    Posts
    11
    Knoppix 6.7.0 and 6.7.1 DVDs will boot on an iMac, at least they do on mine. I have a 21.5" iMac from early 2009. It's the Intel dual core 3GHz version running Snow Leopard.

    The iMac hardware detection seems mostly OK with me & certainly the graphics all work OK, even Compiz effects. What doesn't work for me are the wireless keyboard and the Apple wireless magic mouse. I use the Mac wired keyboard and a 'normal' Logitech wireless mouse.

  4. #4
    Junior Member
    Join Date
    Sep 2011
    Posts
    3

    Chipset Info

    Dear Krishna:

    Thanks for your response. I tried calling my local Apple store to see if they would tell me the chipset info. No dice. Company Proprietary. Intel provides a program to scan for the info, but only for Windows. The only way to get it is to take the iMac apart. Its still under extended warranty so I'm a little reluctant. If you google for the string, iMac Intel 27" Teardown, you should find an ifixit site with an article of the same title that shows good pictures of the innards. To get at the chip side of the motherboard requires nearly complete dis-assembly. I have to think on that. I have a 27" display and apparently that also affects the problem. The system part number is MB952LL/A and model ID iMac10,1. The site, everymac, says its model A1312 (EMC 2309) with core 2 duo (E7600). I found a program called Mactracker that is supposed to identify the chipset, but it doesn't. If anyone knows of a program/script for OSX that would probe for the chipset info I would love to try it. Unless I can overcome my reluctance to take this think apart, I may be stuck.

  5. #5
    Junior Member
    Join Date
    Sep 2011
    Posts
    3
    Dear Lang:
    Thanks for posting. I appreciate it. I have the 27" display, which apparently affects the problem. Both my wired and wireless keyboard work, at least to answer to boot messages. Dunno what would happen after Knoppix came up.

  6. #6
    Junior Member
    Join Date
    Oct 2011
    Posts
    1
    Hi
    I have a similar problem on my netbook toshiba nb550d with ATI Mobility Radeon HD 6250 graphic. The live CD (CD/DVD connected on USB) does boot but at the it appears a screen with white stripes and points and the system is frozen. Like Knbob I have to push the power button.
    Thank's in advance.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Apple Magsafe 60W Power Adapter Macbook Charger Genuine OEM - A15
$29.62
Apple Magsafe 60W Power Adapter Macbook Charger Genuine OEM - A15 pictureOriginal OEM 85W Charger for 2008 2009 2010 2011 APPLE MacBook Pro 15" 17" A1343
$30.6
Original OEM 85W Charger for 2008 2009 2010 2011 APPLE MacBook Pro 15MacBook Air A1465 11" 2015 MJVM2LL/A OEM Battery 7.6V 38.75Whr 5100mAh 661-7467
$9.99
MacBook Air A1465 11Apple MacBook Pro 85W MagSafe2 OEM Power Supply NSW25679 - untested, frayed cord
$14.99
Apple MacBook Pro 85W MagSafe2 OEM Power Supply NSW25679 - untested, frayed cord pictureOEM Apple 60W Magsafe 2 Mag 2 Power Adapter Charger Laptop Charger
$15.0
OEM Apple 60W Magsafe 2 Mag 2 Power Adapter Charger Laptop Charger  picture