Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Knoppix 6.7.1 Setting The Right Time?

  1. #1
    Junior Member
    Join Date
    Apr 2011
    Posts
    23

    Knoppix 6.7.1 Setting The Right Time?

    Hi, just downloaded and installed the cd version of 6.7.1. All successful, but cannot set the time? I have tried doing "time-admin" through the root terminal but nothing happens. It comes up with : "command not found". Any ideas? Thanks. By the way, this is a lot better than 6.4!

  2. #2
    Moderator Moderator
    Join Date
    Jan 2010
    Location
    Asheville, NC, USA
    Posts
    528
    You could always set the time in the BIOS...

    The big trouble I ran into in the past was having a dual-boot system, where Windows and Knoppix both have to interpret the time correctly. Knoppix has a tendency to clear out stuff that you'd rather have set ongoingly, like the timezone (because it's essentially based on a system philosophy that assumes it is loaded from a non-writable medium.) So, I ended up changing some stuff in the startup script(s) to make it work better for me. That's the beauty of the Linux approach!

    Let us know what you decide to do, and if you need help doing it, we're ready to help.

    Cheers!
    Krishna

  3. #3
    Junior Member
    Join Date
    Apr 2011
    Posts
    23
    Hi there and thanks for the reply. I am only running Knoppix on this Dell Inspiron 1545 so would very much lie to know how to set the time right. I could install the dvd version, but that has an awful lot of stuff on it that I never use. This cd version is just about perfect for me! Thanks once again.

  4. #4
    Junior Member
    Join Date
    Apr 2011
    Posts
    23
    Hi there, solved the problem by going into boot system and setting the clock right there. Thanks a lot.

  5. #5
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    I always use in BIOS Greenwich time (UTC). For Linux you need in '/etc/default/rcS' the item: "UTC=yes" and within the kernel line the item "tz=..". Change "tz=.." as you need for your region; I have "tz=Europe/Berlin". Possible items for "tz" you'll find in '/usr/share/zoneinfo'.

    To avoid trouble in case of Dualboot with Windows, you must force Windows also to use UTC.
    Go to the registry key
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
    
    and create a dword-entry
    RealTimeIsUniversal=1
    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.7.1 remaster)

  6. #6
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    There are contrarians like myself that go for tz=localtime,
    keep the hw clock on local, Windows happy & lxpanel clock happy,
    only date= is off by difference between local & utc.

    I've never found a way to set the hw clock that lets you have
    Windows happy, date= on utc & lxpanel clock on local.
    tz=/America/New_York is NOT for me.

    I'm not sure, but I think KK sets up the EN version of Knoppix
    this way.
    Last edited by utu; 09-22-2011 at 05:52 PM.

  7. #7
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    If you use UTC within BIOS and let Linux and Windows do the job, to calculate your local time, all are happy

    You'll get right time (also summertime and wintertime here in Europe) and the right date in the panel display either of Linux or of Windows.

    KK uses "tz=localtime" within Knoppix as default in the hope, users are clever and change it to timezone of their region.

  8. #8
    Junior Member
    Join Date
    Jun 2011
    Posts
    23
    Quote Originally Posted by utu View Post
    I've never found a way to set the hw clock that lets you have
    Windows happy, date= on utc & lxpanel clock on local.
    tz=/America/New_York is NOT for me.
    If you using persistent storage, then
    1. Change in '/etc/default/rcS' the line 'UTC=no'
    2. Then use tz=/America/New_York during boot process

    I would suggest 'UTC=no' to be default option in future distros OR
    Make 'noutc' option in bootprompt ( I hope its not available currently)
    Last edited by vkrishn; 09-23-2011 at 02:09 AM. Reason: Typo

  9. #9
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    ... that's not the UNIX/ Linux way and you'll run in trouble in case of dualboot systems.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD with Knoppix (Knoppix V6.7.1 remaster)

  10. #10
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Seems to me vkrishn's way is the Debian way.
    Works for me. I prefer NOT to modify my Windows install in any way.

    My only adaptation here (now) is ALSO to modify ALL instances of tz=localtime
    in /mnt-system/boot/syslinux/syslinux.cfg to tz=America/New_York.

    Dual booting that chains through or modifies my HDD's MBR have always been
    a problem for me. My Dell laptop has a nice boot management feature
    that allows one to select from its menu what device to boot. If my
    Linux's are always self-bootable on USBs or CDs I never have to modify
    the Windows install in any way.

    I like fixing broken Linuxes, but I cringe at the thought of trying
    to fix a broken Windows system.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


16GB Memory Dell XPS 15 9560 DDR4 RAM Upgrade picture

16GB Memory Dell XPS 15 9560 DDR4 RAM Upgrade

$50.95



CORSAIR - VENGEANCE LPX 16GB (2PK x 8GB) 3200MHz DDR4 C16 DIMM Desktop Memory... picture

CORSAIR - VENGEANCE LPX 16GB (2PK x 8GB) 3200MHz DDR4 C16 DIMM Desktop Memory...

$44.99



Samsung 16GB 2Rx4 PC3L-12800R DDR3-1600 1.35V ECC REG RDIMM Server Memory RAM 1x picture

Samsung 16GB 2Rx4 PC3L-12800R DDR3-1600 1.35V ECC REG RDIMM Server Memory RAM 1x

$10.99



HyperX FURY DDR4 8GB 16GB 4GB 32GB 2666MHz PC4-21300 Desktop RAM Memory DIMM 288 picture

HyperX FURY DDR4 8GB 16GB 4GB 32GB 2666MHz PC4-21300 Desktop RAM Memory DIMM 288

$26.95



8GB SODIMM 2Rx8 PC3L 12800S DDR3 DDR3L Laptop Memory Ram HP Dell lenovo picture

8GB SODIMM 2Rx8 PC3L 12800S DDR3 DDR3L Laptop Memory Ram HP Dell lenovo

$13.99



16GB 2 x 8GB DDR3 1333 REG Memory RAM for DELL PRECISION T5500 T5600 T7500 T7600 picture

16GB 2 x 8GB DDR3 1333 REG Memory RAM for DELL PRECISION T5500 T5600 T7500 T7600

$17.99



HyperX FURY DDR3 4GB 8GB 16GB 32G 1333 1600 1866 Desktop RAM Memory DIMM 240pins picture

HyperX FURY DDR3 4GB 8GB 16GB 32G 1333 1600 1866 Desktop RAM Memory DIMM 240pins

$12.95



Corsair Vengeance LPX 32GB PC4-25600 DDR4-3200 Memory - CMK32GX4M2E3200C16 picture

Corsair Vengeance LPX 32GB PC4-25600 DDR4-3200 Memory - CMK32GX4M2E3200C16

$70.19



16GB Memory Dell OptiPlex 3050 SFF (Small Form Factor) DDR4 RAM Upgrade picture

16GB Memory Dell OptiPlex 3050 SFF (Small Form Factor) DDR4 RAM Upgrade

$50.95



A-Tech 16GB 2 x 8GB PC3-12800 Laptop SODIMM DDR3 1600 Memory RAM PC3L 16G DDR3L picture

A-Tech 16GB 2 x 8GB PC3-12800 Laptop SODIMM DDR3 1600 Memory RAM PC3L 16G DDR3L

$33.99