Results 1 to 10 of 10

Thread: Why is not possible to install other languages for LibreOffice???????????????????

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Posts
    4

    Why is not possible to install other languages for LibreOffice???????????????????

    I run KNOPPIX V6.4.4 DVD EN from the HDD of my Amilo La1703 notebook using a persistent image (knoppix-data.img). (The 6.7.1 KNOPPIX version doesn't work with my notebook at all, it seems to have problems with my notebook's graphics: chrome 9.) I have tried many operating systems and I found KNOPPIX the best in the handling the hardware and in general I am very satisfied with this OS. But there is a big problem and I can't resolve it. I want to use LibreOffice and it's Help in my native language (Hungarian) but is not possible to install the Hungarian language pack because Synaptic wants to remove a lot of packages (...brasero...clamtk...compiz...gedit...gimp...kin o...synaptic.......) for this reason. I don't uderstand this: I want to install only a simple language pack for LibreOffice and why is not possible this when there is installed the German language pack yet!!! The German language pack why doesn't create problems????????? Please, who knows the solution tell me, too!

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,408

    An alternative suggestion

    @ szzsqing1
    .
    I don't have an answer to your question, but if some of our senior
    members don't have an answer either, then I have an alternative you might consider.

    PCLinuxOS has an LXDE version similar to Knoppix, but an older kernel, and not
    as good on some video drivers as Knoppix. Has a peculiar way of handling LO.
    It is not in the base install, but an option loaded with 'LOManager'. IIRC,
    LOManager has an option up front to select the language, and is not limited to just
    English & German. Perhaps that's why it is handled this way.

    Hope that helps.
    Last edited by utu; 11-20-2011 at 05:42 PM.

  3. #3
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    925
    ???????????????????
    Please, don't cry!

    You'll run in trouble using an old version of Knoppix and trying to install something. In the meantime Debian "testing" became "stable" and so on; therefore with the '/etc/apt/sources.lst' from 6.4.4 you get other results than with the '/etc/apt/sources.lst' from 6.7.1.

    And the version of LibreOffice within 6.4.4 is 1:3.3.0-1 and is 1:3.4.4-3 within 6.7.1.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD (Knoppix V6.7.1 remaster)
    Last edited by Werner P. Schulz; 11-20-2011 at 09:28 PM.

  4. #4
    Member registered user
    Join Date
    Apr 2009
    Location
    Christchurch, New Zealand
    Posts
    34
    Hi szzsqing1

    2 quick suggestions

    re not getting 6.7.1 to run on a computer that will run 6.4.4 perfectly well - you might try using the cheatcodes at boot time

    <knoppix nodrm no3d>

    - this worked for me on an old Compaq desktop- when the graphics display just seized up completely when trying to boot without them - somewhere on the dvd you will find other cheatcodes to fix graphics problems so you might find better ones - actually the 'somewhere' on my DVD is:

    /media/sr0/KNOPPIX/knoppix-cheatcodes.txt

    re getting the Hungarian language pack and dictionaries - I've had to find a workaround even for en-gb language packs and dictionaries as often the debian repositories synaptic uses don't come up with compatible packages for your libreoffice/openoffiice main packages

    - so what I have done is go and look for the package I want on either the Debian or the Ubuntu [heresy] packages sites [google package name] and find there the language package or dictionary you want [somewhere among lenny, wheezy, squeeze or sid] with the same 3 figure version names - so if your main installed libreoffice packages are 3.3.0 [check in synaptic] then this is the package version you need for your lnguage pack - not 3.3.1 or 3.3.2 or whatever. So far I've managed to find what i need somehow, downloaded it and installed it with:

    dpkg -i *.deb

    I know this isn't the orthodox answer but it does sometimes work perfectly well - and uses a lot less download quota than reinstalling a whole new version of your office suite just to get a compatible language pack and dictionary.

    Best wishes, John

  5. #5
    Junior Member
    Join Date
    Aug 2011
    Posts
    4
    I don't know if PCLinuxOS is as good for my purposes as knx, if it has the feature being copied to hdd and running from there as knoppix does (fromhd=/dev/...), what package management system uses (deb?), etc. But I will inquire about PCLinuxOS when I'll have time.

    Thanks for suggestion.

  6. #6
    Junior Member
    Join Date
    Aug 2011
    Posts
    4
    Thanks for your answer but I don't think that this is the problem. I succeded to run V6.7.1 with my notebook (using johnmd's advice) but there was no difference: Synaptic wanted to remove the same packages as at V6.4.4.

  7. #7
    Junior Member
    Join Date
    Aug 2011
    Posts
    4
    Thanks for your answer.

    Yes, the cheatcodes helped me. I found for my notebook Amilo La1703 the best combination is: knoppix nodrm nofb no3d|nocomposite.
    But I don't think I'll use V6.7.1, because I found these problems (in the first half hour):
    1. When setting my DSL connection, after pressing the Save button, Network Manager crashed. Well, I could it restart with Root Terminal (root@Microknoppix:/home/knoppix# NetworkManager) and then the connection worked, but at V6.4.4 there is not such problem.
    2. VLC once opened couldn't be closed, only killing it with System Monitor.
    However I found a positive thing: Gnome Player workes with full screen at V6.7.1 (at V6.4.4 my system restarts if I swith the full screen with mplayer).

    I downloaded LibO_3.3.0_Linux_x86_helppack-deb_hu.tar.gz and LibO_3.3.0_Linux_x86_langpack-deb_hu.tar.gz (V6.4.4 has LibreOffice 3.3.0). But I couldn't install the debs with dpkg: there was unsatisfied dependences (libobasis... ... ...).

    For all who wrote to me:

    Actually I succeded to install somehow LO with Hungarian language, but I am not very satisfied with this installation...
    I removed with Synaptic libreoffice-core and the packeges that needed selected for this. But at the end I got: 'An error occured! E: postgresql-common: installed post-installation script alfolyamat 1 hibakóddal kilépett (... subprocess exited with error code 1)'.
    But the LibreOffice package was removed.
    After this I downloaded the newest LO from it's website (LibO_3.4.4_Linux_x86_install-deb_en-US.tar.gz, LibO_3.4.4_Linux_x86_langpack-deb_hu.tar.gz, LibO_3.4.4_Linux_x86_helppack-deb_hu.tar.gz) and I succeded to install it with dpkg.
    This LO version seems to work perfect, the only thing what flusters me is that error message.

  8. #8
    Member registered user
    Join Date
    Apr 2009
    Location
    Christchurch, New Zealand
    Posts
    34
    Hi szzsqing1

    Yes I got the same message when replacing Libreoffice with Openoffice, see my post:

    http://www.knoppix.net/forum/threads...reOffice-3.3.3

    I got rid of the error message, [which would come up again each time I tried to install any other software using synaptic or aptitude] by simply uninstalling postgresql8.4 and postgresql-common [and maybe a couple of other related installed packeges that came up in a synaptic search for postresql packages].

    This seems to leave Openoffice [and all the other programmes that I use] still perfectly functional - but of course it might mess up something else you needed to run [but which i don't use]. So far it hasn't bothered me.

    So that is a possible fix but definitely not an elegant one. I wonder if it is due to there being later versions of postgresql in the synaptic package list, v9.0 and v9.1 and perhaps the new Libreoffice prefers to work with one of them rather than with v8.4 [the installed version with knoppix 6.7.1] - but this is only a guess.

    Best wishes, John

  9. #9
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    This "clash" with postgresql-common remains in KX7.0. Installing any language package for LO triggers an upgrade of all the LO components already installed. In my case, attempting to add the en-GB pack triggered an upgrade for LibreOffice, which in turn required an upgrade of python-uno and this triggered a re-setup of postgresql-common.

    What appears to be happening is that as part of the configuration of postgresql-common by dpkg, a request to start the PostgreSQL-8.4 database server is made and this start process fails.

    The consequent failure of the python-uno upgrade left a ".lock" file in place. Running "sudo apt-get -f install" after removing the lock file fixed most of the python-uno upgrade, except for the situation in postgresql-common.

    Setting up postgresql-common (113) ...
    Starting PostgreSQL 8.4 database server: mainThe PostgreSQL server failed to start. Please check the log output: 2012-04-11 22:12:12 BST FATAL: konnte Serverzertifikatsdatei >>server.crt<< nicht laden: Datei oder Verzeichnis nicht ge ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing postgresql-common (--configure):
    subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
    Errors were encountered while processing:
    postgresql-common
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    The queston is ...why is dpkg requesting the database server to start? Is the server required in order for dpkg toconfigure an upgrade? If not, why the call?

    I fixed the situation by removing postgresql-8.4 via apt-get, then running "sudo apt-get -f install" to clean up. That reported postgresql-common as suitable for autoremove, which I also ran.

    Now both the LO language and help packages for en-GB went straight in, as did myspell-en-gb ... although I had to use "-t testing" to get the latest version of the dictionary.

    No problems yet found from the removal of PostgreSQL. Any information as to whether I have put anything else at risk by this removal would be appreciated.

  10. #10
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    462
    [quote]The queston is ...why is dpkg requesting the database server to start? Is the server required in order for dpkg toconfigure an upgrade? If not, why the call?[/code] I think that there were files upgraded that were in use by the server.

    When I got the error message about the missing file 'server.crt' I searched a while with Google. Then I found the command
    Code:
    sudo make-ssl-cert generate-default-snakeoil --force-overwrite
    followed by
    Code:
    sudo dpkg -a --configure
    sudo apt-get -f install
    Using a self-signed certificate could provide a security issue in a production environment but I think that it is safe to use in Knoppix.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •