Results 1 to 8 of 8

Thread: Audacity not running in 6.7.1, also Kompozer

  1. #1
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40

    Audacity not running in 6.7.1, also Kompozer

    I installed Audacity via the "Preferences, install components" option, on both live USB and HD installs, but it will not start from the menu selection, on either installation. I presumed this was just a glitch to my installs and put it to one side to investigate later ... but now I have the same situation with "Kompozer" which I have just added to both installs with Synaptic. These are both still near vanilla Knoppix 6.7.1 installs, so what possibles may have I wrong?

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    509
    What happens if you start the program from the shell? I suggest that you open a terminal and issue
    Code:
    audacity

  3. #3
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40

    Audacity not running in 6.7.1, also Kompozer

    Both Audacity and Kompozer give:
    Code:
    Gnome-WARNING **: Accessibility: failed to find module 'libgail' which is needed to make this application accessible **
    Audacity also reports:
    Code:
    ERROR:accessible.c:556:spi_accessible_construct: assertion failed: (o) Aborted
    Kompozer also reports:
    Code:
    ERROR:accessible.c:556:spi_accessible_construct: assertion failed: (o) /usr/lib/kompozer/run-mozilla.sh: line 131:  4310 Aborted                 "$prog" ${1+"$@"}
    Module "libgail" appears to be missing.
    Last edited by Gondarc; 11-29-2011 at 04:04 PM. Reason: Layout errors

  4. #4
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    509
    I would try to install the package libgail-common.

  5. #5
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    Package 'libgail-common' is installed, version 2.24.6-1. May have come as part of an upgrade performed to resolve http://www.knoppix.net/forum/threads...ter-HD-install ... but it has not fixed the situation, both Audacity and Kompozer still report "failed to find module 'libgail' ". An upgrade to version 2.24.8-2 is available from the unstable repository, but would this fix a situation where the module cannot be found at all?

  6. #6
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    509
    I would suggest that you try
    Code:
    sudo apt-get update
    sudo apt-get -t testing install libgail-common
    I tried this myself after installing Audacity with Synaptic package management and was able to start Audacity 1.3.12-beta.

  7. #7
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    Yo! That did the trick and the install pulled in upgrades on several related packages. Now both Audacity and Kompozer start. Thank you ... I have some overdue website changes to make.

  8. #8
    Junior Member
    Join Date
    Jan 2012
    Posts
    2
    Solved the Audacity issue on my 0wn install on eeepc x101

    Audacity started not from lxde menu bar nor on terminal.
    Code:
    knoppix@Microknoppix:~$ sudo audacity
    worked.

    I post just some of my logs.

    Code:
    knoppix@Microknoppix:~$ sudo apt-get update 
    ...
    Paketlisten werden gelesen... Fertig
    knoppix@Microknoppix:~$ sudo apt-get -t testing install libgail-common
    ...
    
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
      libqt4-sql-mysql libqt4-dbus libqt4-qt3support mysql-common libqtcore4
      libqt4-sql libqt4-xml libqt4-network libqt4-designer libmysqlclient16
      libqtgui4 libqt4-script qt4-qtconfig
    Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
    Die folgenden zusätzlichen Pakete werden installiert:
      libgail18 libgnome2-0 libgnome2-common libgtk2.0-0
    Vorgeschlagene Pakete:
      desktop-base
    Die folgenden Pakete werden aktualisiert (Upgrade):
      libgail-common libgail18 libgnome2-0 libgnome2-common libgtk2.0-0
    5 aktualisiert, 0 neu installiert, 0 zu entfernen und 948 nicht aktualisiert.
    Es müssen 5.920 kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 534 kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]? J
    Hole:1 http://ftp.de.debian.org/debian/ testing/main libgnome2-0 i386 2.32.1-2 [484 kB]
    Hole:2 http://ftp.de.debian.org/debian/ testing/main libgnome2-common all 2.32.1-2 [1.617 kB]
    Hole:3 http://ftp.de.debian.org/debian/ testing/main libgail-common i386 2.24.8-2 [612 kB]
    Hole:4 http://ftp.de.debian.org/debian/ testing/main libgail18 i386 2.24.8-2 [476 kB]
    Hole:5 http://ftp.de.debian.org/debian/ testing/main libgtk2.0-0 i386 2.24.8-2 [2.731 kB]
    Es wurden 5.920 kB in 24 s geholt (242 kB/s)                                  
    (Lese Datenbank ... 20%
    dpkg: Warnung: Dateilisten-Datei des Paketes »cloop-utils« fehlt, es wird angenommen,
    dass das Paket derzeit keine Dateien installiert hat.
    (Lese Datenbank ... 75018 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Ersetzen von libgnome2-0 2.30.0-1 (durch .../libgnome2-0_2.32.1-2_i386.deb) ...
    Ersatz für libgnome2-0 wird entpackt ...
    Vorbereitung zum Ersetzen von libgnome2-common 2.30.0-1 (durch .../libgnome2-common_2.32.1-2_all.deb) ...
    Ersatz für libgnome2-common wird entpackt ...
    Vorbereitung zum Ersetzen von libgail-common 2.24.6-1 (durch .../libgail-common_2.24.8-2_i386.deb) ...
    Ersatz für libgail-common wird entpackt ...
    Vorbereitung zum Ersetzen von libgail18 2.24.6-1 (durch .../libgail18_2.24.8-2_i386.deb) ...
    Ersatz für libgail18 wird entpackt ...
    Vorbereitung zum Ersetzen von libgtk2.0-0 2.24.6-1 (durch .../libgtk2.0-0_2.24.8-2_i386.deb) ...
    Ersatz für libgtk2.0-0 wird entpackt ...
    dpkg: Warnung: Altes Verzeichnis »/etc/gtk-2.0« kann nicht gelöscht werden: Das Verzeichnis ist nicht leer
    Trigger für man-db werden verarbeitet ...
    Trigger für gconf2 werden verarbeitet ...
    libgnome2-common (2.32.1-2) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/sound/events/gnome-2.soundlist wird installiert ...
    Neue Version der Konfigurationsdatei /etc/sound/events/gtk-events-2.soundlist wird installiert ...
    libgnome2-0 (2.32.1-2) wird eingerichtet ...
    libgtk2.0-0 (2.24.8-2) wird eingerichtet ...
    libgail18 (2.24.8-2) wird eingerichtet ...
    libgail-common (2.24.8-2) wird eingerichtet ...
    knoppix@Microknoppix:~$
    was sucessfull bringing Audacity to work in Terminal
    Code:
    knoppix@Microknoppix:~$ audacity
    
    (Audacity:3140): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.
    
    (Audacity:3140): atk-bridge-WARNING **: IOR not set.
    
    (Audacity:3140): atk-bridge-WARNING **: Could not locate registry
    Some warnings, but

    Audacity at work. Thanks Klaus2008

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •