Results 1 to 5 of 5

Thread: LXDE display glitch in 6.7.1

  1. #1
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40

    LXDE display glitch in 6.7.1

    Every so often I boot either live USB or HD install and the WM has lost the surround on each window ... no title bar, so no minimise maximise or exit buttons, and no bottom or side edges. Cure is to reboot. Is there any command or action I can take to rectify this without rebooting?



  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    512
    Two suggestions:

    1) (Re-) start compiz with the menu entry from the "Preferences" menu

    2) Restart the Xserver with the Ctrl-Alt-Backspace key combination

  3. #3
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    Quote Originally Posted by klaus2008 View Post
    Two suggestions:

    1) (Re-) start compiz with the menu entry from the "Preferences" menu

    2) Restart the Xserver with the Ctrl-Alt-Backspace key combination
    I get this problem every now and then. For my case, restart compiz does not fix the problem. Re-start Xserver can fix the problem but it's a little more painful. I always managed to fix the problem by doing this at any terminal windows :-

    Code:
       $ gtk-window-decorator --replace &
    I don't know why gtk-window-decorator misbehaved for my case. It is still running but it just misbehaved, so restarting compiz fixes nothing. If 'gtk-window-decorator' has died, then restarting compiz will fix the problem.

  4. #4
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Quote Originally Posted by Gondarc View Post
    ... no title bar, so no minimise maximise or exit buttons, and no bottom or side edges...
    I have this problem on rare occasion and control-alt-backspace gets me going again.
    A little faster recovery than a reboot for me.

    I don't recall that re-starting Compiz fixed it for me, but I have limited some of Compiz's tricks.

    I suspect that the cure may depend somewhat on what you have for video hardware.
    Mine is Intel GM45.
    Last edited by utu; 12-01-2011 at 04:46 AM.

  5. #5
    Member
    Join Date
    Nov 2011
    Location
    Somerset, UK
    Posts
    40
    Restarting Xwindow does it for me ... not Compiz ... this machine is quirky and a bit battered anyway, so nothing hardware related would surprise me ... Intel 945 Mobile, I think. So ... fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Knoppix Live GNU Linux System 9.1 on Bootable CD / DVD / USB Flash Drive picture

Knoppix Live GNU Linux System 9.1 on Bootable CD / DVD / USB Flash Drive

$14.99



KNOPPIX 9.1 LINUX INSTALL & LIVE DVD picture

KNOPPIX 9.1 LINUX INSTALL & LIVE DVD

$9.99



Knoppix Linux Bootable OS v8.6

Knoppix Linux Bootable OS v8.6 "Original Live Operating System" 16G USB Stick

$19.10



KNOPPIX LINUX 9.1 + PERSISTENCE 32GB bootable KINGSTON LIVE USB 3.1 picture

KNOPPIX LINUX 9.1 + PERSISTENCE 32GB bootable KINGSTON LIVE USB 3.1

$16.99



Knoppix Hacks O'Reilly Media 2005 CD-ROM Disc Only Linux picture

Knoppix Hacks O'Reilly Media 2005 CD-ROM Disc Only Linux

$5.39



Dell Optiplex SX270 P4 3 GHz, 1 GB ram, LCD 17, HDD 40GB, XP License, Knoppix picture

Dell Optiplex SX270 P4 3 GHz, 1 GB ram, LCD 17, HDD 40GB, XP License, Knoppix

$25.00



Linux Knoppix 9.1 Desktop 64bit Live Bootable DVD Rom Linux Operating System picture

Linux Knoppix 9.1 Desktop 64bit Live Bootable DVD Rom Linux Operating System

$4.80



Knoppix Linux Bootable OS v8.6

Knoppix Linux Bootable OS v8.6 "Original Live Operating System" 32G USB Stick

$19.75