Results 1 to 8 of 8

Thread: grub2 upgrade - problems

  1. #1
    Junior Member
    Join Date
    Jan 2012
    Location
    UK
    Posts
    7

    Question grub2 upgrade - problems

    Hi,

    I have Knoppix 6.7.1 installed on the HDD of my laptop, dual booting with Windows 7. All was working fine untill I upgraded to grub2. Since the upgrade I have two problems:
    a) my wireless nic is no longer detected/active
    b) the Windows 7 boot option is no longer on the Grub boot menu

    Can anyone advise how/where to track down solutions for either of these?

  2. #2
    Junior Member
    Join Date
    Jan 2012
    Location
    UK
    Posts
    7
    Solution to Windows option missing from Grub2 menu:

    You need root privileges for this method, so use Root Shell or sudo.

    Edit file:
    /etc/grub.d/40_custom
    At the end of the file add:
    menuentry "Windows 7" {
    set root=(hd0,1)
    chainloader +1

    }
    (Note this works for my installation of Windows 7, which boots from the first partition (sda1) - Grub2 numbers partitions from 1 not from 0)

    In a root terminal (or use sudo), run:
    update-grub
    That's it, thats what worked for me.
    From my original post, I still have to restore my Wireless network, which isn't proving as easy to track down. Anyone able to help resurrecting wireless networking?

  3. #3
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    I think that you should compare the old configuration file menu.lst and the new one grub.cfg concerning the boot parameters for Knoppix.

    You can find many web pages with tutorials about the configuration of GRUB 2. I think that "GRUB 2 bootloader - Full tutorial" could be a good place to start.

    If you still have problems then I would suggest that you show us the content of the configuration file grub.cfg and give a detailed description of where your Windows partition resides (drive number and partition number).

    I hope this helps.

  4. #4
    Junior Member
    Join Date
    Jan 2012
    Location
    UK
    Posts
    7
    Sorry Klaus,

    I updated this post about 8 hours ago - clearly it didn't take (grrrr), here's what should have uploaded...

    Fix for missing Windows link in Grub2 menu:

    The steps for this require root access, so use Root Shell or sudo.

    Edit file:
    /etc/grub.d/40_custom
    Add this section to the end of the file:
    menuentry "Windows 7" {
    set root=(hd0,1)
    chainloader +1
    }
    (Note this worked for me as Windows boots from first partition (sda0,0) - partition numbering changes in Grub2, now starts at 1 not 0)

    At command prompt run:
    update-grub
    That's it, this curred my missing Windows option in grub2 menu.
    Missing wireless is proving harder to track down, and is still causing a problem if anyone can help?

  5. #5
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Within the link Klaus told you, you can find this hint:
    30_os-prober is the script that will scan the hard disks for other operating systems and add them to the boot menu.
    Perhaps it isn't yet installed. Install it and try update-grub once more. There is no need to edit '/etc/grub.d/40_custom' manually.

    Greetings Werner * http://www.wp-schulz.de/knoppix/summary.html
    Own Rescue-CD (Knoppix V6.7.1 remaster)

  6. #6
    Junior Member
    Join Date
    Jan 2012
    Location
    UK
    Posts
    7
    Apologies for the double post - as a newbie all posts are manually vetted, and I was caught by the time lag involved.

    Further to the wireless problem, I'm now thinking this is only coincidental with the grub change not part of it. As I have discovered wireless availability appears/disappears depending which kernel I choose at boot.

    When I boot to kernel 3.0.4 everything is fine; however when I boot to the newer 3.0.4-64 I loose my wireless. Realise "loose" isn't a very helpful term - when in 3.0.4-64, from a prompt I can run
    Code:
    $ lspci -vnn | grep 14e4
    and get a response which identifies the wireless hardware. However, within the gui shell I can only see settings for wired connections. Also (being a laptop) LED wireless indicator is OUT and does not respond to attempts to turn it back on.

    From Synaptic I can see the same drives for the wireless card are available for both kernels. Can someone advise where to go/check next?

  7. #7
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    I would suggest the following. I suppose that you use your HDD install of Knoppix.
    Boot the Linux 3.0.4 kernel. Open a terminal and issue
    Code:
    sudo lsmod > /home/knoppix/lsmodules-3.0.4.txt
    Reboot the system, but now use the Linux 3.0.4-64 kernel. Open a terminal and issue
    Code:
    sudo lsmod > /home/knoppix/lsmodules-3.0.4-64.txt
    Then you can compare the two text files and try to find out whether one kernel module was missing when you used the 3.0.4-64 kernel.

  8. #8
    Junior Member
    Join Date
    Jan 2012
    Location
    UK
    Posts
    7
    Thanks Klaus,

    These modules are loaded by 3.0.4 but not by 3.0.4-64:
    Code:
    Module                  Size  Used by
    arc4                     994  2 
    lib80211_crypt_tkip     6273  0 
    joydev                  6662  0 
    wl                   1936903  0
    and this module by 3.0.4-64 only:
    Code:
    Module                  Size  Used by
    edac_core              30522  0
    Reading around, I've found a post which advises
    To make the module load at boot, add wl (and lib80211/lib80211_crypt_tkip, if needed) to your MODULES array in /etc/rc.conf
    however on my system I don't have a /etc/rc.conf file. Should I create it, or do the module load instructions go elsewhere?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •