Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Bluetooth Issue on ....

  1. #1
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157

    Bluetooth Issue on ....

    Hi, I'm a new fan of the Knoppix USB System and so far it works great. Right now the only trouble is that on my Laptop HP Pavilion g6-1b67ca I can't get Bluetooth to work with Knoppix 6.71

    1) The Bluetooth device is identified as:
    root@Microknoppix:/home/knoppix# lspci
    7:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter
    (PCI-Express) (rev 01)

    2) Synaptic Package Manager shows the following packages as installed:
    bluetooth, bluez, bluex-alsa, bluez-audio, bluez-cups, bluez-gstreamer,
    bluez-utils and libbluetooth3.

    3) I find the Bluetooth Icon under Preferences in the Main menu and when I click on it the
    Bluetooth Preferences window opens. Here it says: "Bluetooth is disabled" and
    click on "Turn On Bluetooth" button doesn't do anything.

    What is missing and what can I do?

    PS.: I added a line to /etc/apt/sources.list like this:
    deb http://ftp.de.debian.org/debian squeeze main and refreshed the packages in Synaptic in order to get Bluetooth packages.

  2. #2
    Member Blacksimon's Avatar
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    93
    Hi Karibu,
    read this http://knoppix.net/forum/threads/295...tooth-Problem-!!!
    I've solved my bluetooth problem

  3. #3
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    Quote Originally Posted by Blacksimon View Post
    Hi Karibu,
    read this http://knoppix.net/forum/threads/295...tooth-Problem-!!!
    I've solved my bluetooth problem
    OK! Thank you...I'll give it a try...

  4. #4
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    Originally Posted by Blacksimon
    Hi Karibu,
    read this http://knoppix.net/forum/threads/295...tooth-Problem-!!!
    I've solved my bluetooth problem

    Unfortunately not working for my computer!
    It is not a USB Bluetooth device but a built-in Atheros chip! See orig, post.

    Any other idea?
    Last edited by Karibu; 03-02-2012 at 07:53 AM. Reason: more info

  5. #5
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    I think that if there exists a kernel module corresponding to your bluetooth device then you could simulate unplugging and replugging of your bluetooth adaptor by using the program 'modprobe'. See the manual page of modprobe. The program 'lsmod' delivers you a list of the currently loaded kernel modules.

  6. #6
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    'lsmod' gives me Modules listed with Size and Used-by info.
    mac80211 --- 154215 --- 1---ath9k
    ath9k_common --- 1448--- 1--- ath9k
    ath9k_hw --- 248527--- 2--- ath9k,ath9k_common
    ath--- 10270--- 2--- ath9k,ath9k_hw
    cfg80211 --- 98209--- 3--- ath9k,mac80211,ath

    I guess that the entries with "ath" are the modules for Atheros but I'm not able
    to find out if any of them support the Bluetooth device which is listed by 'lspci':

    07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

    How can I find out what is needed?

  7. #7
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    Maybe it is possible to follow the instructions at the end of the page "ath9k bluetooth coexistence" of the Linux Wireless web site.

  8. #8
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    Quote Originally Posted by klaus2008 View Post
    Maybe it is possible to follow the instructions at the end of the page "ath9k bluetooth coexistence" of the Linux Wireless web site.
    Should I try this although it says HERE ?
    Enabling bluetooth coexistence
    Bluetooth coexistence is automatically detected and enabled as of 2.6.32 so you do not have to do anything for it.
    Knoppix 6.7.1 uses Kernel 3.0.4 and xorg 7.6 (core 1.11) for supporting current-most computer hardware.

  9. #9
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    It does not seem easy to find a solution. Some people use Ubuntu Linux with kernel versions later than 2.6.32 and they complain that they are not able to use Bluetooth with the ath9k driver. My post #7 was just a suggestion for the case that your wireless chip was not properly identified, but I am unsure whether the option "btcoex_enable=1" has any effect on recent ath9k kernel modules.

    Have you already successfully used Bluetooth with another operating system (e. g. Windows)? In this case it could be that your wireless adaptor is partly incompatible with the Linux driver. Sometimes there is a special switch or button or combination of function keys to be pressed in order to enable wireless or Bluetooth connectivity. Is there an option in the BIOS of your system to disable Bluetooth or WLAN?

  10. #10
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    Quote Originally Posted by klaus2008 View Post
    Have you already successfully used Bluetooth with another operating system (e. g. Windows)? In this case it could be that your wireless adaptor is partly incompatible with the Linux driver. Sometimes there is a special switch or button or combination of function keys to be pressed in order to enable wireless or Bluetooth connectivity. Is there an option in the BIOS of your system to disable Bluetooth or WLAN?
    It works in Windows7 from where I connect to my Desktop Computer and my HP printer. I'm going to check the BIOS and let you know.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •