Results 1 to 5 of 5

Thread: Knoppix 6.7.1 DVD hangs when detecting GeForce GTX 550 Ti, ignores Realtek 8111C

  1. #1
    Junior Member
    Join Date
    Apr 2012

    Knoppix 6.7.1 DVD hangs when detecting GeForce GTX 550 Ti, ignores Realtek 8111C

    During the hardware detection and configuration all goes well except for the following:

    * there is a stack dump when trying to set up DRM, but it continues
    * the screen goes black and 'hangs' when X Window should start to load

    The card in question is: EVGA 01G-P3-1556-KR GeForce GTX 550 Ti (Fermi) FPB 1GB

    This problem can be worked around by passing the following kernel option: xmodule=fbdev OR xmodule=vesa

    Attempting to use the nv or svga xmodule's avoids the stack dump when setting up drm, but tells you that the graphics adapter or monitor is not auto-configuable and that you should use the cheat codes. It also fails to recognize the Realtek 8111C Ethernet chipset.

    The motherboard this chipset is found on is: EP45-UD3R (rev 1.1) None of this hardware is particularly obscure, obsolete, or difficult to support. The video card has been out for about a year, and the motherboard for about 3 years. I have had no trouble with either the Realtek onboard nor the 3Com (PCI card) networking on my 3 year old Mandriva install.

    While it does detect the 3Com card and set it up correctly, and all text mode programs (e.g. ping) seem to have no problem using it, of the web browsers I tried only Chromium works. Iceweasel and Konqueror behave as if the network connection is down. This problem also occurs in 6.7.0. I was not able to test older releases since, for some reason (bad reasons), these have been removed.

    I might otherwise have been able to tell the maintainers when the problem started, so they could see what changed in that version. The problem does /not/ occur in 6.2.1. I had this older version on hand.

    This is the first time I've seen Knoppix fail to handle non-cutting-edge hardware correctly. I appreciate the work the maintainers put into Knoppix, and recognize it's being provided for free. I use it to troubleshoot hardware and software problems, and perform data recovery, for myself and others. I hope this problem will be rectified in the next release so I can keep using it for this purpose.

    Please use the "Go Advanced" button to have more abilities to format the posting; before sending your posting use "Preview" to see how it looks like.
    Last edited by Werner P. Schulz; 04-13-2012 at 03:26 PM. Reason: formatted by moderator

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Columbia, Maryland USA
    Greetings, Shambles, and welcome to the forum.

    There are a large number of threads listed under 'geforce' which show up
    on the forum search (upper right, next to magnifying glass icon).

    Do none of these help?

  3. #3
    Junior Member
    Join Date
    Apr 2012
    Not as far as I can tell. I posted the workaround I found myself. The problem seems rather cut and dried. I burned and verified the image with ImgBurn. Further, I also downloaded, and burned, and verified, the earlier version, and got the same results. I'm having a problem with the live DVD. It's not a read/write medium, and I haven't told it to use my hard drive, so it can't be some setting I've messed up. There appears to be some problem with the NVidia driver. Perhaps it's not up to date, or buggy. I know the 296.10 (current) version of the NVidia drivers causes the "magenta screen of death" on Windows XP when used with this card ( I have two cards like this and it happens on both of them, but does not happen on 295.73 (previous version) or earlier. The boot failure only happens with recent versions of Knoppix. I have since found a second workaround. To get the onboard network adapter to appear I have to turn off the "Green LAN" setting in BIOS. This wasn't necessary on my old Mandriva install. It worked so long as there's a cable connecting it to something when booted. I'm currently trying to figure out how to fix what remains of the networking problem. It looks like it may be due to IPv6 support. I need to figure out how to disable that globally.

  4. #4
    Junior Member
    Join Date
    Apr 2012
    I have managed to get Knoppix 6.7.1 to behave as well as 6.2.1 did on my hardware.

    To make this happen I had to:
    * pass "xmodule=fbdev" or "xmodule=vesa" on the kernel command line; the nv and svga xmodules didn't work
    * turn off "Green LAN" on the Realtek onboard NIC in BIOS
    * disable IPv6 globally via entering "echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6" in a terminal as root, and manually in Iceweasel by going to the "about:config" page and setting "network.dns.disableIPv6" to true

    The Knoppix NVidia driver is definitely broken, at least when used on a EVGA 01G-P3-1556-KR GeForce GTX 550 Ti (Fermi) FPB 1GB video card. This is the only thing that seems to be unique to Knoppix. I'm seeing the Realtek and IPv6 problems on a Mageia live CD.

    The IPv6 problem is especially aggravating and difficult to figure out. There seems to be no way to do disable it at boot. Disabling it globally stops *most* programs from trying to use it, but Iceweasel (Firefox) will continue to try to use it, even if restarted after it's disabled, until you turn it off in the "about:config" page. While some people merely reported slow networking with it enabled, I literally could not connect to anything with most graphical programs with IPv6 enabled, unless I used the IP rather than the DNS name. The connections always timed out.

  5. #5
    Junior Member
    Join Date
    Apr 2012
    Thanks for posting this, I had the same problem of a blank screen as it was detecting hardware with a system I recently built. My graphics card is a little different but similar as far as the TI goes, my card is an MSI 560GTX Ti 448 Twin Frozr III with an ASRock Fatal1ty Z77 Professional motherboard. The xmodule=fbdev cheat code worked like a charm, but yea this is also the first time I've encountered Knoppix not working right out of the gate. I am also using the v6.71 DVD version (booted off a USB flash drive). I tried xmodule=nv prior to searching here and had the same results where it just sits there saying the graphics card may not be auto configurable and if no codes are given it spews out the stack dump then goes blank and sits there. Just posting to voice my added concern about this and hoping it can improve Knoppix a bit, it's great

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Lenovo Notebook ThinkPad L13 Yoga Gen 2 Laptop, 13.3

Lenovo Notebook ThinkPad L13 Yoga Gen 2 Laptop, 13.3" FHD IPS 300 nits


Lenovo ThinkBook 15-IIL 15.6” FHD Laptop Core i5 16GB RAM 256GB SSD Windows 11 picture

Lenovo ThinkBook 15-IIL 15.6” FHD Laptop Core i5 16GB RAM 256GB SSD Windows 11


Lenovo ThinkPad T480 Laptop 14

Lenovo ThinkPad T480 Laptop 14" FHD Core i5 16GB RAM 256GB SSD Windows 11 Pro


Lenovo Thinkpad T490s, 14

Lenovo Thinkpad T490s, 14", Core i5 8365U, 16GB, 256GB, Windows 11


Lenovo Ideapad 1 15Amn7 15.6

Lenovo Ideapad 1 15Amn7 15.6" Laptop Ryzen 3 7320U 8GB 256GB SSD W11H-64


Lenovo 100e Laptop PC Computer 11.6

Lenovo 100e Laptop PC Computer 11.6" Windows 10 Celeron 4GB RAM 64GB SSD


Lenovo Loq 15Irh8 15

Lenovo Loq 15Irh8 15" Laptop Core i5-13420H GeForce RTX 2050 16GB 512GB SSD W11H


Lenovo Legion Pro 5i 16

Lenovo Legion Pro 5i 16" Gaming Laptop RTX 4070 8GB i9-13900HX 16GB RAM 1TB SSD


Lenovo Laptop Computer ThinkPad 14

Lenovo Laptop Computer ThinkPad 14" Core i5 8GB RAM 256GB SSD WiFi Windows 10 PC


Lenovo IdeaPad 3 14ITL05 14

Lenovo IdeaPad 3 14ITL05 14" (128GB SSD, Intel Core i3-1115G4, 3.00GHz, 4GB RAM,