Results 1 to 4 of 4

Thread: Automatically Start nm-applet After HD Install...

  1. #1
    Junior Member
    Join Date
    May 2012

    Question Automatically Start nm-applet After HD Install...

    I just installed Knoppix 6.7.1 to HDD from a Live CD. While using the Live CD, The Network Manager's nm-applet places an icon in the panel, but after installing, the nm-applet icon is NOT in the panel. It appears that nm-applet isn't loaded in the case of a full install. I can load nm-applet by going to a terminal session and entering "nm-applet &", which will then place the applet's icon in the panel, with all working normally afterward. But, I want it to work the same as the Live CD.

    Question: How do I get nm-applet to load automatically?
    __________________________________________________ _

    IBM Aptiva, AMD K6 266MHz, 256Mb Memory, 15Gb HD, D-Link G122 USB Wireless

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Germany/ Dietzenbach
    The NMApplet is also per default within HD installation within the panel (left of the clock).

    If you've removed it:
    right mouseclick to panel => Panel Settings
    within the window "Panel Preferences" => tab "Panel Applet"
    => button "Add" => select "System Tray"

  3. #3
    Junior Member
    Join Date
    May 2012
    Hello Werner, and thanks for the quick reply.

    No, I didn't remove anything, and I've installed Knoppix 6.7.1 several times with the result always being the same, no nm-applet icon in the panel. Following your instructions, I find that the "System Tray" is already in the panel. In (Panel Preferences / Panel Applets) from the bottom, I have (Digital Clock, CPU Usage Monitor, System Tray. Volume Control, ...).

    Some additional info: When I enter "ps aux" in a terminal session, immediately after boot, but before manually starting nm-applet, "nm-applet" DOES NOT appear in the list of processes. After I enter "nm-applet &" to manually start nm-applet, "nm-applet" DOES appear in the list of processes. Apparently, nm-applet is not being launched automatically.

    Is it possible that the failure to launch nm-applet is an i586 issue?

  4. #4
    Junior Member
    Join Date
    May 2012
    OK, over the past day or so, some foggy memories have returned of having been here before. Last year, I installed Knoppix 6.7.1 on a Compaq Deskpro (Pentium II), after having Knoppix 6.7.0 installed on it, and I ran into the exact same problem. After spending too much time trying (unsuccessfully) to get the nm-applet problem sorted, I re-installed 6.7.0, which worked great, proving the problem to not be an i586 issue. Last night, I installed 6.7.0 on the Aptiva, and Voila!!!, the nm-applet problem was gone. It's NOT an i586 issue.

    Now, with Knoppix 6.7.0 running great on the Aptiva, I have a different problem. I tried to install Samba, and had problem with dependencies. If there's a quick answer to this, here's the message that Synaptic returned:

    Depends: samba-common (=2:3.5.6~dfsg-3squeeze7) but 2:3.5.8~dfsg-1 is to be installed
    Depends: libwbclient0 (=2:3.5.6~dfsg-3squeeze7) but 2:3.5.8~dfsg-1 is to be installed

    Otherwise, it's the topic of a different thread.

    Werner - Thanks for trying to help..

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Lenovo Yoga 7i Laptop, 15.6

Lenovo Yoga 7i Laptop, 15.6" FHD IPS LED , i7-1165G7, 12GB, 512GB, Win 11 Home


Lenovo ThinkPad T470 14

Lenovo ThinkPad T470 14" FHD Core i7-7600U 2.80GHz Webcam Backlit HDMI USB-C


Lenovo Thinkbook 15 1ML, i5, 8GB RAM, 256GB SSD, No OS picture

Lenovo Thinkbook 15 1ML, i5, 8GB RAM, 256GB SSD, No OS


Lenovo Laptop Computer E460 14

Lenovo Laptop Computer E460 14" Intel Core i5 8GB Ram 1TB SSD Windows 10 WiFi


Lenovo ThinkPad X1 Nano Gen 1 13

Lenovo ThinkPad X1 Nano Gen 1 13" Notebook 2K i5-1130G7 16GB RAM 512GB SSD


Lenovo Ideapad Gaming 3 15.6

Lenovo Ideapad Gaming 3 15.6" FHD Laptop R5-7535HS 8GB RAM 512GB SSD RTX 2050


Lenovo - Ideapad 3i 15.6

Lenovo - Ideapad 3i 15.6" FHD Touch Laptop - Core i5-1155G7 with 8GB Memory -...


Lenovo LOQ 15 15.6

Lenovo LOQ 15 15.6" Gaming Laptop 144Hz R7-7840HS 16GB RAM 512GB SSD RTX 4060


Lenovo ThinkPad T460 14

Lenovo ThinkPad T460 14" Laptop Core i7-6600U 6th 2.60GHz WebCam Backlit HDMI


Lenovo ThinkPad Laptop Computer 12.5

Lenovo ThinkPad Laptop Computer 12.5" Windows 10 PC Core i5 8GB Ram 240GB SSD