Results 1 to 4 of 4

Thread: Automatically Start nm-applet After HD Install...

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    4

    Question Automatically Start nm-applet After HD Install...

    I just installed Knoppix 6.7.1 to HDD from a Live CD. While using the Live CD, The Network Manager's nm-applet places an icon in the panel, but after installing, the nm-applet icon is NOT in the panel. It appears that nm-applet isn't loaded in the case of a full install. I can load nm-applet by going to a terminal session and entering "nm-applet &", which will then place the applet's icon in the panel, with all working normally afterward. But, I want it to work the same as the Live CD.

    Question: How do I get nm-applet to load automatically?
    __________________________________________________ _

    IBM Aptiva, AMD K6 266MHz, 256Mb Memory, 15Gb HD, D-Link G122 USB Wireless

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    The NMApplet is also per default within HD installation within the panel (left of the clock).

    If you've removed it:
    right mouseclick to panel => Panel Settings
    within the window "Panel Preferences" => tab "Panel Applet"
    => button "Add" => select "System Tray"

  3. #3
    Junior Member
    Join Date
    May 2012
    Posts
    4
    Hello Werner, and thanks for the quick reply.

    No, I didn't remove anything, and I've installed Knoppix 6.7.1 several times with the result always being the same, no nm-applet icon in the panel. Following your instructions, I find that the "System Tray" is already in the panel. In (Panel Preferences / Panel Applets) from the bottom, I have (Digital Clock, CPU Usage Monitor, System Tray. Volume Control, ...).

    Some additional info: When I enter "ps aux" in a terminal session, immediately after boot, but before manually starting nm-applet, "nm-applet" DOES NOT appear in the list of processes. After I enter "nm-applet &" to manually start nm-applet, "nm-applet" DOES appear in the list of processes. Apparently, nm-applet is not being launched automatically.

    Is it possible that the failure to launch nm-applet is an i586 issue?

  4. #4
    Junior Member
    Join Date
    May 2012
    Posts
    4
    OK, over the past day or so, some foggy memories have returned of having been here before. Last year, I installed Knoppix 6.7.1 on a Compaq Deskpro (Pentium II), after having Knoppix 6.7.0 installed on it, and I ran into the exact same problem. After spending too much time trying (unsuccessfully) to get the nm-applet problem sorted, I re-installed 6.7.0, which worked great, proving the problem to not be an i586 issue. Last night, I installed 6.7.0 on the Aptiva, and Voila!!!, the nm-applet problem was gone. It's NOT an i586 issue.

    Now, with Knoppix 6.7.0 running great on the Aptiva, I have a different problem. I tried to install Samba, and had problem with dependencies. If there's a quick answer to this, here's the message that Synaptic returned:

    samba:
    Depends: samba-common (=2:3.5.6~dfsg-3squeeze7) but 2:3.5.8~dfsg-1 is to be installed
    Depends: libwbclient0 (=2:3.5.6~dfsg-3squeeze7) but 2:3.5.8~dfsg-1 is to be installed

    Otherwise, it's the topic of a different thread.

    Werner - Thanks for trying to help..

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell PowerEdge R620 Server | 2x 2680 V2 2.8GHz = 20 Cores | 96GB | 2x 1TB SAS picture

Dell PowerEdge R620 Server | 2x 2680 V2 2.8GHz = 20 Cores | 96GB | 2x 1TB SAS

$334.40



Dell PowerEdge R620 Server | 2x E5-2680 V2 2.8GHz =20 Cores | 128GB | 2x 1TB SAS picture

Dell PowerEdge R620 Server | 2x E5-2680 V2 2.8GHz =20 Cores | 128GB | 2x 1TB SAS

$353.60



Dell PowerEdge R620 Server 2x E5-2660v2 10C (20 Cores Total) 96GB 2x 1TB w/ Raid picture

Dell PowerEdge R620 Server 2x E5-2660v2 10C (20 Cores Total) 96GB 2x 1TB w/ Raid

$222.30



Dell PowerEdge R630 Server 10-Bay Barebones picture

Dell PowerEdge R630 Server 10-Bay Barebones

$250.00



Dell Poweredge R620 2x E5-2670 2.6ghz 16-Cores / 32gb / H710 / 2x Trays / 750w picture

Dell Poweredge R620 2x E5-2670 2.6ghz 16-Cores / 32gb / H710 / 2x Trays / 750w

$89.99



Dell PowerEdge R720 Server 2x E5-2650 V2 2.6GHz = 16 Cores 32GB H710 No HDD picture

Dell PowerEdge R720 Server 2x E5-2650 V2 2.6GHz = 16 Cores 32GB H710 No HDD

$256.80



Dell Poweredge R620 2x E5-2630 2.3ghz 12-Cores / 16gb / H710 / 2x Trays / 750w picture

Dell Poweredge R620 2x E5-2630 2.3ghz 12-Cores / 16gb / H710 / 2x Trays / 750w

$74.99



Dell PowerEdge R710 Server | 2x X5650 =12 Cores | 32GB RAM | H700 | 2x 300GB SAS picture

Dell PowerEdge R710 Server | 2x X5650 =12 Cores | 32GB RAM | H700 | 2x 300GB SAS

$184.80



Dell PowerEdge R410 4-Bay Server 2x E5645 2.40GHz 6C 32GB DDR3 1x 500GB HDD picture

Dell PowerEdge R410 4-Bay Server 2x E5645 2.40GHz 6C 32GB DDR3 1x 500GB HDD

$134.10



Dell PowerEdge R730xd 24-Bay Server 2x E5-2650V3 2.30GHz 64GB 2x 600GB w/ Raid picture

Dell PowerEdge R730xd 24-Bay Server 2x E5-2650V3 2.30GHz 64GB 2x 600GB w/ Raid

$495.00