Results 1 to 7 of 7

Thread: Need help with Synaptic

  1. #1
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,386

    Need help with Synaptic

    .
    My Synaptic has a quirk I would like to correct.
    I think perhaps the CeBIT Knoppix 7 may have a similar quirk.

    If I select Settings>Repositories it says 'Repositories Changed-Reload';
    After I Reload, it comes back with the same message.
    I never get a chance to review the repos from Synaptic itself.

    I can make meaningful transactions otherwise with Synaptic for files that
    are either reachable from a repo or already on-board.

    I know I can see the repo list at /etc/apt/sources.list.
    If I dumb-down this list to just 'stable' that doesn't solve the problem.

    I'd like to solve the Synaptic problem. I'd rather not have only an answer to
    'just use apt-get' as my alternative.

    With that one restraint, I'd like some help here.
    What should I look for and where?

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,386
    .
    In regard to my previous post re mscorefonts & Synaptic bad behaviour,
    please browse the following Ubuntu posting:

    http://www.tuxgarage.com/2011/11/ttf...er-ubuntu.html

    One quote stands out for me.

    [quote]
    If the installation of "ttf-mscorefonts-installer" was not successful due to any reason, you might not be able to use your package manager, Ubuntu Software Center, Update Manager or Synaptic, etc.; in short you won't be able to install, remove, or upgrade any packages until the issue is fixed! Hrrnnh!!
    [unquote]

    I don't see that this reference solves my problem, but it it a good independent description of it.

  3. #3
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    902
    ... aptitude CLI can solve the problem with installation of "ttf-mscorefonts-installer"; but you don't like it

  4. #4
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,386
    Greetings, Werner.

    While it is true, I'd prefer to use Synaptic, the point I'm
    trying to express here is that I think Synaptic is screwed-up
    as of Knoppix 7 and needs to be fixed. Not a Knoppix problem,
    but a Debian problem at the heart of it.

    Ubuntu sees the problem tied to the EULA associated with
    mscorefonts, and how recent Synaptic changes may have caused
    this difficulty to develop.

    Moreover, I think the Synaptic difficulty may carry over into
    apt as well if your system has both installed.

    If you have the CeBIT Knoppix 7, please try apt-get install on
    mscorefonts and see if there's a problem. I don't have the CeBIT version.

    I know apt always used-to-be an alternative to Synaptic.
    In this current case, I'm not so sure.

    Best regads.

  5. #5
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    902
    I could install msorefonts within CeBIT version using aptitude without any problems. I prefer aptitude, not ap-get; aptitude is more versatile.

  6. #6
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,386
    Greetings, Werner.

    I have tried aptitude and it gives the same result I get with
    Synaptic, apt-get or Install Components on trying to bring in
    ttf-mscorefonts-installer. That is, aptitude also wants deforma
    and x-ttcidfont.conf to be installed as a pre-condition to proceed.

    Synaptic doesn't act on requests to install either.

    It is apparent that deforma will remove a host of fonts already
    installed. That doesn't seem right.

    Are deforma and/or x-ttcidfont.conf part of your mscorefonts installation?

  7. #7
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    902
    The question has been: Can aptitude install mscorefont?

    Yes?

    If you get violated dependicies, you can try to solve them. Perhaps you have to downgrade many hundreds of packages. Otherwise try to live with broken installation of defoma; I don't know, if you will run in trouble without it.

    Especially for Knoppix: Never change a running system!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •