Results 1 to 7 of 7

Thread: VMWare Workstation 8.0.3/Player 4.0.3 on 7.0.2

  1. #1
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    801

    VMWare Workstation 8.0.3/Player 4.0.3 on 7.0.2

    Maybe I shouldn't be any longer, but I'm still astounded at how VMware keeps on intimidating its customers. Don't think I'll even file a bug/support issue on this one, as my last were "closed" with no response at all.

    The problem is, that some VMware kernel modules have to be compiled and installed before Workstation/Player will run on Knoppix, and this has often been non-trivial. When the compilation aborts on one module, you can't run VMware. With Workstation 8.0.3 on 7.0.2 (kernel 3.3.7) it aborted on vmnet, the other modules compiled fine this time.

    The problems, and their solutions, are well known in the user community.
    Weltall's (Stefano Angeleri) blog has come to the rescue for many http://weltall.heliohost.org/wordpre...l-3-2-and-3-3/

    A small tarball may be downloaded, and with a minimal patch, it will work well. Change the
    patch-modules_3.2-0.sh script so the vmreqver and plreqver variables are set correctly, and run as super user. Worked fine for me on first try with the first lines as follows.

    Code:
    #! /bin/bash
    # VMWare Workstation/Player _host kernel modules_ patcher v0.6.2 by 2010 Artem S. Tashkinov
    # Tailored and fixed vmblock patching for the 2.6.39 patch by Stefano Angeleri (weltall)
    # Use at your own risk.
    
    fpatch=vmware3.2.0.patch
    vmreqver=8.0.3  #  Change as needed
    plreqver=4.0.3  #
    Note that this has so far only been tried out with 32-bits Workstation, but seems to work just fine. I'm quite annoyed that VMware seemingly can't apply a well-known patch themselves..

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Quote Originally Posted by Capricorny View Post
    ... my last were "closed" with no response at all...
    Did you refer to Knoppix in your bug report(s)?

  3. #3
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    801
    I may have. Been running Workstation under Knoppix for some 4 years (I think), under Linux for 12+ years..
    The essential thing is VMware doesn't really care about service - they are in business, and we (me and people like me) are old, but rather uninteresting customers.
    And they want to get money from us - the trouble with WS7 and new kernel was quite easily patched, for example, but they chose to correct it only in the new WS8, to milk some more money out of us..

  4. #4
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    I've noticed with other forums, there quite often seems to be a reluctance
    to discuss common LXDE problems with 'outsiders'. I find maintaining some
    anonymity in regard to distribution details is prudent in such cases.

    Your VMWare problem may come from more commercial considerations.
    is VirtualBox a viable alternative in the 'free' world?

  5. #5
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    801
    Clearly, many consider Virtualbox a very good alternative - depends on the uses, I think. Mine is for running Linux and Windows VMs simultaneously, to create a development environment that closely models actual production environments. Workstation/Player is very good at that. And Player is free. I prefer Qemu-kvm for testing and simple running purposes. VirtualBox seems to place itself between those, thus it is not that interesting for me.

    And, using the patch presented, there is no real problem getting VMware 8+/4+ to work in 7.0.2.

  6. #6
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    801

    Update for Workstation 8.0.6 and kernel 3.9.X - Knoppix 7.2.0

    Business as usual from vmware, Workstation 8.0.4+ (I think). Issues are well known, related to kernel 3.8+ (I think) - no patch from them, not even hints, and module compilation aborts with no real clue as to why. Seems like kind of mixture of planned and forced obsolescense to me.

    I almost gave up this time

    1. Fix "missing version.h" kernel header issue - a really old one. For example, by issuing

    Code:
    sudo ln -s /usr/include/linux/version.h /usr/src/kernels/$(uname -r)/include/linux/version.h
    The $(uname -r) phrase will ensure to update the header tree for your currently running kernel.


    2. Run module configuration from the command line

    Code:
    sudo /usr/bin/vmware-modconfig --icon=vmware-workstation --appname=VMware
    The built-in configuration tool doesn't work - and running CLI is safer and more informative anyway. With any luck, most modules will compile just fine, except for vmci. Here is a diff of defunct original and working patched version of the culprit, driver.c:

    Code:
    diff driver.c  ~/Downloads/driver.c
    127c127
    <    .remove = __devexit_p(vmci_remove_device),
    ---
    >    .remove = vmci_remove_device,
    1744c1744
    < static int __devinit
    ---
    > static int
    1972c1972
    < static void __devexit
    ---
    > static void
    I found a patch on the vmware forum: http://communities.vmware.com/thread...art=0&tstart=0
    using the patched driver.c provided by user HaoZhuyi there. Placed it in ~/Downloads.

    3. Fix the vmci tarball: Untar, patch driver.c and tar again

    Code:
    cd /usr/lib/vmware/modules/source
    sudo cp -a vmci.tar vmci.tar.806
    sudo tar xf vmci.tar
    cd vmci-only/linux
    diff driver.c  ~/Downloads/driver.c
    sudo cp -a ~/Downloads/driver.c .
    cd ../..
    sudo tar cf vmci.tar vmci-only
    4. Run module configuration from the command line again

    Code:
    sudo /usr/bin/vmware-modconfig --icon=vmware-workstation --appname=VMware
    Thus, I got Workstation 8.0.6 up and running on Knoppix 7.2.
    BUT: I wasn't allowed to enter my Vs 8 license key - button didn't work...
    Last edited by Capricorny; 07-10-2013 at 08:25 AM.

  7. #7
    Senior Member registered user
    Join Date
    Sep 2006
    Posts
    801
    After having tested some more:
    There seem to be quite a few problems with Knoppix 7.2.0 and Workstation 8.0.6 - apart from basic module compilation. I could not get vmblock to compile with the 64-bits kernel, for example, and not being able to run vmware with the 64-bits kernel is too impractical for me. I'd like to hear from others wiith more luck running Workstation 8.X (or 9) under 7.2.0. This is in such a contrast to 8.05 and Knoppix 7.0.5. I will later try 8.0.6 with 7.0.5 to see whether issues crop up there too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •