Maybe I shouldn't be any longer, but I'm still astounded at how VMware keeps on intimidating its customers. Don't think I'll even file a bug/support issue on this one, as my last were "closed" with no response at all.

The problem is, that some VMware kernel modules have to be compiled and installed before Workstation/Player will run on Knoppix, and this has often been non-trivial. When the compilation aborts on one module, you can't run VMware. With Workstation 8.0.3 on 7.0.2 (kernel 3.3.7) it aborted on vmnet, the other modules compiled fine this time.

The problems, and their solutions, are well known in the user community.
Weltall's (Stefano Angeleri) blog has come to the rescue for many

A small tarball may be downloaded, and with a minimal patch, it will work well. Change the script so the vmreqver and plreqver variables are set correctly, and run as super user. Worked fine for me on first try with the first lines as follows.

#! /bin/bash
# VMWare Workstation/Player _host kernel modules_ patcher v0.6.2 by ©2010 Artem S. Tashkinov
# Tailored and fixed vmblock patching for the 2.6.39 patch by Stefano Angeleri (weltall)
# Use at your own risk.

vmreqver=8.0.3  #  Change as needed
plreqver=4.0.3  #
Note that this has so far only been tried out with 32-bits Workstation, but seems to work just fine. I'm quite annoyed that VMware seemingly can't apply a well-known patch themselves..