Results 1 to 3 of 3

Thread: Dell Inspiron 8100 has Grub Boot Problems

  1. #1
    Junior Member
    Join Date
    Jul 2012
    Posts
    2

    Dell Inspiron 8100 has Grub Boot Problems

    I have an older Dell Inspiron whose CD drive does not work, and whose bios dose not allow booting from a usb device. So, I downloaded the ADRIANE iso to the hard drive (it currently runs xubuntu) and configured grub with this boot entry:

    menuentry knoppix {
    loopback loop (hd0,1)/home/ADRIANE....iso
    linux (loop)/boot/isolinux/linux debug nousb bootfrom=/dev/sda1/home/ADRIANE....iso expert knoppix
    initrd (loop)/boot/isolinux/minirt.gz
    }
    When I boot the computer, Knoppix appears to boot ok --it displays a message that it finds knoppix 6 at /dev/sda1/home/.... It displays a messages that kernel 2.6.39.3 is loaded. Then it displays a message:

    sh: can't access tty; job control turned off

    It then displays a prompt. The hard disk is mounted at /mnt-iso. I cannot run any programs on the hard disk such as firefox. Even if I type the full path, a message is displayed that the program is not found. A character interface is displayed -- no graphical windows manager. Obviously somethins is wrong. Any ideas?

    Thanks much!

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    I would suggest that you try to boot without the 'debug' cheat code.

  3. #3
    Junior Member
    Join Date
    Jul 2012
    Posts
    2
    Alright. It worked! I presumed that "debug" would offer something useful if the boot malfunctioned, and that it would be harmless if it functioned well. I was wrong. Thanks much for your assistance.

    Cheers!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •