Results 1 to 2 of 2

Thread: troubleshooting my sound card ...

  1. #1
    Senior Member registered user
    Join Date
    Dec 2004
    Posts
    168

    troubleshooting my sound card ...

    While booting knoppix complains about my sound device. I see messages scroll that look like this:
    Code:
    [0x82631c0] main services discovery error: no suitable services discovery module
    grepHelper: File does not exists:  "/proc/asound/card1/pcm0p/info" 
    ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused
    
    ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused
    This is what I see in dmesg:
    Code:
    $ cat dmesg | grep -i radeon
    [   15.645268] [drm] radeon kernel modesetting enabled.
    [   15.645522] radeon 0000:01:00.0: power state changed by ACPI to D0
    [   15.645533] radeon 0000:01:00.0: power state changed by ACPI to D0
    [   15.654309] radeon 0000:01:00.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
    [   15.654317] radeon 0000:01:00.0: GTT: 512M 0x0000000020000000 - 0x000000003FFFFFFF
    [   15.661353] [drm] radeon: 512M of VRAM memory ready
    [   15.661358] [drm] radeon: 512M of GTT memory ready.
    [   15.661513] radeon 0000:01:00.0: irq 45 for MSI/MSI-X
    [   15.661538] radeon 0000:01:00.0: radeon: using MSI.
    [   15.661595] [drm] radeon: irq initialized.
    [   15.664687] [drm] radeon: ib pool ready.
    [   16.178679] radeon 0000:01:00.0: WB enabled
    [   16.232432] [drm] Radeon Display Connectors
    [   16.232643] [drm] radeon: power management initialized
    [   17.702626] fbcon: radeondrmfb (fb0) is primary device
    [   18.171419] fb0: radeondrmfb frame buffer device
    [   18.171429] [drm] Initialized radeon 2.13.0 20080528 for 0000:01:00.0 on minor 0
    
    $ cat dmesg | grep -i sound
    [    1.688609]   No soundcards found.
    
    $ cat dmesg | grep -i alsa
    [    1.688605] ALSA device list:
     
    [    1.688605] ALSA device list:
    [    1.688609]   No soundcards found.
    ...
    [   16.232488] [drm] Connector 3:
    [   16.232492] [drm]   HDMI-A
    [   16.232495] [drm]   HPD1
    [   16.232501] [drm]   DDC: 0x7e20 0x7e20 0x7e24 0x7e24 0x7e28 0x7e28 0x7e2c 0x7e2c
    [   16.232505] [drm]   Encoders:
    [   16.232509] [drm]     DFP1: INTERNAL_UNIPHY
    [   16.232643] [drm] radeon: power management initialized
    The only sound-related cheatcode I found "knoppix alsa" didn't work on my box.

    This is what "lspci -v" tells me about my audio device
    Code:
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series]
     Subsystem: Hewlett-Packard Company Device 3600
     Flags: bus master, fast devsel, latency 0, IRQ 47
     Memory at d2310000 (32-bit, non-prefetchable) [size=16K]
     Capabilities: <access denied>
     Kernel driver in use: snd_hda_intel
    
    $ lspci -vv -k -t
    -[0000:00]-+-00.0  Advanced Micro Devices [AMD] RS780 Host Bridge
               +-02.0-[01]--+-00.0  Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series]
                            \-00.1  Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series]
    How can I fix or do more troubleshooting on my sound card?
    lbrtchx
    Last edited by Albretch; 08-02-2012 at 11:41 AM.

  2. #2
    Junior Member registered user
    Join Date
    Jun 2008
    Posts
    18
    Sometimes I've had to tell Mplayer to specifically use ALSA instead of pulse-audio or default audio output in the player settings.

    Then, sometimes follow up by bringing up alsamixer in a terminal, and bring up the master and sometimes the pcm levels. I run a persistent image, so the settings tend to stay fixed upon the next reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1TB/2TB SATA 3 SSD Hard Drive 2.5

1TB/2TB SATA 3 SSD Hard Drive 2.5" Internal External Solid State Drive PC Laptop

$32.44



WD Elements 1TB Certified Refurbished Portable Hard Drive Black picture

WD Elements 1TB Certified Refurbished Portable Hard Drive Black

$24.99



1TB 7mm 2.5in SSD SATA III PC Internal Hard Drives Solid State Drive High Speed picture

1TB 7mm 2.5in SSD SATA III PC Internal Hard Drives Solid State Drive High Speed

$35.88



Western Digital WD10JPVX 1TB 5400RPM 6Gb/s 2.5

Western Digital WD10JPVX 1TB 5400RPM 6Gb/s 2.5" SATA LAPTOP Hard Drive

$35.00



Samsung - 980 PRO 1TB PCIe Gen 4 x4 NVMe Gaming Internal Solid State Drive picture

Samsung - 980 PRO 1TB PCIe Gen 4 x4 NVMe Gaming Internal Solid State Drive

$139.99



1TB SanDisk X400 TLC SATA 3 6Gb/s 2.5

1TB SanDisk X400 TLC SATA 3 6Gb/s 2.5" 7mm SED Internal SSD SERVER SYSTEM PULL

$59.99



SAMSUNG T7 Portable SSD 1TB - Up to 1050 MB/s - USB 3.2 External Solid State Dri picture

SAMSUNG T7 Portable SSD 1TB - Up to 1050 MB/s - USB 3.2 External Solid State Dri

$109.99



Crucial 2TB 1TB 480GB 240GB SSD SATA III 2.5 Internal Solid State Drive 7mm Lot picture

Crucial 2TB 1TB 480GB 240GB SSD SATA III 2.5 Internal Solid State Drive 7mm Lot

$59.95



1TB HDD/SSD 2.5

1TB HDD/SSD 2.5" SATA Hard Drive Laptop with Windows 10 Pro Installed Legacy 64

$25.49



Netac 120GB 240GB 500GB SSD 2.5

Netac 120GB 240GB 500GB SSD 2.5" SATA III Internal Solid State Drive 500MB/s lot

$90.93