Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: Which Broadcom STA driver do I install from the ones listed in Synaptic?

  1. #21
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Quote Originally Posted by utu View Post
    There is other evidence, e.g. Ubuntu, that says it works with the wl driver.
    @John & Klaus2008

    That was a comment of mine earlier in this thread.

    I've gone back over my notes, and I now think my reading of the Ubuntu reference example was not correct.
    I'll have to say I have found no firm evidence that anyone has got BCM43227 to work with anything but wl.
    I'd be glad to have someone else come up with an example that shows b43 is a viable solution.

    For anyone that's interested, the most authoritative discussion of Linux drivers for Broadcom wifis seems (to me) to be:
    http://linuxwireless.org/en/users/Dr...devicefirmware
    It shows BCM43227 as 'not tested', meaning not tested with b43.
    Last edited by utu; 08-28-2012 at 09:55 PM.

  2. #22
    Hi utu

    After my #17, I continued to read your #16 and decided to follow your
    suggestions in #16.

    Re your
    "Since we know b43 is available, you can do a modprobe b43 to install the
    drivers YOURSELF":

    I did that as follows

    knoppix@Microknoppix:~$ lsmod|grep b43
    knoppix@Microknoppix:~$ sudo modprobe b43
    knoppix@Microknoppix:~$ lsmod|grep b43
    b43 290652 0
    bcma 15000 1 b43
    mac80211 264810 1 b43
    cfg80211 114298 2 mac80211,b43
    ssb 34520 1 b43
    rng_core 2328 1 b43
    pcmcia 24848 2 ssb,b43
    knoppix@Microknoppix:~$

    Note, the first line (lsmod|grep b43) indicates that b43 ISN'T in the kernel
    at that point. But note that the second line (sudo modprobe b43) gives NO
    OUTPUT. According to your kind #16,
    "If b43 is installed already and you command 'modprobe b43',
    you get no response, and no information."

    For some reason, that doesn't fit with what occurred above. But in any event,
    the above seems to have added b43 (again) to the kernel (even though this seems
    to be a TEMPORARY addition, as I've mentioned at #17).

    Should the wifi be physically operating at this point (assuming b43 works and I
    don't need the sta driver)? I toggled Fn + F3 at least twice, but the orange
    wifi LED still doesn't come on.

    But I continued following your instructions and left-clicked on the network
    manager icon, which shows:

    Wired Network (greyed)
    Auto Ethernet (bold)
    Disconnect
    VPN Connections

    I then right-clicked the network manager icon, which shows:

    Enable Networking (ticked)
    Enable Notifications (ticked)
    Connection Information
    Edit Connections...

    There is NO choice offered to select wifi. What I tend to do in day-to-day use
    is use the "Enable Networking" entry to enable/disable the networking when I
    want it on or off. Doing this, by the way, doesn't turn the orange wifi LED on
    or off, but no doubt you knew that.

    Clicking on "Connection information" says:
    Active Network Connections (Heading)
    Auto Ethernet (default) (a single tab)
    ... followed by details (eg "General, IPv4")

    -----------------------------------------------

    Finally. I've just read your #18 & #19. I'll report back with the info you
    want, when I can. My priority is still working out the meaning of life, so I
    have to control how much attention I give knoppix.

    Take it steady, John.

  3. #23
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings again, John.

    You've been pretty patient; sorry things aren't going so well for you.
    I think you've shown your Knoppix 7.0.2 can be made to install b43
    as a kernel module, but unfortunately it doesn't seem to work as we'd hoped.

    Why your 7.0.2 requires manual intervention is an additional puzzlement,
    but not as crucial a finding.
    Two of your symptoms in trying to get your BCM43227 wifi to work with b43
    driver don't bode well: the orange light doesn't behave as you'd expect;
    and the fact network manager doesn't ask you for wifi handshaking parameters.

    Not having a working wl driver alternative is also unfortunate. Knoppix 7 uses
    a 3.4 Linux kernel. Debian source for wl for the 3.4 kernel has some error
    which causes it to fail to compile. This can be a problem for other Broadcom
    wifis as well. A few other distributions have also found this to be the case
    and have achieved some work-arounds. Such work-arounds are beyond my skills.
    Debian can be expected to take care of this in time.

    Lucky you can use the ethernet to exercise your Knoppix 7.
    We appreciate your efforts to help us sort this out.

  4. #24
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    @winger9
    The rfkill command told that the acer-wireless was neither soft blocked nor hard blocked. Even if the orange WiFi LED does not shine I would try the sta driver.

    On Broadcom's website you can find the documentation README.txt which you should read carefully.

    While being connected to the internet I would open an LXTerminal and issue
    Code:
    sudo apt-get update
    sudo apt-get -t testing install broadcom-sta-source
    sudo m-a build broadcom-sta
    sudo dpkg -i /usr/src/broadcom-sta-modules-3.3.7_5.100.82.112-7+3.3.7-10.00.Custom_all.deb 
    sudo apt-get -t testing install broadcom-sta-common
    sudo rmmod b43
    sudo rmmod ssb
    sudo rmmod bcma
    sudo rmmod wl
    sudo leafpad /etc/modprobe.d/blacklist-knoppix.conf
    I think that the configuration file should look like the following.
    Code:
    # modprobe blacklist for KNOPPIX
    # some blacklisted modules are in the configuration file /etc/modprobe.d/broadcom-sta-common.conf
    
    # graphics/KMS drivers should not get autoloaded by udev
    blacklist nvidia
    blacklist nouveau
    blacklist nvidiafb
    blacklist intelfb
    blacklist mbp_nvidia_bl.ko
    blacklist rivafb
    blacklist i915
    blacklist radeon
    After you have made the changes you should save the file and close the text editor. It should be possible to load the wl kernel module. I would disconnect from the network and reboot the system.

    If the wl kernel module was not loaded at boot time you could open a terminal and issue
    Code:
    sudo modprobe cfg80211
    sudo modprobe wl
    I hope that helps.

  5. #25
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, Klaus2008

    Nice posting, thanks.

    If John, or anyone else, succeeds in compiling wl for the 3.4.9 kernel in
    Knoppix 7.0.4, I hope their result will get posted to the alioth depository,
    which Klaus K sometimes uses, for others to access until Debian gets their
    problem solved.

  6. #26
    Dear utu

    Thanks everso much for your continuing help. Just right now, I'm keen to try
    klaus2008's suggestion at #4 (m-a build broadcom-sta, etc). I hope you don't
    mind.

    You see, before I approached you fine chaps at knoppix.net, I had spent a
    lot of time looking on the Internet for how to make my wifi work in
    Linux/knoppix with MY PARTICULAR Broadcom card. And it became evident to me
    that the "b43" or "b43 legacy" driver/firmware is for earlier types of
    Broadcom card in that series. (I apologise if I'm wrong about that).

    So i felt back then (and still do now) that i need a newer driver that has come
    out since the b43, and that covers my BCM43227 card. To cut a long story short,
    I found a driver that does cover my BCM43227, at

    http://www.broadcom.com/support/802.11/linux_sta.php/ (as I mentioned
    before).

    BUT AFTER THAT I discovered in Synaptic that there appeared to be the same (or
    equivalent) driver already available for download from the Linux repository. So
    that's what led to my first post in this thread, asking if someone could tell me
    WHICH of the 5 Synaptic modules ("broadcom-sta-...") to install.

    In Synaptic, the first part of the FULL description of ALL 5 packages is as
    follows:

    "Broadcom STA is a binary-only device driver to support the following IEEE
    802.11a/b/g/n wireless network cards: BCM4311-, BCM4312-, BCM4313-,
    BCM4321-, BCM4322-, BCM43224-, BCM43225-, BCM43227-, and BCM43228-based
    hardware."

    So this shows clearly that my BCM43227 is accommodated by these packages.

    I could tell utu, that you (and Klaus K) were keen to see if Knoppix 7.0.2
    already covered my BCM43227. So I tried to help out, and went in that direction
    for your good selves.

    But having had no success with that thus far, I'd like to switch (at least for
    the time being) to trying klaus2008's suggestion at #4, which is I believe going
    down the route of my Synaptic "broadcom-sta..." packages, that I've mentioned
    above.

    By-the-way, I'm trying to tell myself not to be so wordy. So if my future posts
    are brief and pithy, I'd just like you to know that i hold you fine chaps in
    high regard, and that no offense is meant whatsoever by my brief wording.

    Take care. John.

  7. #27
    To klaus2008 (and utu for your info)

    Reply to your posts klaus, #4 & #24.

    Thanks immensely. THE ORANGE WIFI LED LIGHT HAS JUST COME ON!

    Skipping all the details, I have just entered the following commands:

    knoppix@Microknoppix:~$ sudo modprobe cfg80211
    knoppix@Microknoppix:~$ sudo modprobe wl
    knoppix@Microknoppix:~$

    Immediately after the second of the above 2 commands, the wifi LED came on! And I can now toggle the LED on and off with Fn + F3!

    I've still got to check some things, but thought I'd let you know this promising progress.

    John

  8. #28
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Good work, John.

    I think all you need now is to set up the handshake just like
    you do for Windows and you should be all set. You can do this
    by working with the network manager icon on the lxpanel.

  9. #29
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    @winger9

    You can edit the file /etc/modules and add the two modules cfg80211 and wl if you want to load them at boot time.

  10. #30
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, Klaus2008.

    I tried to use your fine instructions at post #24 with my Knoppix 7.0.4,
    and it fails in the third step 'sudo m-a build broadcom-sta'.

    Steps 1 and 2 took some time, but completed without noting any errors.

    I presume it likely that the fact the 7.0.4 kernel is 3.4.9, where the
    7.0.2 kernel is 3.3.7 is at the heart of the problem, but I don't know how
    to adjust your instructions to account for this.

    I have a new wifi which works with b43 and allegedly works as well with wl.
    I'd hoped to try that out. Any suggestions?
    Last edited by utu; 09-05-2012 at 04:32 PM.

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •