Results 1 to 3 of 3

Thread: Default beep not working on 7.0.3 DVD

  1. #1

    Default beep not working on 7.0.3 DVD

    Hello. I can't seem to get a beep out of the LXTerminal and some other programs. It worked in 6.7.1 when you enabled audible bell in the preferences, but that still doesn't get it to work. I also tried 'xset b ...' and KDE system settings, but still nothing. All that happens is compiz shakes the window which does no good if it's behind other windows.

    Thanks

  2. #2
    Ok, I believe I may have traced it to there not being a pcspkr or snd-pcsp kernel module. There is no package available which contains these, so I would apparently have to build them from source? However this does not appear to be a standard Debian kernel. Does anyone know what packages I need? Any help would be much appreciated.

  3. #3
    Ok, I have finally traced the problem down to compiz fusion. This is despite the audible bell being enabled in settings manager. Switching to metacity fixes the problem.

    I also compiled a pcspk.ko for Linux 3.4.4 if anyone is interested.

    Some useful commands:

    Code:
    metacity --replace &
    
    depmod
    
    insmod pcspk

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •