Results 1 to 8 of 8

Thread: Starting Compiz in 7.0.4

  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    8

    Starting Compiz in 7.0.4

    I used 6.4.3 on a flash drive with persistent storage as my only operating system for more than a year. I thought I understood Knoppix fairly well. Then I got 7.0.4. I canít start Compiz no matter how much I fiddle with the settings. I canít connect to the Internet. Help.

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, Mark.
    What do you get for testcd or testdvd?

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    8
    ďAll files OK.Ē

    I downloaded 7.0.2 and 7.0.4 and md5 sums checked. I also bought the 7.0.3 DVD from osdisc.com. None work correctly for me, no compiz and no connection (although I havenít tried too hard to get a connection). Same hardware -- 6.4.3 works fine but none of the 7.0 work.

  4. #4
    Junior Member registered user
    Join Date
    Dec 2002
    Location
    Germany
    Posts
    22
    Quote Originally Posted by Mark_Twain View Post
    I used 6.4.3 on a flash drive with persistent storage as my only operating system for more than a year. I thought I understood Knoppix fairly well. Then I got 7.0.4. I canít start Compiz no matter how much I fiddle with the settings. I canít connect to the Internet. Help.
    Which graphics chipset do you have?

    I think that one of the 6.x series was the last one to have the gma500 acellerated driver, which was unfortunately dropped for newer X servers. Since Kernel 3.x, we now have the gma500_gfx framebuffer driver, which is too slow for compiz in mesa 3d software rendering.

    Another reason could be that your card is blacklisted for automatic 3D detection (some NVidia and Radeon cards are, because Composite is not stable there), in which case you may try

    knoppix 3d

    in order to get back the old behaviour of enabling Composite, and letting compiz decide by itself whether or not your card is safe for 3d.

    Regards
    -Klaus

  5. #5
    Junior Member
    Join Date
    May 2011
    Posts
    8
    Quote Originally Posted by knopper View Post
    Which graphics chipset do you have?
    NVidia GeForce FX 5200 -- knoppix 3d does not work.

    When I try to start compiz from a console I get:

    FATAL: No composite extension

  6. #6
    Junior Member
    Join Date
    May 2011
    Posts
    8
    UPDATE

    7.0.2 DVD downloaded U.S. server -- no compiz, no connection.
    7.0.3 DVD purchased OSDisk.com -- no compiz, no connection.
    7.0.4 DVD downloaded German server -- no compiz, no connection.

    However, this morning I downloaded the 7.0.4 CD and it works perfectly. Compiz comes up and the connection is automatic.

    Something on the DVD is different from the CD.

  7. #7
    Junior Member
    Join Date
    May 2011
    Posts
    8
    Well, that 7.0.4 CD worked exactly ONCE back in August. It hasn't worked since and I've tried almost daily. I have no connection, no audio and limited graphics.

    I have a working Debian testing where I added the proprietary drivers last year. Unfortunately I don't remember what I did. It works perfectly and shows the following cards and drivers:

    Graphics: Card NVIDIA C51G [GeForce 6100] X.org 2) Res: 80x24 Gfx Data: N/A for root
    Audio: Card NVIDIA MCP51 AC97 Audio Controller driver snd_intel8x0 at ports dc00 d800 BusID: 00:10.2
    Network: Card NVIDIA MCP51 Ethernet Controller driver forcedeth at port d400 BusID: 00:14.0

    How can install the proper drivers in Knoppix?

    And why in the world did the CD work only once?

  8. #8
    Junior Member registered user
    Join Date
    Dec 2002
    Location
    Germany
    Posts
    22
    Quote Originally Posted by Mark_Twain View Post
    Well, that 7.0.4 CD worked exactly ONCE back in August. It hasn't worked since and I've tried almost daily. I have no connection, no audio and limited graphics.

    I have a working Debian testing where I added the proprietary drivers last year. Unfortunately I don't remember what I did. It works perfectly and shows the following cards and drivers:

    Graphics: Card NVIDIA C51G [GeForce 6100] X.org 2) Res: 80x24 Gfx Data: N/A for root
    Audio: Card NVIDIA MCP51 AC97 Audio Controller driver snd_intel8x0 at ports dc00 d800 BusID: 00:10.2
    Network: Card NVIDIA MCP51 Ethernet Controller driver forcedeth at port d400 BusID: 00:14.0

    How can install the proper drivers in Knoppix?

    And why in the world did the CD work only once?
    It seems your graphics card does not work well with free drivers, so I would suggest to disable accellerated graphics ad use framebuffer or non-3d mode. I'm not convinced that the proprietary drivers behave stable, I would try to avoid them. NVIDIA has always been "problem hardware".

    knoppix no3d
    or
    fb1024x768

    will turn off composite and acellerated mode, and use the 2D window manager.

    I have no idea why your audio and network isn't working. The onboard intel soundcard is completely independent from your graphics card, and all recent network and wifi adapters should be supported by a recent kernel. Also, there is no natural explanation for a case of the CD working "just once". Neither the CD content, nor your computer hardware can be "changed" by software only. If you find out what happened, please let me know!

    Regards
    -Klaus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell PowerEdge R620 Server | 2x 2680 V2 2.8GHz = 20 Cores | 96GB | 2x 1TB SAS picture

Dell PowerEdge R620 Server | 2x 2680 V2 2.8GHz = 20 Cores | 96GB | 2x 1TB SAS

$338.99



HP ProLiant DL380 Gen9 Server | No HDD | 2x Xeon E5-2620 v3 | 128GB DDR4 RAM picture

HP ProLiant DL380 Gen9 Server | No HDD | 2x Xeon E5-2620 v3 | 128GB DDR4 RAM

$299.99



Dell PowerEdge R630 Server | 2x E5-2680v3 24cores 2.4GHz | 128GB | H730 | 2x750W picture

Dell PowerEdge R630 Server | 2x E5-2680v3 24cores 2.4GHz | 128GB | H730 | 2x750W

$546.00



Dell PowerEdge R620 Server 2x E5-2650L V2 2.6GHz =20 Cores | 128GB | 4x 1TB SATA picture

Dell PowerEdge R620 Server 2x E5-2650L V2 2.6GHz =20 Cores | 128GB | 4x 1TB SATA

$246.99



HYVE ZEUS V1 1U SERVER 2x 10 CORE E5-2670V2 2.5GHz 32GB RAM RAIL NO HDD picture

HYVE ZEUS V1 1U SERVER 2x 10 CORE E5-2670V2 2.5GHz 32GB RAM RAIL NO HDD

$142.00



HPE ProLiant EC200a Mini Server, Xeon D1518 2.2GHz CPU picture

HPE ProLiant EC200a Mini Server, Xeon D1518 2.2GHz CPU

$159.00



Dell PowerEdge R620 Server | 2x E5-2650 V2 2.6GHz =16 Cores | 32GB | 2x trays picture

Dell PowerEdge R620 Server | 2x E5-2650 V2 2.6GHz =16 Cores | 32GB | 2x trays

$145.99



HP Proliant DL360p G8 Server | 2x E5-2680 2.7GHz =16 Cores | 96GB | 2x 300GB SAS picture

HP Proliant DL360p G8 Server | 2x E5-2680 2.7GHz =16 Cores | 96GB | 2x 300GB SAS

$179.99



Dell PowerEdge T130 Intel Xeon E3-1220 v5 8GB RAM 1TB HDD VGA USB Win 10 Server picture

Dell PowerEdge T130 Intel Xeon E3-1220 v5 8GB RAM 1TB HDD VGA USB Win 10 Server

$309.99



Dell PowerEdge R620 Server 2x E5-2680 V2 2.8GHz = 20 Cores 128GB RAM 2x trays picture

Dell PowerEdge R620 Server 2x E5-2680 V2 2.8GHz = 20 Cores 128GB RAM 2x trays

$262.99