Results 1 to 8 of 8

Thread: Starting Compiz in 7.0.4

  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    8

    Starting Compiz in 7.0.4

    I used 6.4.3 on a flash drive with persistent storage as my only operating system for more than a year. I thought I understood Knoppix fairly well. Then I got 7.0.4. I cant start Compiz no matter how much I fiddle with the settings. I cant connect to the Internet. Help.

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, Mark.
    What do you get for testcd or testdvd?

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    8
    All files OK.

    I downloaded 7.0.2 and 7.0.4 and md5 sums checked. I also bought the 7.0.3 DVD from osdisc.com. None work correctly for me, no compiz and no connection (although I havent tried too hard to get a connection). Same hardware -- 6.4.3 works fine but none of the 7.0 work.

  4. #4
    Junior Member registered user
    Join Date
    Dec 2002
    Location
    Germany
    Posts
    22
    Quote Originally Posted by Mark_Twain View Post
    I used 6.4.3 on a flash drive with persistent storage as my only operating system for more than a year. I thought I understood Knoppix fairly well. Then I got 7.0.4. I cant start Compiz no matter how much I fiddle with the settings. I cant connect to the Internet. Help.
    Which graphics chipset do you have?

    I think that one of the 6.x series was the last one to have the gma500 acellerated driver, which was unfortunately dropped for newer X servers. Since Kernel 3.x, we now have the gma500_gfx framebuffer driver, which is too slow for compiz in mesa 3d software rendering.

    Another reason could be that your card is blacklisted for automatic 3D detection (some NVidia and Radeon cards are, because Composite is not stable there), in which case you may try

    knoppix 3d

    in order to get back the old behaviour of enabling Composite, and letting compiz decide by itself whether or not your card is safe for 3d.

    Regards
    -Klaus

  5. #5
    Junior Member
    Join Date
    May 2011
    Posts
    8
    Quote Originally Posted by knopper View Post
    Which graphics chipset do you have?
    NVidia GeForce FX 5200 -- knoppix 3d does not work.

    When I try to start compiz from a console I get:

    FATAL: No composite extension

  6. #6
    Junior Member
    Join Date
    May 2011
    Posts
    8
    UPDATE

    7.0.2 DVD downloaded U.S. server -- no compiz, no connection.
    7.0.3 DVD purchased OSDisk.com -- no compiz, no connection.
    7.0.4 DVD downloaded German server -- no compiz, no connection.

    However, this morning I downloaded the 7.0.4 CD and it works perfectly. Compiz comes up and the connection is automatic.

    Something on the DVD is different from the CD.

  7. #7
    Junior Member
    Join Date
    May 2011
    Posts
    8
    Well, that 7.0.4 CD worked exactly ONCE back in August. It hasn't worked since and I've tried almost daily. I have no connection, no audio and limited graphics.

    I have a working Debian testing where I added the proprietary drivers last year. Unfortunately I don't remember what I did. It works perfectly and shows the following cards and drivers:

    Graphics: Card NVIDIA C51G [GeForce 6100] X.org 2) Res: 80x24 Gfx Data: N/A for root
    Audio: Card NVIDIA MCP51 AC97 Audio Controller driver snd_intel8x0 at ports dc00 d800 BusID: 00:10.2
    Network: Card NVIDIA MCP51 Ethernet Controller driver forcedeth at port d400 BusID: 00:14.0

    How can install the proper drivers in Knoppix?

    And why in the world did the CD work only once?

  8. #8
    Junior Member registered user
    Join Date
    Dec 2002
    Location
    Germany
    Posts
    22
    Quote Originally Posted by Mark_Twain View Post
    Well, that 7.0.4 CD worked exactly ONCE back in August. It hasn't worked since and I've tried almost daily. I have no connection, no audio and limited graphics.

    I have a working Debian testing where I added the proprietary drivers last year. Unfortunately I don't remember what I did. It works perfectly and shows the following cards and drivers:

    Graphics: Card NVIDIA C51G [GeForce 6100] X.org 2) Res: 80x24 Gfx Data: N/A for root
    Audio: Card NVIDIA MCP51 AC97 Audio Controller driver snd_intel8x0 at ports dc00 d800 BusID: 00:10.2
    Network: Card NVIDIA MCP51 Ethernet Controller driver forcedeth at port d400 BusID: 00:14.0

    How can install the proper drivers in Knoppix?

    And why in the world did the CD work only once?
    It seems your graphics card does not work well with free drivers, so I would suggest to disable accellerated graphics ad use framebuffer or non-3d mode. I'm not convinced that the proprietary drivers behave stable, I would try to avoid them. NVIDIA has always been "problem hardware".

    knoppix no3d
    or
    fb1024x768

    will turn off composite and acellerated mode, and use the 2D window manager.

    I have no idea why your audio and network isn't working. The onboard intel soundcard is completely independent from your graphics card, and all recent network and wifi adapters should be supported by a recent kernel. Also, there is no natural explanation for a case of the CD working "just once". Neither the CD content, nor your computer hardware can be "changed" by software only. If you find out what happened, please let me know!

    Regards
    -Klaus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


DATTO-1000 Micro Server 8GB RAM picture

DATTO-1000 Micro Server 8GB RAM

$110.00



Supermicro 847BE1C-R1K28LPB 4U 36-Bay Server Chassis 12Gbs SAS3-846EL1 w/ Rail picture

Supermicro 847BE1C-R1K28LPB 4U 36-Bay Server Chassis 12Gbs SAS3-846EL1 w/ Rail

$799.00



HPE ProLiant MicroServer Gen10 AMD Opteron X3216 8GB RAM No HDDs picture

HPE ProLiant MicroServer Gen10 AMD Opteron X3216 8GB RAM No HDDs

$575.00



HPE ProLiant MicroServer Gen10 AMD Opteron X3216 8GB RAM No HDDs picture

HPE ProLiant MicroServer Gen10 AMD Opteron X3216 8GB RAM No HDDs

$400.00



HPE microserver Gen8 Update Firmware iLO4 + BIOS System Latest HP Server FAST⚡️✅ picture

HPE microserver Gen8 Update Firmware iLO4 + BIOS System Latest HP Server FAST⚡️✅

$99.99



HPE P16006-001 ProLiant MicroServer Gen10 Plus Server E-2224 16GB MicroSever picture

HPE P16006-001 ProLiant MicroServer Gen10 Plus Server E-2224 16GB MicroSever

$769.99



HP Proliant MicroServer Gen8 XeonDC 2.3GHz B Grade NO HD 8GB DDR3 picture

HP Proliant MicroServer Gen8 XeonDC 2.3GHz B Grade NO HD 8GB DDR3

$249.99



DATTO-1000 Micro Server 8GB RAM 500GB HHD picture

DATTO-1000 Micro Server 8GB RAM 500GB HHD

$175.00



HP ProLiant MicroServer AMD Turion II Neo N40L 4GB RAM  picture

HP ProLiant MicroServer AMD Turion II Neo N40L 4GB RAM

$120.00



HP Proliant MicroServer Gen8 XeonDC 2.3GHz 8GB DDR3 NO HDD Working picture

HP Proliant MicroServer Gen8 XeonDC 2.3GHz 8GB DDR3 NO HDD Working

$269.99