Results 1 to 3 of 3

Thread: How do I adjust screen brightness, & use power management?

  1. #1

    How do I adjust screen brightness, & use power management?

    Hi folks

    1. i) I've got knoppix distro 7.0.2, kernel release 3.3.7, on hard disk.

    ii) I use LXDE (Lightweight X Desktop).

    iii) and have an Acer Aspire 5750 laptop.

    2. I'd like to
    a) Be able to adjust screen brightness.
    b) Use the power management system to preserve battery power etc.

    But at the moment I can't do either. (In Windows 7, both work fine).

    3. Re 2.a):
    To increase screen brightness with the keyboard, you press Fn+<right-arrow>
    (left-arrow to decrease it). But nothing happens. ("Fn" is an actual key (in
    blue)).

    Could you tell me how to get it working please?

    I also tried using "xbacklight -set nn" at a terminal (where nn is the
    brightness level). The setting value DOES alter, but it doesn't change the
    brightness of the screen. Is this command supposed to work? If so, could you
    tell me what's wrong?

    4. Re 2.b):
    To call up Power Management, I select Kmenu/Preferences/SystemSettings then
    select Hardware/PowerManagement. The settings are displayed but the window is
    greyed (and you can't change anything), and there is a red square with a white
    "X" in it, and under it it says

    "Power Management configuration module could not be loaded. The Power
    Management Service appears not to be running. This can be solved by starting or
    scheduling it inside 'Startup and Shutdown'".

    5. So in SystemSettings I selected
    SystemAdministration/Startup&Shutdown/ServiceManager. I saw that under Startup
    Services, "Power Management" was ticked (under the "Use" column), but under the
    "Status" column it said "Not running". (Actually, ALL the entries in Startup
    Services said "Not running" in the "Status" column, even though they were all
    ticked under "Use").

    6. I changed the "Status" of Power Management to "Running", then went back into
    SystemSettings/Hardware/PowerManagement. NOW, its window was active, and I
    could change the settings. But ...

    ... Under "Power Profiles", there is a "Display Brightness" slider, but even
    though it was ticked, the brightness DIDN'T CHANGE when I repositioned the
    slider and clicked "Apply". Do you know why this is?

    Also, do you know why the "Advanced Battery Settings" tab was greyed (under
    Global Settings)?

    7. In ../PowerManagement/GlobalSettings/Settings&Profile/ProfileAssignment,
    there are 4 entries, ie:
    a) When AC Adaptor is plugged in
    b) When AC Adaptor is unplugged
    c) When battery is at low level
    d) When battery is at warning level

    Do you know why for "a)" there is only ONE setting offered (ie "Performance")?

    Also there are NO settings offered for b),c),d). Why is this?

    8. When I rebooted, and re-entered ../SystemSettings/Hardware/PowerManagement,
    it's window was greyed out again (as in 4. above). What is the fix for stopping
    this happenning?

    In KDE, PowerManagement WASN'T greyed out (whereas in LXDE it was). Why is
    this?
    However, in KDE the "Advanced Battery Settings" tab WAS still greyed out.

    Also in KDE (immediately after a boot) in
    SystemSettings/SystemAdministration/Startup&Shutdown/SERVICEMANAGER, under
    Startup Services, "Power Management" was "RUNNING". In fact ALL the entries in
    Startup Services were "RUNNING".) Why is this the case with KDE but not LXDE?

    Sorry for the level of detail.

    Your kind help with my questions would be most welcome. Thanks, John.

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, John

    Just ran across the brightness problem on my laptop.
    xbacklight -dec 30 works for me.

    See man xbacklight for other choices.

    Cheers.
    Last edited by utu; 11-18-2014 at 05:24 AM.

  3. #3
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631

    ps, FWIW:

    .
    Fn-Alt-F4 & Fn-Alt-F5 control backlight brightness down & up,
    respectively, on Win7 & Win8 Dell Inspiron laptops.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •