Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Knoppix CeBIT Edition 7.1

  1. #11
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    656
    2 months and still no Knoppix 7.1 community distro... any ETA to share with us ?

  2. #12
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, Gilles.

    Klaus K is still struggling with a PCManFM problem in CeBIT 7.1.
    If you have a solution for that, it would help get the Community Version out.

    As I understand it, a mouse-over of a desktop icon ( in the CeBIT version)
    causes an automatic click to open unless a double-click to open option is in force.

    Werner or Klaus2008 may be able to explain this more clearly, I don't have
    the CeBIT version, myself.

    Regards.

  3. #13
    Moderator Moderator
    Join Date
    Mar 2004
    Location
    Menlo Park, California
    Posts
    656
    Hi Utu,
    I just tried Knoppix CeBIT 7.1 as a VMware guest (booting from the iso without customization)
    and I can see that just moving the mouse over the "KNOPPIX" folder (without any button pressed)
    does actually select that folder as if the button was pressed before moving over that desktop icon.
    But it does not open the folder content (as if you would click on that desktop folder icon).
    As expected a click on the folder icon does open the folder content.
    Not sure why this is a big deal anyway.

    In my slightly customized setup I disabled the single click and the problem is gone:
    in the [config] section of the file: ~knoppix/.config/libfm/libfm.conf
    change "single_click=1" to "single_click=0"

    I understand that for some user the need for a double click may be a problem
    but this can always be improved/solved in a later release and my guess is that
    a lot of Knoppix users would be very happy to see a Knoppix 7.1 Community version
    released sooner than later (even with a double click as a default) since not
    everybody can have access to the Knoppix CeBIT 7.1version.
    My two cents,
    Gilles

  4. #14
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    I don't believe PCManFM's problem is the only problem within V7.1. If I look for possibly problems, I'll get this list. In comparison, within V7.0.5 are no problems reported by kn-what.sh.
    Code:
    Desired=Unknown/Install/Remove/Purge/Hold      
    |  Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend    
    |/  Err?=(none)/Reinst-required    (Status,Err:
    ||/  Name    Version
       
    hi  artwiz-cursor    1:1.3-2knoppix1
    hi  egoboo    1:2.8.1-2knoppix1
    hi  egoboo-data    1:2.8.1-2knoppix1
    hi  gnome-orca    3.4.2-2
    pi  kdebase-workspace    4:4.8.4-6
    hi  libfm-data    1.1.0-1knoppix
    hi  libfm-dev    1.1.0-1knoppix
    hi  libfm-gtk-bin    1.1.0-1knoppix
    hi  libfm-gtk1    1.1.0-1knoppix
    hi  libfm1    1.1.0-1knoppix
    pi  libkutils4    4:4.8.4-4
    pi  libnspr4-0d:i386    2:4.9.4-2
    pi  libnss3-1d:i386    2:3.13.6-2
    hi  lxsession    0.4.6.1-4knoppix
    pi  module-init-tools    9-2
    hi  ntfs-3g    2:2012.1.15AR.8-2knoppix0
    hi  pcmanfm    1.1.0-1knoppix
    pi  python-aptdaemon-gtk    0.45-1
    pi  python-gobject    3.2.2-1
    hi  speech-dispatcher    0.7.1-6.2
    hi  testdisk    1:6.14-0knoppix1
    hi  wpasupplicant-gnutls    1.0-4knoppix2
    hi  xfonts-artwiz    1:1.3-2knoppix1

  5. #15
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Quote Originally Posted by Werner P. Schulz View Post
    I don't believe PCManFM's problem is the only problem within V7.1. If I look for possibly problems, I'll get this list. In comparison, within V7.0.5 are no problems reported by kn-what.sh....
    This list contains many packages in common with 7.0.5, which does not have this problem.
    Also, 'pi' and 'hi' mean what?

  6. #16
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Some packages have the same version, some are newer.

    hi => Hold/Inst
    pi => Purge/Inst

    Code:
    Desired=Unknown/Install/Remove/Purge/Hold      
    |  Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend    
    |/  Err?=(none)/Reinst-required    (Status,Err:
    ||/  Name    Version
    
        Knoppix V7.1                          Knoppix V7.0.5
    hi  artwiz-cursor 1:1.3-2knoppix1       | artwiz-cursor 1:1.3-2knoppix1
    hi  egoboo 1:2.8.1-2knoppix1            | egoboo 1:2.8.1-2knoppix1
    hi  egoboo-data 1:2.8.1-2knoppix1       | egoboo-data 1:2.8.1-2knoppix1
    hi  gnome-orca 3.4.2-2                  > gnome-orca 2.30.2-2
    pi  kdebase-workspace 4:4.8.4-6         > kde-workspace 4:4.7.4-2
    hi  libfm-data 1.1.0-1knoppix           | libfm-data 1.1.0-1knoppix
    hi  libfm-dev 1.1.0-1knoppix            | libfm-dev 1.1.0-1knoppix
    hi  libfm-gtk-bin 1.1.0-1knoppix        | libfm-gtk-bin 1.1.0-1knoppix
    hi  libfm-gtk1 1.1.0-1knoppix           | libfm-gtk1 1.1.0-1knoppix
    hi  libfm1 1.1.0-1knoppix               | libfm1 1.1.0-1knoppix
    pi  libkutils4 4:4.8.4-4                > libkutils4 4:4.8.4-3
    pi  libnspr4-0d:i386 2:4.9.4-2          > libnspr4-0d 2:4.9.3-1
    pi  libnss3-1d:i386 2:3.13.6-2          > libnss3-1d 2:3.13.5-1
    hi  lxsession 0.4.6.1-4knoppix          | lxsession 0.4.6.1-4knoppix
    pi  module-init-tools 9-2               > module-init-tools 8-2
    hi  ntfs-3g 2:2012.1.15AR.8-2knoppix0   > ntfs-3g 1:2012.1.15AR.5-2knoppix
    hi  pcmanfm 1.1.0-1knoppix              | pcmanfm 1.1.0-1knoppix
    pi  python-aptdaemon-gtk 0.45-1         | python-aptdaemon-gtk 0.45-1
    pi  python-gobject 3.2.2-1              | python-gobject 3.2.2-1
    hi  speech-dispatcher 0.7.1-6.2         > speech-dispatcher 0.7.1-6.1
    hi  testdisk 1:6.14-0knoppix1           | testdisk 1:6.14-0knoppix1
    hi  wpasupplicant-gnutls 1.0-4knoppix2  | wpasupplicant-gnutls 1.0-4knoppix2
    hi  xfonts-artwiz 1:1.3-2knoppix1       | xfonts-artwiz 1:1.3-2knoppix1

  7. #17
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    If I run aptitude for the first time within Knoppix V7.1, I'll get this screen; in comparison there are no error messages from aptitude within V7.0.5

    aptitude_71..png

  8. #18
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Greetings, Werner.

    What happens if you try to upgrade the 17 broken packages from
    "unstable" manually using

    sudo apt-get install -t unstable packagename?

  9. #19
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    In the next days Debian testing will become stable and all within '/etc/apt/sources.lst' must be changed. Therefore at present it makes little sense to look what happens using "-t testing" versus "-t unstable". I believe, KK is also waiting until Debian Wheezy will be "stable".

  10. #20
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Quote Originally Posted by Werner P. Schulz View Post
    I believe, KK is also waiting until Debian Wheezy will be "stable".
    I think you are right, and this may change Aptitude's assessment.
    Broken packages is not a popular theory with _some_ developers.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •