Results 1 to 3 of 3

Thread: Knoppix 7.2 LiveUSB lxpanel doesn't appear initially

  1. #1
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631

    Knoppix 7.2 LiveUSB lxpanel doesn't appear initially

    .
    I have this one small problem with the Knoppix 7.2 LiveUSB which
    I made from a 'standard' 32-bit Knoppix LiveCD.

    I alway change from Klaus K's desktop background image to one of my own choosing,
    using a right-click and the LXDE desktop pop-up applet to point to a jpg image
    I have placed in /mnt-system. These changes are recorded in the persistence file
    and work ok in all except in one regard, as follows.

    If I've not made any desktop background changes, then I have a working lxpanel
    at the bottom of my LiveUSB desktop screen after Knoppix boots up. Once I've
    arranged for a different desktop background, the lxpanel does not initially appear,
    but will appear with a right-click at the lower-left edge of the desktop and
    the lxpanel will henceforth behave correctly. Every boot-up, I have to 'activate'
    my missing lxpanel with a right-click in its vicinity.

    I would like to know how to either avoid this effect or to overcome it with
    some neat snippet of code somewhere. Any help or explanation would be welcome.

  2. #2
    Senior Member registered user
    Join Date
    Dec 2008
    Location
    Mysore, India
    Posts
    252
    It is because some codes are not drawn on the Display Monitor. The system draws on the Display by GTK human-readable format, not binary.

    I know that you are aware about this, you are a pretty learned person in coding and system, but I am writing keeping newbies in view.

    To cut the long story short, load Compiz Fusion Icon from the start-menu --> system to find the icon on the bottom left panel. Right click on the icon, and left click Reload Windows Manager. Your panel should be drawn right.

    Sorry for the late reply
    Last edited by rajibando; 04-24-2015 at 11:05 AM.

  3. #3
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Thanks for your reply rajib.

    I've since moved on to Knoppix 7.4.2 and no longer have this problem.

    It's good that you've made this note for some Knoppixers that must
    use 7.2 for one reason or another, such as graphics driver availability.

    My graphics are plain old Intel as you can see:
    Code:
    knoppix@Microknoppix:~$ inxi -G
    Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
               Display Server: X.Org 1.16.0 drivers: intel (unloaded: fbdev,vesa)
               Resolution: 1366x768@59.97hz
               GLX Renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2
               GLX Version: 2.1 Mesa 10.2.4
    Best Regards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •