Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Flash Player no longer Directly Supports Linux

  1. #1
    Junior Member AussiePete's Avatar
    Join Date
    May 2013
    Location
    Sydney, Australia
    Posts
    18

    Flash Player no longer Directly Supports Linux

    Introduction:As of flash player >11.2 adobe will no longer be producing a stand-alone version for Linux or Mac computers. Instead, users will have to install Google Chrome which contains flash as an extension called "Pepper Flash", or alternatively a version of Pepper-Flash that has been extracted from Google Chrome by other means.

    This has created problems which I will explain below.My OS set-up:I have Knoppix 7.2 installed on a 8Gb memory stick with a knoppix-data.img of 3.4Gb. My browser is Chromium Version 31.0.1650.63 (not Google Chrome). The Flash-player version 11.2 (last stand alone version)

    Problem:One of my favourite web sites has just started streaming videos using flash-player ver 11.7 which has forced me to install pepper-flash. However, when I attempt to install the file (pepperflashplugin-nonfree 1.2) using Synaptic Package Manager I receive an error telling me the package is broken.

    On trying fix the package I get the following errors:
    E: Unable to correct problems, you have held broken packages.
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependenciesI've tried using other package managers but receive the same message.

    I've been able to download the file (pepperflashplugin-nonfree_1.2.tar.gz) from the Debian web site but it is in the format (*tar.gz) which I am unable to install. An ulternative would be to install Google Chrome but I only want to do this as a last resort. So I am left with the other 2 methods of the broken package or a file I don't know how to install.

    Help!
    Last edited by Werner P. Schulz; 01-11-2014 at 01:19 PM. Reason: formatted by mod

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    I've tried using other package managers but receive the same message.
    I would suggest that you close Synaptic Package Manager and open an LXTerminal. Issue the following commands and describe which packages raise problems.
    Code:
    sudo apt-get update
    sudo apt-get install pepperflashplugin-nonfree

  3. #3
    Junior Member AussiePete's Avatar
    Join Date
    May 2013
    Location
    Sydney, Australia
    Posts
    18
    Hi klaus,Thank you for your prompt reply. I did try from the command line before, this is what I get:
    Code:
    root@Microknoppix:/home/knoppix# sudo apt-get install pepperflashplugin-nonfree
    Reading package lists... Done
    Building dependency tree        
    Reading state information... Done
    Some packages could not be installed. 
    This may mean that you have requested 
    an impossible situation or if you are using 
    the unstable distribution that some required 
    packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies: 
    pepperflashplugin-nonfree :
    Depends: libpango-1.0-0 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    The problem seems to be with "libpango-1.0-0", I have a sneaky suspicion it conflicts with a similar package call "libpango1.0-0" but this is just a guess on my part.




    -------------------------------------
    You can use the "Go Advanced" button to have more abilities to format the posting; before sending your posting use "Preview" to see how it looks like.

    If "noscript" (within Iceweasel/Firefox) is active for http://knoppix.net/forum/ disable it for this website; otherwise you cannot use the format abilities.
    wps
    Last edited by Werner P. Schulz; 01-11-2014 at 04:38 PM. Reason: formatted by mod

  4. #4
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    I think the next attempt could be
    Code:
    sudo apt-get update
    sudo apt-get -f install
    You have to read the messages carefully because sometimes the package management software wants to remove packages which are essential for your work.

    If everything went well you could try
    Code:
    sudo apt-get install pepperflashplugin-nonfree libpango-1.0-0
    Most probably apt-get will tell you why it cannot install libpango-1.0-0.

  5. #5
    Junior Member AussiePete's Avatar
    Join Date
    May 2013
    Location
    Sydney, Australia
    Posts
    18
    Klaus,
    Thanks again for replying. I had already done your first recommendation, namely:
    Code:
    sudo apt-get updatesudo 
    
    apt-get -f install
    I have just carried out your second step and received the following message:
    Code:
    root@Microknoppix:/home/knoppix# sudo apt-get install pepperflashplugin-nonfree libpango-1.0-0
    Reading package lists... 
    DoneBuilding dependency tree Reading state information... 
    DoneSome packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.The following information may help to resolve the situation:
    The following packages have unmet dependencies: 
    libpango-1.0-0 : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is to be installed 
    Breaks: libpango1.0-0 (< 1.32.5-2) but 1.30.0-1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    I'm not 100% sure what the above means. I presume the following dependencies/upgrades are required:
    force upgrade to: libglib2.0-0 ver 2.36 (testing)
    force upgrade to: libpango1.0-0 ver 1.36.0-1 +b2 (testing).

    Please let me know if I am to proceed with the above?

    One other thing, I previously tried to install "libpango-1.0-0" from the Synaptic Package Manager but it told me a whole list of major packages would be remove such as AbiWord and Chromium, so immediately aborted the installation!!!

    Thanks,

    Peter

  6. #6
    I don't know if this will help you, but I know Aptitude suggests removing Adriane-x and several of its dependencies when I try upgrading Libpango. Assuming you don't need accessibility software, marking ariane-x and its dependencies as automatically installed and allowing aptitude(or another package manager) to remove them as "no longer needed" might resolve whatever issue prevents you from upgarding libpango, and by extension pepperflash. o

  7. #7
    Junior Member AussiePete's Avatar
    Join Date
    May 2013
    Location
    Sydney, Australia
    Posts
    18
    Jeffery,
    Thanks for you reply. I removed ariane-x which also removed ariane and then tried to install libpango-1.0-0 with the same problem as before. There is another file called libpango1.0-0 whith exactly the same funsions. I tried to remove this file, but as I mesioned in another post it wanted to remove other packages such as Abiword and chrome, so I aborted.
    Thanks anyway!

  8. #8
    ^Considering how stripped down my Adriane Knoppix Install is, I suppose I shouldn't be surprised that you would have packages installed that a package manager would want to purge to allow the upgrade. Anyways, I think I have found a solution, though it might be riskier than you want to risk: in the file /etc/apt/apt.conf.d/00knoppix the second line sets the default release to Debian Wheezy in Knoppix 7.2.0. Apparently, this prevents a sizeable number of packages from being marked as upgradable by Aptitude(and persumably other apt frontends). Before commenting out this line, Aptitude only showed 10 packages as upgradable(5 of them being libpango related) and all of its resolution suggestions either gutted what I need to do web browsing(Adriane-x, gnome-orca, iceweasel, theirr dependencies) or cancelled the libpango upgrade. Commenting out this line caused Aptitude to show 400+ packages as upgradable, and while most of its resolution suggestions for trying to upgrade libpango still wanted me to gut my web browsing, it eventually gave me one what only involved upgrading installed packages or installing new packages. I upgraded libpango, uncommented the default release line, and now Aptitude is showing only 5 upgradable packages, nothing libpango related among them, and best I can tell, nothing has borken, but then again, Iceweasel is the only reason I ever leave text-only mode. On my test machine, I tried upgrading all of the newly marked as upgrable packages and lost sound halfway through the upgrade, so I would recommend caution with any software upgrades made visible by commenting out the default release line in /etc/apt/apt.conf.d/00knoppix. e

  9. #9
    Junior Member AussiePete's Avatar
    Join Date
    May 2013
    Location
    Sydney, Australia
    Posts
    18
    Jeffery,
    Thank again for your help. My system doesn't contain a file called 00Knoppix. The only files in this directory are '10Periodic' and '99Synaptic'. However, I assume the following is a related file for package sources '/etc/apt/sources.list' which is shown below:
    Code:
    # Debian/Squeeze is the stable base for this installation
    deb ftp://ftp.de.debian.org/debian/ stable main contrib non-free
    deb http://security.debian.org stable/updates main contrib non-free
    
    # testing/unstable/experimental contain newer versions, but
    # packages from there are not being installed by default, unless
    # they came from there in the first place.
    deb ftp://ftp.de.debian.org/debian/ testing main contrib non-free
    deb http://security.debian.org testing/updates main contrib non-free
    deb ftp://ftp.de.debian.org/debian/ unstable main contrib non-free
    deb http://ftp.de.debian.org/debian experimental main contrib non-free
    
    # Debian/volatile contains quickly changing data like spam- and virusfilter databases
    # Does not exist anymore
    # deb http://volatile.debian.org/debian-volatile stable/volatile main contrib non-free
    deb http://ftp.de.debian.org/debian stable-updates main contrib non-free
    
    # Knoppix repository
    deb http://debian-knoppix.alioth.debian.org ./
    
    # x2go
    # deb http://x2go.obviously-nice.de/deb/ lenny main
    # deb http://packages.x2go.org/debian squeeze main
    deb http://packages.x2go.org/debian wheezy main
    deb http://packages.x2go.org/debian sid main
    
    # Debian Multimedia, contains non-free software like acrobat reader
    # deb http://www.deb-multimedia.org squeeze main non-free
    deb http://http.us.debian.org/debian/ wheezy contrib non-free main
    Actually I altered the above file some time ago replacing 'squeezy' with 'wheezy' due to another unrelated problem. So if I understand things correctly, I am already down loading 'wheezy' updates. However, I use Synaptic Package installer which seems to have a mind of its own so I am not sure what it is downloading, although there are some squeezy versions among the updates.
    I've basically made very few changes to the standard Knoppix 7.2 system, apart from adding Chromium and a few other minor programs, such as package installers, as well as installing very few updates except for the packages I use. I'm running on a memory stick so have very little space left in the knoppix-dada.img file.
    Thank anyway,
    Peter

  10. #10
    Junior Member
    Join Date
    Jan 2014
    Posts
    1
    I upgraded libpango, uncommented the default release line, and now Aptitude is showing only 5 upgradable packages, nothing libpango related among them, and best I can tell, nothing has borken, but then again, Iceweasel is the only reason I ever leave text-only mode.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •