Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Dual Boot question....

  1. #21
    Moderator Moderator
    Join Date
    Nov 2010
    Germany/ Dietzenbach
    It's hard to see what's going wrong within your different grub without direct access to your computer.

    • Start your new installation
    • Open (as root) the file '/boot/grub/menu.lst
    • Append in the "title" line: (started from new install)
    • Open the file '/etc/fstab' and look for the other Knoppix installation; in my example:

    # Added by Knoppix
    /dev/sdb2 /media/sdb2
    • Open (as root) the file '/media/sdbX/boot/grub/menu.lst'
    • Append in the "title" line: (presumable old install)
    • Notice all the root points (hd...) to paper
    • Start your presumable old installation
    • Can you see within the "title" line the entry: (presumable old install)?

  2. #22
    OK, I tried to open '/boot/grub/menu.lst' and I am getting "Permission Denied" with no explanation. Same with the file'/etc/fstab'. If I try to open the 'media/boot/sdb1/grub/menu.lst' which is the file on the old program I get "no such file or directory"Which doesn't make sense unless I am not getting the command right, and that is both as Root.I also tried the 'sdbX' entry just to see if it would be different, but it came back with the same output. I have actually never had that happen before. If I use 'su' in the command line then I get 'no password entry for user. Since I have never had to use the password entry, I was of the thought that it would default to 'microknoppix' as the password but haven't tried it because I am not really familiar with the syntax for the use of the password in the command as yet and my installation is straight forward default installation. I didn't install it with any special information when I installed it. It should be a straight up default installation. I made sure that all of my drives were linked too, when I was trying the file on the old installation, so that wasn't a factor.

    Any idea why when I do boot up the old program I get it with no internet connection? It doesn't boot with any of the usual system settings. I am copying the entry for the new system boot grub exactly except the drive, and don't really know if that information is right for the old drive, but, it does send the computer at the old installation, just without the system settings that are normally available.
    Last edited by E-Tramp; 06-03-2014 at 03:48 AM.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts