Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Dual Boot question....

  1. #11
    What about the lines:
    title Windows
    rootnoverify (hd2,3)
    chainloader +1

    Are these necessary or can they be deieted, since no Windows programming is on this computer?

  2. #12
    Also I put the entry on the grub with mcedit/boot/grub/menu.lst like you said, and hit save at the bottom, verified save, and then quit the grub editor. The entry didn't show on the menu when I restarted the computer. Did I do something wrong?

  3. #13
    Moderator Moderator
    Join Date
    Nov 2010
    Germany/ Dietzenbach
    You can delete the three lines of Windows entry. After this tell us the output of
    cat /boot/grub/menu.lst

  4. #14
    This is what it shows:

    knoppix@Microknoppix:~$ cat /boot/grub/menu.lst
    default 0
    timeout 30
    color cyan/blue white/blue

    title KNOPPIX
    root (hd1,1)
    kernel /boot/vmlinuz root=/dev/sdb2 rootwait lang= apm=power-off nomce libata.force=noncq tz=localtime loglevel=1 rw

    Title KNOPPIX old installation
    root (hd1,0)
    kernal /boot/vmlinuz root=/dev/sdb1 rootwait lang= apm=power-off nomce libata.force=noncq tz=localtime loglevel=1 rw

    I am wondering if maybe there are two grub installations and the one that is in booting is different than the one that is being edited. Is this a possibility?

    After I installed the new program, I couldn't boot it until I did a repair on the grub that directed it to the new one and deleted the grub entry for the old one. What if the one we are editing is a different grub instance?

  5. #15
    Moderator Moderator
    Join Date
    Nov 2010
    Germany/ Dietzenbach
    Yes it looks like you are booting with grub from the old installation and therefore you see the grub menü from the old one.
    To install grub from the new installation at 'dev/sdb2' within the MBR of '/dev/sda' try
    root (hd1,1)
    setup (hd0)

  6. #16
    This is what I got when I did that:

    GNU GRUB version 0.97 (640K lower / 3072K upper memory)

    [ Minimal BASH-like line editing is supported. For
    the first word, TAB lists possible command
    completions. Anywhere else TAB lists the possible
    completions of a device/filename. ]

    grub> root (hd1,1)
    Filesystem type is reiserfs, partition type 0x83

    grub> setup (hd0)
    Checking if "/boot/grub/stage1" exists... yes
    Checking if "/boot/grub/stage2" exists... yes
    Checking if "/boot/grub/reiserfs_stage1_5" exists... yes
    Running "embed /boot/grub/reiserfs_stage1_5 (hd0)"... failed (this is not fata
    Running "embed /boot/grub/reiserfs_stage1_5 (hd1,1)"... failed (this is not fa
    Running "install /boot/grub/stage1 d (hd0) /boot/grub/stage2 p /boot/grub/menu
    .lst "... succeeded

    grub> root (hd1,1)

    Will check reboot and see what it accomplished.

  7. #17
    Still only getting one boot option for the new system boot. There has to be a way to edit the old grub istallation to access the old operating system.

  8. #18
    Come on people there has to be a way for me to edit the grub menu it is booting to, and to clear this one so there is only one grub. One of you guys must have the answer to this.

  9. #19
    OK, here is what I have managed to do on my own. It occured to me that I might be able to edit the grub as the system was booting up, so I hit the e key as the grub was displaying and went into the grub, and created a new listing for the old programming. Using the information from the new operating system, I typed up the new entry editing it so it directed the computer at the first partition. I hit F10 and the computer booted into the old operation system, but, without an active internet connection for some reason. Anyway, after I was booted into it, I started mcedit, and to my great surprise there were no existing entries in the grub that mcedit brought up. Appearantly the drive actually has three different grubs, and none of the os's are directed at the one that is currently booting the system up with. I tried editing the blank one in the old operating system and when I rebooted the computer the grub that boots the system remains unchanged and the system is still not able to edit it from either side of the partitions. Appearantly when I used the grub repair tool to change the grub, it just created a whole new grub and deleted the directions of the old grub leaving it inplace but not accessible to the boot process, and the new installation also created its own grub when it was installed that didn't edit the original. That is why the new system wouldn't boot from the old grub. So, now we have three grubs one that is booting and isn't editable from either of the operating systems and two that the computer can't find to use to boot with.

    Surely, there is a program that I can use that will detect all of the grub instances and give me the option of deleting those I don't want, and editing those I want to use on the systems?

    Someone have anything that will help me resolve these complications?

    Oh, and by the way, the entry I created in the bootable grub was temporary, and must be retyped each time to boot the old system.

  10. #20
    Here is some more information that I have discovered. While studying the boot files on the two OS's I found that there are some discrepencies on how the hard drives are mapped according to each program. It occurs to me that problem is that these two systems are actually seeing two different drives by definition, and this is why it isn't able to go see both. See the attached screen shot of the boot files on both programs.Screenshot from 2014-05-22 23:08:12.png

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts