Results 1 to 4 of 4

Thread: Problem installing Python (libglib2.0-dev)

  1. #1

    Problem installing Python (libglib2.0-dev)

    I am having some trouble installing Python.



    knoppix@Microknoppix:~$ sudo apt-get install python3.4
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    librrd4 ntop-data python-mako python-markupsafe
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    libdb5.3 libmpdec2 libpython3.4-minimal libpython3.4-stdlib
    python3.4-minimal
    Suggested packages:
    python3.4-venv python3.4-doc
    The following NEW packages will be installed:
    libdb5.3 libmpdec2 libpython3.4-minimal libpython3.4-stdlib python3.4
    python3.4-minimal
    0 upgraded, 6 newly installed, 0 to remove and 488 not upgraded.
    1 not fully installed or removed.
    Need to get 4,804 kB of archives.
    After this operation, 19.0 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://ftp.de.debian.org/debian/ testing/main libdb5.3 i386 5.3.28-3 [662 kB]
    Get:2 http://ftp.de.debian.org/debian/ testing/main libmpdec2 i386 2.4.0-6 [76.4 kB]
    Get:3 http://ftp.de.debian.org/debian/ unstable/main libpython3.4-minimal i386 3.4.1-6 [484 kB]
    Get:4 http://ftp.de.debian.org/debian/ unstable/main libpython3.4-stdlib i386 3.4.1-6 [2,018 kB]
    Get:5 http://ftp.de.debian.org/debian/ unstable/main python3.4-minimal i386 3.4.1-6 [1,366 kB]
    Get:6 http://ftp.de.debian.org/debian/ unstable/main python3.4 i386 3.4.1-6 [198 kB]
    Fetched 4,804 kB in 7s (621 kB/s)
    Selecting previously unselected package libdb5.3:i386.
    (Reading database ... 459131 files and directories currently installed.)
    Unpacking libdb5.3:i386 (from .../libdb5.3_5.3.28-3_i386.deb) ...
    Selecting previously unselected package libmpdec2:i386.
    Unpacking libmpdec2:i386 (from .../libmpdec2_2.4.0-6_i386.deb) ...
    Selecting previously unselected package libpython3.4-minimal:i386.
    Unpacking libpython3.4-minimal:i386 (from .../libpython3.4-minimal_3.4.1-6_i386.deb) ...
    Selecting previously unselected package libpython3.4-stdlib:i386.
    Unpacking libpython3.4-stdlib:i386 (from .../libpython3.4-stdlib_3.4.1-6_i386.deb) ...
    Selecting previously unselected package python3.4-minimal.
    Unpacking python3.4-minimal (from .../python3.4-minimal_3.4.1-6_i386.deb) ...
    Selecting previously unselected package python3.4.
    Unpacking python3.4 (from .../python3.4_3.4.1-6_i386.deb) ...
    Processing triggers for man-db ...
    Processing triggers for menu ...
    Processing triggers for gnome-menus ...
    Processing triggers for desktop-file-utils ...
    dpkg: dependency problems prevent configuration of libglib2.0-dev:
    libglib2.0-dev depends on python:any (>= 2.6.6-7~).

    dpkg: error processing libglib2.0-dev (--configure):
    dependency problems - leaving unconfigured
    Setting up libdb5.3:i386 (5.3.28-3) ...
    Setting up libmpdec2:i386 (2.4.0-6) ...
    Setting up libpython3.4-minimal:i386 (3.4.1-6) ...
    Setting up libpython3.4-stdlib:i386 (3.4.1-6) ...
    Setting up python3.4-minimal (3.4.1-6) ...
    Setting up python3.4 (3.4.1-6) ...
    Processing triggers for menu ...
    Errors were encountered while processing:
    libglib2.0-dev
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    510
    1 not fully installed or removed.
    [ ... ]
    dpkg: dependency problems prevent configuration of libglib2.0-dev:
    libglib2.0-dev depends on python:any (>= 2.6.6-7~).
    Try
    Code:
    sudo apt-get update
    sudo apt-get -f install

  3. #3
    after sudo apt-get update


    and doing sudo apt-get -f install python, I still get the error

    knoppix@Microknoppix:~/ntopngtr2/ntopng-1.1_6932$ sudo apt-get -f install python
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    python is already the newest version.
    python set to manually installed.
    The following packages were automatically installed and are no longer required:
    librrd4 ntop-data python-mako python-markupsafe
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 486 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    dpkg: dependency problems prevent configuration of libglib2.0-dev:
    libglib2.0-dev depends on python:any (>= 2.6.6-7~).

    dpkg: error processing libglib2.0-dev (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    libglib2.0-dev
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    knoppix@Microknoppix:~/ntopngtr2/ntopng-1.1_6932$

  4. #4
    A Debian user mentioned to me that I should do amongst other things to try $apt-cache policy libc6 and see the results.

    He said I have libc6 at 2.19. That doesn't correspond to any debian release.

    And Debian doesn't take well to having unexpected versions mixed in like I have there.

    Any advice?

    knoppix@Microknoppix:~$ apt-cache policy libc6
    libc6:
    Installed: 2.17-5
    Candidate: 2.19-1
    Version table:
    2.19-1 0
    500 http://ftp.de.debian.org/debian/ testing/main i386 Packages
    500 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
    *** 2.17-5 0
    100 /var/lib/dpkg/status
    2.13-38+deb7u1 0
    990 http://ftp.de.debian.org/debian/ stable/main i386 Packages

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •