Results 1 to 5 of 5

Thread: Time problem

  1. #1

    Time problem

    I installed knoppix 7.2 on a USB and everything workds great...except it gives the wrong time. This would only be an annoyance except I need to have the correct timestamp on my files. I use multiple computers and OS's for my work and it is beneficial to know which of several is the most recent version of a file.

    I've tried using the following:

    dpkg-reconfigure tzdata

    Current default time zone: 'America/Regina'
    Local time is now: Wed Aug 13 10:40:20 CST 2014.
    Universal Time is now: Wed Aug 13 16:40:20 UTC 2014.

    Unfortunately the local time was 16:40. My actual time zone is CST so UTC-6 is correct. It seems to be acquiring the wrong UTC time.

    I then used a time server (20 minutes later)

    ntpdate -q nist1-nj2.ustiming.org
    server 165.193.126.229, stratum 1, offset 21599.700910, delay 0.09451
    13 Aug 11:00:51 ntpdate[4395]: step time server 165.193.126.229 offset 21599.700910 sec

    BTW, as I said, I'm running knoppix on a USB. When running Fedora 20 on my harddrive there are no such problems so I do not think it is a hardware problem.

    Thanks for any help someone might give.

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    You can use the cheatcode "tz=America/Regina". Take care of hint 9!

    Have also a look at Micro-Remastering at this website.

  3. #3
    The problem is that it does not set the UTC time correctly so setting "tz=America/Regina" gives me a local time for somewhere in the middle of the Pacific ocean. It so happens it sets the UTC time equal to what my local time actually happens to be. So my workaround is to set my local time=UTC. Then I get the correct local time. Weird!

  4. #4
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    The problem is that it does not set the UTC time correctly ..
    Did you read hint 9? You must set the hardware clock within BIOS to UTC manually by yourself.

  5. #5
    Senior Member
    Join Date
    Jul 2011
    Posts
    110
    I get time set via ntpdate-debian. /etc/default/ntpdate edit the line NTPSERVERS="your ntp server" Verify the ntpdate file exist in /etc/network/if-up.d Now each time your nic becomes active or up. Your time will sync. I use pool.ntp.org for correct time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


pi1541 Disk Emulator for Commodore -  picture

pi1541 Disk Emulator for Commodore -

$34.95



Commodore 64 Dead Test Cartridge v781220  picture

Commodore 64 Dead Test Cartridge v781220

$24.95



Commodore 64 SD Card Reader (SD2IEC) and Epyx Fastload Cartridge combo  C64 picture

Commodore 64 SD Card Reader (SD2IEC) and Epyx Fastload Cartridge combo  C64

$33.86



Commodore 64 Diagnostic and Board Repair Service C64 picture

Commodore 64 Diagnostic and Board Repair Service C64

$45.00



NEW Commodore 1581 Enhanced V2 and PC Drive Adapter PCB pair picture

NEW Commodore 1581 Enhanced V2 and PC Drive Adapter PCB pair

$25.95



C64 PSU - Commodore 64 Power Supply - Black, LED, Power Switch (US plug) picture

C64 PSU - Commodore 64 Power Supply - Black, LED, Power Switch (US plug)

$43.99



Commodore 64 w/ 1541 Disk Drive picture

Commodore 64 w/ 1541 Disk Drive

$185.00



Commodore 64C Personal Computer in Box w/ Cords and Manuals Tested Working READ picture

Commodore 64C Personal Computer in Box w/ Cords and Manuals Tested Working READ

$249.99



Commodore 64 decal picture

Commodore 64 decal

$2.28



Commodore PLA Replacement -- MOS 906114-01 picture

Commodore PLA Replacement -- MOS 906114-01

$13.95