Hello, I have installed KNOPPIX_V7.4.0DVD-2014-08-01 on a usb formatted as fat32 (/dev/sdb1). The drive has already a SysRescueCD installation on it, so I have uncompressed the iso to a folder KNOPPIX_V7.4.0DVD-2014-08-01-EN and I can boot Knoppix fine from syslinux and I also have a 500MB knoppix-data.img.

All works well apart from the fact that it's quite slow. So I have tried to boot the image from a copy of the iso on the Windows partition (/dev/sda2) and I boot it from syslinux like this:

LABEL knoppix64
KERNEL /KNOPPIX_V7.4.0DVD-2014-08-01-EN/boot/isolinux/linux64
INITRD /KNOPPIX_V7.4.0DVD-2014-08-01-EN/boot/isolinux/minirt.gz 
APPEND apm=power-off nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1  lang=uk bootfrom=/dev/sda2/Users/ottavio.owner-PC/Downloads/KNX.iso
However in doing so it doesn't recognize the persistent image on sdb1.

I've tried the old (deprecated) cheat code:
But it's not recognized.

Is there any way to force syslinux to load a file from sda2 but to mount the settings from sdb1?